Gr4cchus
Enthusiast
Enthusiast

vCSA 6.x Reusing password "BAD PASSWORD"

Jump to solution

When trying to update vCSA through appliance management on port 5480 the update failed as it said the password had expired. This is a lab environment so is it possible to reuse the same password. Although I have done other things so far, running passwd as root user in the shell results in this when trying to reuse the old password:

Gr4cchus_0-1633571572486.png

This article didnt seem to help either www.boche.net/blog/2011/06/27/forc-a-simple-vmware-vma-password/

 

 

 

Labels (3)
0 Kudos
1 Solution

Accepted Solutions
Gr4cchus
Enthusiast
Enthusiast

Following http://vcloud-lab.com/entries/vcenter-server/resetting-root-password-in-vmware-vcenter-server-applia... where everything is mounted, as root I followed this for guidance https://askubuntu.com/questions/113682/how-to-change-disable-password-complexity-test-when-changing-... . edit /etc/pam.d/system-password . I set minlen=6 to 1 (however this is prob redundant) which failed, then I also removed the enforce_for_root which then allowed me to use the desired password. Likely some of these steps are not necessary.

Gr4cchus_0-1633918086373.png

 

 

View solution in original post

0 Kudos
3 Replies
asajm
Expert
Expert

Hi @Gr4cchus 

Can you check these articles maybe help

Authentication Token Manipulation Error 

resetting-root-password-in-vmware-vcenter-server-appliance 

If you think your queries have been answered
Marking this response as "Solution " or "Kudo"
ASAJM
0 Kudos
Gr4cchus
Enthusiast
Enthusiast

Neither of these options sound like they are going to work as both have warnings in the article about the password and the dictionary it checks against. I think something was changed where somehow the password was originally grandfathered in and now im stuck trying to fight it.

0 Kudos
Gr4cchus
Enthusiast
Enthusiast

Following http://vcloud-lab.com/entries/vcenter-server/resetting-root-password-in-vmware-vcenter-server-applia... where everything is mounted, as root I followed this for guidance https://askubuntu.com/questions/113682/how-to-change-disable-password-complexity-test-when-changing-... . edit /etc/pam.d/system-password . I set minlen=6 to 1 (however this is prob redundant) which failed, then I also removed the enforce_for_root which then allowed me to use the desired password. Likely some of these steps are not necessary.

Gr4cchus_0-1633918086373.png

 

 

0 Kudos