VMware Cloud Community

vCSA 6.0 install failure - unable to connect to ESXi Server

I have the vCSA ISO extracted to local drive and am running it from Internet Explorer as Administrator mode. After allowing the plugin, I click Install.

I click Accept, then Next.

At this point, I am unable to proceed past 2. Connect to target server step.

This is the error code which I can not get past no matter what I try:

"Cannot connect to target server. Invalid FQDN or IP address."

I can enter FQDN, IP address, root or domain accounts and nothing works. I even tried connecting to a virtual ESXi 5.5 u2 server with nothing configured but IP address and root password.

I've tried from utility servers, and from my user workstation, no luck -> same error.

The ESXi hosts are not in lockdown mode or in maintenance mode. I've tried all of about 30 different IP addresses and FQDNs for the various ESXi 5.5 hosts.

The hosts do have new ECA-signed ssl certificates, and i thought this might be an issue, but the virtual ESXi server i deployed didn't work either, and that had the default VMware certs.

I've tried reinstalling the Client Integration 6.0 plugin, restarting workstation/utility servers.

I've tried Firefox and IE 11 but nothing appears to work.

I've verified that the FQDN or IP and username/password works when connecting via the vSphere Client so I know I'm not fat-fingering it into the setup wizard.

What gives? What am I missing? Has anyone experienced this problem? Is there a way to collect logs for this? I tried looking for them but also couldn't find anything.

Tags (3)
11 Replies

Hello Bedobash,

I had some problems with installing vCSA 6.0.

Check these settings:

- Do you have DNS records for the new vCSA server, try to resolve the FQDN before installation of vCSA.

- Do you have DNS records for the ESXI servers, try to resolve the FQDN before installation of vCSA.

- Temperary disable virus scan software on your Windows machine where you install vCSA (I had problems with Avast virus scanner on my Windows 7 machine).

- Check if you not using any 3e party firewall software on your Windows machine where you install vCSA.

After I setup my DNS correctly and disabled the Avast virusscanner the installation succeeded.

0 Kudos
Hot Shot
Hot Shot

Did you ever get past this error? I'm having the same thing going on. Deploy from OVF was sooooooo easy.

0 Kudos

Same problem, fresh 6.0 U1 deployment in lab environment.  Logs are located: C:\Users\youruser\AppData\Local\VMware\CIP\vcsaInstaller

CSD Log:

-09-29 16:01:06] [INFO] Process created: "C:\Program Files (x86)\VMware\Client Integration Plug-in 6.00\ovftool.exe" "--machineOutput" "--sourceType=OVA" "//d:/vcsa/vmware-vcsa"

[2015-09-29 16:01:14] [INFO] Request 16 - [session: session].ping: Received.

[2015-09-29 16:01:16] [INFO] Process with ID: Ag5N-X38F-OXcw-1n6Q has terminated , notifying owner

[2015-09-29 16:01:16] [ERRO] Request 17 - [fileTransfer: 8088-jT99-8gEX-Xsia].getServerType: Error Status UNKNOWN_METHOD: Unknown method name.

[2015-09-29 16:01:22] [INFO] Request 21 - [session: session].remove: Received.

[2015-09-29 16:01:22] [INFO] Stop called on web socket: 50100

[2015-09-29 16:01:22] [INFO] Web Socket Server [50100] Terminated With no error code

[2015-09-29 16:01:26] [INFO] Process exiting.


2015-09-29 16:00:48.261015 EULA Page: EULA Accepted

2015-09-29 16:01:04.567651 CIP Service: [VCSA INFO] Fetch thumbprint result:{"type":"result","statusCode":"PROCESS_STATUS","sessionId":"pXiu-Wkys-qnBl-ROFF","requestId":"11","requestComponentId":"fileTransfer","requestObjectId":"8088-jT99-8gEX-Xsia","result":"","isFinal":"true","item":["{\"data\":{\"thumbprint\":\"FA:32:D9:2D:DD:16:D1:B2:C8:AB:72:8A:DD:49:BC:1B:7F:1C:2C:7A\"}}"]}

2015-09-29 16:01:16.863438 CIP Service: [VCSA ERROR] Error fetching Target type:{"type":"error","statusCode":"UNKNOWN_METHOD","message":"Unknown method name.","isFinal":"true","sessionId":"pXiu-Wkys-qnBl-ROFF","requestId":"17","requestComponentId":"fileTransfer","requestObjectId":"8088-jT99-8gEX-Xsia"}

2015-09-29 16:01:16.864436 Target Page: [VCSA ERROR] - Error in getting target type

2015-09-29 16:01:16.865436 Target Page: Details - IP192.168.1.51 UserName: root

0 Kudos

UPDATE:  I uninstalled the previously installed VMware-ClientIntegrationPlugin-6.0.0.exe

Extracted ISO to HD

Installed Client Integration Plugin from ISO in the VCSA folder:  VMware-VCSA-all-6.0.0-3040890\vcsa\VMware-ClientIntegrationPlugin-6.0.0.exe

Ran the vcsa-setup.html

Good to go.


DNS is good, no firewall blocking, no antivirus configured.

Still unable to go any further "Cannot connect to target server. Invalid FQDN or IP address." Logs contain no further information than this.

I'm using IP address of ESXi server, and i can ping and connect to it via vSphere Client using the same login/password.

0 Kudos

Thank you Michael!

I had the same problem as described in this thread, and this was working for me.

0 Kudos

Worked for me too!

0 Kudos

Thanks a lot for this hint!

I also had the problem:

After starting vcsa-setup.html and accepting the license I was stuck at:

Validating -> Connection timed out.

I saw no connection attempt at all to the destination esxi server with wireshark / tcpdump. Even no DNS request for the FQDN.

After uninstalling the VMware Client Integration Plugin and reinstalling the version from the ISO, everything works a expected again and I am currently deploying the vCenter Server Appliance (vCSA)!

Again: Thanks a lot!

0 Kudos

Yes that´s it.

0 Kudos

Stand alone ESXI host 6.7

Okey I know I might be like 4 years late but I came here to share my experience.

After struggling for about 10 hours or something, trying to figure out how to solve this this, this is how I did it and my setup:

1x "home office" aka my own home pc and a NetGear NightHawk Router.

1x standalone Dell poweredge t30

1x fiber connection from ISP

I tried to make this as simple as possible and not spend to much time/work to configure which turned out to be a misstake.

Starting off with installing ESXI on an USB and booting from there, remoting to the host via my home computer and installing VCSA.

My major problem was the network part, It felt like no matter how much I changed config and addresses always something in my way.

The main issue was the management port not being able to finish of the appliance installation, complaining about "no contact".

* configure this with DHCP = bad idea,

* configure the DNS settings of your router = does not work.

* configure DNS to use Google's DNS = does not work.

* having your local computer (the one you're remoting from) set to IPv6 = bad idea.

So after trying to take the short cuts, this is how I did it:

* Make your you have IP adresses free to reserve in your router

* Deploy up at least one DC on your local ESXI host .Give that one a static IP in your home network, in my case the 192.168.1.X/24 range.

* configure DNS services

* create DNS record of your VCSA host, both forward and PTR record

* connect your computer directly to the router, either via wifi or ethernet. Give your computer a static IP, turn off IPv6 and set DNS server to your own DC. Make your those two can talk to each other (ping between them). Also make sure your DC has IPv6 turend off

* reserve both IP's and MAC's of your PC and DC in your router

* Now you should be able to make a nslookup on your computer to have your DC as DNS


Default Server:  yourdc.yourdomain.loc

Address:  number.number.number.number

* start the deployment of VCSA

* when you come to the network part I used this:

IP: static, set adress to one in your network range, for example in my case

FQDN: the hostname that you created a record of in the DNS

DNS: the DC that you created earlier

Gateway: Same as your home computer

Probalby not relevant anymore but felt like sharing it to you guys!

0 Kudos

Hi everyone,

I confirm ! That's works by uninstall and re-install VMware Client Integration Plugin !

0 Kudos