Spud312R
Contributor
Contributor

vApp Export OVF Template fails with VM's are in a Resource Pool

I'm wondering if what i'm doing is right/wrong ..

I have a resource pool  DEV  which i have 2 virtual sites Site1 and Site2

     In this resource pool DEV  i have 2 vApps Site 1 and Site2

          In the vApp Site1  i have another resource Pool Site1 and a number of  vm's are placed in this resource Pool

               This allows me to managed the resources of the vm's in this vApp (ie shutodown/update)separately to the root

                    Resource Pool and other vApp Site2

But when i shut down the vApp Site 1 and try to export OVF Template, i get an error

The operation is not supported on the Object

Call "OvfManager.CreateDescriptor" for object "OvfManager" on vCenter Server "vCenter Server namet" failed.

The only way i can export ovf template is by removing the Resource Pools ??

Am i mising somthing here , or am i going about managing the vApps/Resource Pools wrongly ??

regards

Paul

0 Kudos
2 Replies
esujit
Contributor
Contributor

Hi,

   I am also facing the same issue. However, you mentioned that you removed the resource pool and it worked. Could you elaborate on that.

In my setup described below, do you have any suggestions.

Thanks

I posted the below question in the vSphere forum

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Following is my setup

vCenter Server 5.0 (vCentre Server Standard license)

created one data centre

added one host ESXi 5.0  (installed vSphere Enterprise Plus license)

Created a VM installed Ubuntu desktop linux. Powered off the VM.

Created a vAPP. Added the linux VM to the vAPP.

Now I am trying to export the vAPP as a OVF template.

It fails with the following error msg

Call "OvfManager.CreateDescriptor" for object "OvfManager" on vCentre Server "xyz" failed.

Is there anything I am doing wrong ?

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

0 Kudos
bouke
Hot Shot
Hot Shot

Just had this issue too. Restarting the client didn't help, moving the VM to an other ESXi host didn't help. Moving it out of the resource pool didn't help. The one that worked though for me was to remove the VM from inventory and register it again. Works like a champ!

Cheers,

Bouke

Oh no, another Virtualisation signature...
0 Kudos