VMware Cloud Community
RUG201110141
Enthusiast
Enthusiast

unable to deploy ovf template of vSphere Management Assistant in vCenter version 4

I'm trying to deploy the vSphere Management Assistant. I've tried through the url and downloading and using the downloaded files and have had no success. I meet the hardware and software prerequisites to deploy the virtual machine. I'm trying to deploy it to a ESX 3.5 u3 host that is compatible with the hardware requirements. I get the following error: Error uploading the C:\path to ovf fle\vMA-ovf-4.0.0-161933-0.vmdk to server. Unable to write data to the transport connection: An established connection was aborted by the software in your host machine. Any ideas?

Tags (1)
Reply
0 Kudos
12 Replies
lamw
Community Manager
Community Manager

Both URL and .ISO works. Last time someone had this issue, they had a corrupted download. Please try again on either another system or browser and verify the MD5 checksum.

=========================================================================

William Lam

VMware vExpert 2009

VMware ESX/ESXi scripts and resources at:

VMware Code Central - Scripts/Sample code for Developers and Administrators

If you find this information useful, please award points for "correct" or "helpful".

Reply
0 Kudos
RUG201110141
Enthusiast
Enthusiast

downloaded the file again and checked the md5 checksum. It was the appropriate checksum so I attempted to deploy it again and it's the same issue.

Reply
0 Kudos
lamw
Community Manager
Community Manager

Have you tried to deploy vMA directly onto the ESX(i) host?

=========================================================================

William Lam

VMware vExpert 2009

VMware ESX/ESXi scripts and resources at:

VMware Code Central - Scripts/Sample code for Developers and Administrators

If you find this information useful, please award points for "correct" or "helpful".

Reply
0 Kudos
RUG201110141
Enthusiast
Enthusiast

I ended up using vmware converter to import the virtual machine into vCenter. Don't know whey I couldn't use the import feature of vCenter as of yet though.

Reply
0 Kudos
Phril
Contributor
Contributor

Using lamw's tip above, I was able to point my vSphere client direct to an esx host and choose File > Virtual Appliance > Import

Stepping through similar screens to the "Deploy OVF Template", I was able to succesfully import the .ovf file and get the VMA box running.

Reply
0 Kudos
Slack-User
Contributor
Contributor

I was seeing the same problem, and I was also able to import from the individual host as well. To me, this is not an acceptible solution. The option is there in vSphere, so it should work. Does anyone have an answer from VMware as to why this does not work and when we can expect a fix? This worked in VirtualCenter 2.5 but broke in vSphere Server.

Reply
0 Kudos
RicoRico
Contributor
Contributor

I'm seeing the same issue. Apparently it's in issue when you try to deploy an ovf template into an ESX 3.5 using VC 4 . I'm seeing the same issue also with the new ovftool provided by VMware (ovftool 1.0) Any ideas if there's something that needs to be reconfigured? My guess is that the underlying protocol used by VMware changed from VI3.5 to the one in VI 4

Reply
0 Kudos
millennia
Enthusiast
Enthusiast

Exactly the same problem. Thought the OVF was broke but thanks to this thread I managed to import directly into the host - looks like VC4/ESX3.5 compatibility is a little bit frayed Smiley Wink

Reply
0 Kudos
jefmes
Contributor
Contributor

Agreed, seeing the same issue after upgrading to vCenter 4.0 today with our 3.5U4 hosts. Once connecting VI Client directly to one of the boxes it seems to drop down to the VI 2.5 Import functionality and works fine. Maybe the upcoming first vSphere update will address this too? Smiley Wink

Reply
0 Kudos
admin
Immortal
Immortal

It certainly will. There is a bug in vCenter 4.0 when importing through vCenter to an ESX 3.0 or 3.5 host with SSL disabled. I'm guessing this is what you're seeing here.

Possible workarounds include importing directly to the host (which only works for single-VM OVFs), enabling SSL, or waiting for vCenter 4.0 update 1, which doesn't have this bug.

Reply
0 Kudos
admin
Immortal
Immortal

Enabling SSL did the trick.

To do so on vSphere4:

Go to the VI client

Administration->vCenter Server Settings -> SSL settings

mark the checkbox "vCenter requires verified host SSL certificates". You might be needing to reconnect your host(s) to the VC and provide user and password to the host(s) afterwards.

Reply
0 Kudos
alnr
Contributor
Contributor

had the same problem... aetzioni's suggestion worked for me...

thanks!

Reply
0 Kudos