JustyC
Enthusiast
Enthusiast

iSCSI Initiator Port Group Error

Jump to solution

Problem adding back in the second vmk to an existing iSCSI vSwitch.  Original config was 2 vmks - all worked successfully.  1 vmk was removed to troubleshoot network issues.

Re-created the 2nd vmk, but when moving down one of the active NICs to the Unused category as soon as OK is selected the message "This vmkernel port group contains a NIC

which is bound to an iSCSI initiator.  Changing it's settings might disrupt the connection to the iSCSI datastore" appears.  The reply options are Yes or No.  A screen print is attached.

vCenter is version 5.0 U1b.  The host is ESXi5.0 U2 and is in maintenance mode with no guests.  The host boots off local disk not the SAN.  Can I safely choose yes then go back and

make the vmnic move or is there a better way to correct this issue.  Thanks.

1 Solution

Accepted Solutions
SanjaySP1
VMware Employee
VMware Employee

Thanks for sharing the information. Please try below steps :

Step 1. Remove existing port bindings and reboot the host.

Step 2. Edit iSCSI port group and set preferred vmnic to active status and move the second NIC to unused.

Step 3. Edit iSCSI 2 port group and set preferred vmnic to active status and move the other NIC to unused.

Step 4. Add vmk1 and vmk2 under iScsi initiator network configuration port bindings.

I hope above steps will help in resolving the issue. If you run into the same error please let me know.

View solution in original post

0 Kudos
6 Replies
SanjaySP1
VMware Employee
VMware Employee

Hi,

May I know if you're using software or hardware initiator ? Have you tried removing all port bindings & reconfiguring ?

Also, Could you please share the screenshot of network configuration from iScsi initiator properties.

JustyC
Enthusiast
Enthusiast

initiator_general.pngHi SanJaySP1,

It is software initiator.  No I have not yet tried removing the bindings.  I may reboot the host and issue a rescan to see if that

corrects the condition.  Attached are some screen shots of the iSCSI initiator settings.  Hopefully you can read them.  Thanks.initiator_dyn_discovery.pnginitiator_network.png

0 Kudos
SanjaySP1
VMware Employee
VMware Employee

Thanks for sharing the information. Please try below steps :

Step 1. Remove existing port bindings and reboot the host.

Step 2. Edit iSCSI port group and set preferred vmnic to active status and move the second NIC to unused.

Step 3. Edit iSCSI 2 port group and set preferred vmnic to active status and move the other NIC to unused.

Step 4. Add vmk1 and vmk2 under iScsi initiator network configuration port bindings.

I hope above steps will help in resolving the issue. If you run into the same error please let me know.

View solution in original post

0 Kudos
JustyC
Enthusiast
Enthusiast

I followed the steps you provided and was able to make the iSCSI configuration changes.  All is working as expected now.  Removing the one and only port binding, which displayed as non-compilant on the adapter

properties was probably the key.  Another question.... on this same host I may need to swap the existing physical NIC ports currently used for iSCSI.  That would mean the vmnic numbers would be different.  Should I

follow the same steps you provided starting with removing the port bindings on the adapter ?   Thanks.

0 Kudos
SanjaySP1
VMware Employee
VMware Employee

Thanks for sharing the update.

To unlink a physical NIC card which is being used for iSCSI vmkernel port please follow the steps in below KB article :

VMware KB: Unbinding physical network cards from the iSCSI VMKernel

Please let me know if you have any questions and I will be glad to help you.

0 Kudos
JustyC
Enthusiast
Enthusiast

I followed the KB instructions and all is working perfectly now.  Thanks again for all the support.