bergerpjr
Contributor
Contributor

host profiles - failures against host profile

I've created a host profile from a golden host. and applied it to the rest of my cluster. When I Check the Compliance they all fail as "Noncompliant". The reason given is: Failures Against Host Profile "LinkSpeed or duplexity criteria doesn't match for NIC vmnicX". This error displays for all vmnic's and for all ESXi hosts.

When I go to Apply the Profile I get the error message: Configuration Tasks "There are no configuration changes to be made". I click on Finish and then it gives the error "Apply host configuration - a specified parameter was not correct. Time; target and vCenter Server. I click Close.I don't see any other errors to describe that this incorrect parameter is.

So I manually go into the host configuration tab; Networking; Manage Phusical Adapters and check the Link Status; Configured Spped, Diples; Actual Spped, Duplex. For all ESXi hosts they are all the same "Connected; Auto negotiate and 5000 Mb, Full Duplex".

So -- if all of the duplex's; speeds; etc. are the same -- then what is Host Profiles complaining about?

I've searched on the Internet for "LinkSpeed or duplexity criteria doesn't match for NIC vmnicX" and don't get much.

Any help/411 would be great. thanks...

0 Kudos
11 Replies
AndreTheGiant
Immortal
Immortal

Welcome to the community.

Have you tried to rebuild the host template?

Have you verified on physical switches that all ports are configured in the same way and are working at same parameters?

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
bergerpjr
Contributor
Contributor

andre -- i did try to rebuild the profile. i also tried building the profile from a different blade with the same results. There are 8 HP BL490c G6 blades and they are all the same.

I logged into the HP Flex10 Virtual Connect (this is in a C7000 chassis BTW) and verified that all blades are set for "auto" and are allocated at 5 Gb per port (4 NICs total to each blade).

I checked in ESXi again and the physical NICs all negeotiate auto too.

Other than this error everything else within the ESXi cluster seems to be operating normally.

hmmmm....

I've uploaded pics as I know they're more helpful than words...

0 Kudos
ToreUthus
Enthusiast
Enthusiast

Hi.

I'e just experienced the same problem.

Ve have installed a new c7000 blade system vith VC Flex-10 for the first time.

Been useing c7000 with Cisco 3120x until now. No problems whatsoever.

We got the same problems that you have regarding host profiles.

Just because of VC Flex-10

Hope someone knows the solution.

0 Kudos
DSeaman
Enthusiast
Enthusiast

I have the same problem. HP BL490c G6 with Flex-10.  The only way I could get it to work is by removing ALL of the Physical NIC configuration settings. After that, it applies.

Derek Seaman
0 Kudos
Mackopes
Enthusiast
Enthusiast

Same problem here..

Just beginning to investigate.

Will likely open up a ticket with VMware.

AK

0 Kudos
Mackopes
Enthusiast
Enthusiast

OK, played around with this for a bit.

As an addition to what DSeaman said.

I went into the Physical NIC configuration Profile, and noticed that for the NICs it was complaining about, the link speed was set to '0'.

This was only on nics that were not a simple 100, or 1000. (In our config we have a 3000mbps VMotion and 5900mbps DataNetworks).

I changed them to what they 'should' be, and it worked!

(I attached the screen of where I changed it)

0 Kudos
DSeaman
Enthusiast
Enthusiast

That's a great find! I'll be sure to try that out in my environment. Definately a VMware bug. 

Derek Seaman
0 Kudos
bulletprooffool
Champion
Champion

Hi,

try statically assigning all speeds on the Nics on one of the host and remove autonegotiate from any switches / ports (as a test)

One day I will virtualise myself . . .
0 Kudos
dchunt
Contributor
Contributor

I have just run into the same thing with HP BL465 G7 blades and Virtual Connect.  When I edit the host profile and choose Networking configuration | Physical NIC configuration | Physical NIC Configuration | Physical network adapter , instead of specifying the NIC link speed and duplexity, I chose for one NIC the option in the dropdown on the right for 'Physical network adapter automatically negotiates the proper settings'.  Then put in the NIC it applies to such as 'vmnic0'.

When I then check compliance against one of the hosts, the Compliance Details tab now shows 'Validate that a physical NIC named     vmnic0     exist on the host' and it doesn't show up as a variance from the profile.

Would this be a good alternative?  I guess in this case the profile is just checking that the NIC exists and not what speed it is connected at or that it is at duplex setting.  Since the NICs in a Virtual Connect environment may run at different speeds (think of the vMotion network set to 'Auto' in VC) I don't think you want to assign a specific speed or duplexity here.  Maybe all you want to check for is that the vmnic0.. vmnicx exist?

I called VMware and the support people there didn't have a clue about profiles in general or how this linkspeed and duplexity issue worked.

Any other thoughts would be appreciated.

Dan

0 Kudos
grahamfairbank2
Contributor
Contributor

Thanks! Worked for me as well- Same basic configuration, same result!

0 Kudos
lledarby
Contributor
Contributor

This worked for me as well.

Good find!

0 Kudos