tdubb123
Expert
Expert

deploying vm from content library - no customization template option?

Jump to solution

How do I customize my vm with a customization template when using the content library? I do not see the option where to select a customization template

Tags (1)
1 Solution

Accepted Solutions
rcporto
Leadership
Leadership

Which version of vCenter you're running? Unless I'm missing something, that feature is available only with vCenter 6.5, see: What’s New in vSphere 6.5: Host & Resource Management and Operations - VMware vSphere Blog

Content Library

Content Library with vSphere 6.5 includes some very welcome usability improvements.  Administrators can now mount an ISO directly from the Content Library, apply a Guest OS Customization during VM deployment, and update existing templates.

---

Richardson Porto
Senior Infrastructure Specialist
LinkedIn: http://linkedin.com/in/richardsonporto

View solution in original post

0 Kudos
13 Replies
rcporto
Leadership
Leadership

Which version of vCenter you're running? Unless I'm missing something, that feature is available only with vCenter 6.5, see: What’s New in vSphere 6.5: Host & Resource Management and Operations - VMware vSphere Blog

Content Library

Content Library with vSphere 6.5 includes some very welcome usability improvements.  Administrators can now mount an ISO directly from the Content Library, apply a Guest OS Customization during VM deployment, and update existing templates.

---

Richardson Porto
Senior Infrastructure Specialist
LinkedIn: http://linkedin.com/in/richardsonporto

View solution in original post

0 Kudos
tdubb123
Expert
Expert

yes I am on vcenter 6.0 u3

0 Kudos
rcporto
Leadership
Leadership

Then, if you want use that feature with Content Library, you will need to upgrade to version 6.5.

---

Richardson Porto
Senior Infrastructure Specialist
LinkedIn: http://linkedin.com/in/richardsonporto
0 Kudos
tdubb123
Expert
Expert

thank you

0 Kudos
hiphil1729
Contributor
Contributor

hi,

i am using 6.5U1 but i can't find this feature in the deployment dialogue.

br,

philipp

0 Kudos
jfene72
Enthusiast
Enthusiast

pastedImage_0.png

0 Kudos
hiphil1729
Contributor
Contributor

ahhh, thanks! missed that one.

0 Kudos
jfene72
Enthusiast
Enthusiast

No worries. Easier to explain with a pic!

0 Kudos
brotherdh
Contributor
Contributor

I see the option in the Screenshot, but when I deploy, my customize options do not work, It does not ask for the IP address and does not sysprep the system.

My version of Vcenter is Version 6.5.0.10000 Build 7119157

0 Kudos
Raj1988
Enthusiast
Enthusiast

This is a limitation .

""Deploying vm from Content Library using template does not prompt for IP when Guest Customization Spec(prompt user for ipv4 address) is selected""

This has gone as a feature request as Content Library API doesn't provide API support to update the Guest Customization spec as of now. Hoping to see this is future.

0 Kudos
PaulFreedman
Enthusiast
Enthusiast

ajay​ Do you have any update on the feature request?

0 Kudos
adr1an5
Contributor
Contributor

Any update on this? I'm running into the same issue and currently on 6.5 U2c.

Other than sync'in templates/iso across your environment, what's the benefit of Content Lib if you can't leverage Custom specs for deployments?

Content Lib has been out for sometime now and I think its a great feature but the limitations are preventing us from using this feature.

Krede
Enthusiast
Enthusiast

Same in vCenter 6.7 U3 - not able to prompt for IP.

0 Kudos