dquevillon
Contributor
Contributor

command not found

Hello, 

I just recently upgraded my VCSA from 6.5 to 6.7 U 3m, I am trying to patch it to U 3n because security issue.

i log into the shell with root and whatever command i try it alwasy fail stating that command not found.

i did the su ~ to no avail

it probably is a super easy think but i am not very versed in shell command so any help sould be apreciated.

here is the command tried and the output for reference

root@xxxxxxxxx [ ~ ]# software-packages stage --iso
bash: software-packages: command not found

Labels (1)
6 Replies
TorbinIT
Contributor
Contributor

Seconding this. I'm working with a system administrator who is having a similar problem, and I'm not entirely sure what's causing it. It doesn't help that I can't touch or log into the server myself, I can only see screenshots he shares with me.

Can anyone think of what might be causing this?

zenking
Hot Shot
Hot Shot

The software packages command failed for me, too. I had already run the shell.set and shell commands to enable the bash shell.

VMWare Environment: vSphere 6.7, EQ PS6210 SANs, Dell R730 Hosts, dedicated Dell switches w/ separate vlans for vmotion and iscsi.
a_p_
Leadership
Leadership

The update commands have to be entered in the appliance shell, not in a bash shell (https://kb.vmware.com/s/article/2100508).

André

Ajay1988
VMware Employee
VMware Employee

Run them in the appliance shell and not in a bash shell.
Run this from bash : chsh -s /bin/appliancesh root
Restart the SSH session to VCSA. You will reach the Appliance Shell.
Run software-packages from here.

If you think your queries have been answered
Mark this response as "Correct" or "Helpful".

Regards,
AJ
zenking
Hot Shot
Hot Shot

Thanks, Ajay. Switching back to the appliance shell fixed the command.

VMWare Environment: vSphere 6.7, EQ PS6210 SANs, Dell R730 Hosts, dedicated Dell switches w/ separate vlans for vmotion and iscsi.
zenking
Hot Shot
Hot Shot

Thanks. Switching back to the appliance shell worked.

VMWare Environment: vSphere 6.7, EQ PS6210 SANs, Dell R730 Hosts, dedicated Dell switches w/ separate vlans for vmotion and iscsi.
0 Kudos