VMware Cloud Community
fitzie22
Contributor
Contributor
Jump to solution

change cd rom to use my work station's

OK I have been working with no luck to be able to have a virtual server use my local work station's cd rom rather that the one on the host. can someone give some pointers on this?

Thanks

Reply
0 Kudos
1 Solution

Accepted Solutions
esiebert7625
Immortal
Immortal
Jump to solution

Try changing to Host Device, selecting OK and then edit the settings again and sleect Client Device. The button will appear only when Client Device is selected.




<a href="http://tinypic.com" target="_blank">!http://i14.tinypic.com/5yba4ab.jpg|alt=Image and video hosting by TinyPic|src=http://i14.tinypic.com/5yba4ab.jpg|border=0!</a>

View solution in original post

Reply
0 Kudos
18 Replies
esiebert7625
Immortal
Immortal
Jump to solution

It's fairly straightforward, what problem are you experiencing. All you do is Edit the VM settings and select Client Device. You can also change the from Emulate IDE to Passthrough IDE if you have problems. Are you trying to boot off the CD-ROM on the VM?

fitzie22
Contributor
Contributor
Jump to solution

yeah I did that . I cahnged it to client device but it is not reading it. I am actually tryign to boot from a cd adn read from it through windows. after I change it to client device do i need to reboot the vm for teh change to take place?

Reply
0 Kudos
lbourque
Virtuoso
Virtuoso
Jump to solution

Not necessarily but checking the "Connected" and "Connect at power on" (if you need to boot from the CD) would be things to verify.

Reply
0 Kudos
esiebert7625
Immortal
Immortal
Jump to solution

You need to click the Connect CD-ROM button after you connect to the VM remote console. If you are trying to boot off it, first click this and then hit ESC at the VMware BIOS at boot and select CD-ROM as the boot device.

Reply
0 Kudos
esiebert7625
Immortal
Immortal
Jump to solution

"Connected" and "Connect at power on" are not options for Client Device, only for Datastore ISO or Host device.

Reply
0 Kudos
fitzie22
Contributor
Contributor
Jump to solution

I am not able to see the "Connect CD ROm Button:

I see the connected adn connect at power on check boxes. is this what you are talking about?

Reply
0 Kudos
lbourque
Virtuoso
Virtuoso
Jump to solution

Did you click the "Connect DVD/CDRom button" in the toolbar as the note suggests when choosing the client device? Keep in mind that using the client device can be very slow compared to ISO and depends on the speed of your network. You do have the CD in your desktop CDRom/DVDRom device, correct?

Reply
0 Kudos
esiebert7625
Immortal
Immortal
Jump to solution

Once you connect to the remote console of the VM there is a button on the icon bar called "Virtual CD-ROM". If you previously had Datastore or Host selected you sometimes have to power down the VM to change it to Client device. If you have Client Device select the Connected and Connected at power on check boxes are greyed out.

Reply
0 Kudos
fitzie22
Contributor
Contributor
Jump to solution

yes there is a cd in there. see that is where I am loosing my mind. I do not see the :Connect DVD/CDrom" button.

Reply
0 Kudos
esiebert7625
Immortal
Immortal
Jump to solution

Try changing to Host Device, selecting OK and then edit the settings again and sleect Client Device. The button will appear only when Client Device is selected.




<a href="http://tinypic.com" target="_blank">!http://i14.tinypic.com/5yba4ab.jpg|alt=Image and video hosting by TinyPic|src=http://i14.tinypic.com/5yba4ab.jpg|border=0!</a>

Reply
0 Kudos
VirtualNoitall
Virtuoso
Virtuoso
Jump to solution

Hey,

If you have the CDROM setting configured to connected/connect at power on and set the CDROM Device Type to client device then you will see it above the console window a little to the left of center in the VI client. Simply press it to connect to a local CDROM or iso file.

fitzie22
Contributor
Contributor
Jump to solution

OK I need a vacation. I hid the top tool bar because my resolution was not good. I foud it and it works great. thanks to all who helped.

Reply
0 Kudos
fitzie22
Contributor
Contributor
Jump to solution

how did you get a pic up on here. man that would help out big time

Reply
0 Kudos
esiebert7625
Immortal
Immortal
Jump to solution

Just uploaded via Tinypic and added the html code to the post.

http://www.vmware.com/community/thread.jspa?messageID=585364&#585364

Reply
0 Kudos
fitzie22
Contributor
Contributor
Jump to solution

awesome. I will give it a whirl

Reply
0 Kudos
fitzie22
Contributor
Contributor
Jump to solution

one more quick thing. it is working fine on windows 2003 serevers but it does not work on windows 2000. have you heard of that problem?

Reply
0 Kudos
esiebert7625
Immortal
Immortal
Jump to solution

Do you not get the button on those or does it not map at all? Do you have VMware tools installed on the VM?

Reply
0 Kudos
fitzie22
Contributor
Contributor
Jump to solution

ok I got. sorry about that. what I had to do was change it to use the host adn then back to the client adn it worked.

Reply
0 Kudos