parisv
Contributor
Contributor

cannot access web client https://localhost:9443/admin-app/

I have vcenter 5.0 installed on a Windows 2008 r2 vm.

I installed it using this guide here: http://lonesysadmin.net/2011/10/06/how-to-install-microsoft-sql-server-2008-r2-for-vmware-vcenter-5/

I just tried to install the web client on the same machine. The instruction say I should go to https://localhost:9443/admin-app/

When I try nothing happens. I've also tried going to http://localhost:9090/admin-app/

Disabling proxy settings doesn't help.

Any ideas?

Tags (1)
0 Kudos
18 Replies
parisv
Contributor
Contributor

I looked in the services and 'vsphere web client' was set to disabled. I've enabled it but that hasn't fixed the issue.

0 Kudos
canadavirt
Contributor
Contributor

Hi Parisv,

First of all you can check if the vSphere Web Client is registered. And check the VMWare VirtualCenter Management Webservices service. The Web access uses Tomcat.

Another thing you should try is connect with another browser, like Google Chrome.

0 Kudos
parisv
Contributor
Contributor

Hi Thanks for your reply,

Where do I check if the vSphere web client is registerd?

I have tried with firefox, vmware virtualcenter management webservices is running.

not sure about tomcat, does this need to be on the esxi server where my vcenter windows vm is installed on?

fyi my esxi servers are running 4.1

0 Kudos
canadavirt
Contributor
Contributor

To register you must connect into vCenter Server (localhost). The Admin tools isn't enable remotely. To connect into Admin Tools you should use:

https://localhost:{port-number}/admin-app.

Can you find on Programs and Features the "VMware vSphere Web Client" on your vCenter Server?

0 Kudos
parisv
Contributor
Contributor

Yeah thats what I have being trying to do. The machine has vncenter and wed admin installed. On the same machine I have been trying to go to https://localhost:9443/admin-app/

Also the same machine has the attached pic in programs and features

0 Kudos
prince1121
Enthusiast
Enthusiast

Hi welcome to forum

Once installed, you’ll need to authorize the vSphere web client to use your credentials with your vCenter server. if not please folow below link

http://www.virtualizationadmin.com/articles-tutorials/vmware-esx-and-vsphere-articles/general/gettin...

________________________________
If at first you don't succeed, skydiving is not for youhttp://imagicon.info/cat/5-59/vbsmile.png

0 Kudos
parisv
Contributor
Contributor

my problem is that I install the web client but and the end where you click finish it's supposed to launch a web browser and get you to authorize the server it doesn't launch a web browser (I have ie9 installed). I also tried with firefox but no joy. So I can't even get to the steps in firgure 4.

The attached pic is my server which has vcenter 5 installed. It was installed using these instructions: http://lonesysadmin.net/2011/10/06/how-to-install-microsoft-sql-server-2008-r2-for-vmware-vcenter-5/

so I didn't use the bundled in sql express. Could this be the problem??

The attached pic (webserv) is from my vcenter 5 server which has the web client installed

The attached pic tomcat is a picture of the tomcat settings.

0 Kudos
canadavirt
Contributor
Contributor

I found that nice tutorial:

http://www.sysadmintutorials.com/tutorials/vmware-vsphere-5-x/vcenter-5-x/web-client-server/installa...

About the SQL, I needed to run the vCenter Server database.

Did you check the Windows' log and windows firewall?

0 Kudos
canadavirt
Contributor
Contributor

Hi Paris,

Did you get it? Working?

0 Kudos
parisv
Contributor
Contributor

The guide I follwed here: http://lonesysadmin.net/2011/10/06/how-to-install-microsoft-sql-server-2008-r2-for-vmware-vcenter-5/ creates an sql db named VCDB. This is probably a different name than what the default db is called when you installed vcenter with the bundled in sql express.

So I'm thing maybe the web client is looking for a default db where as I need to get it to point to the VCDB I created? Not sure how I would do this though.

0 Kudos
squevill
Contributor
Contributor

I have the exact same problem. If anyone has an answer, please share 🙂

0 Kudos
bondie
Contributor
Contributor

Ensure that you have actually installed the Vcenter Web Services Server from the DVD

0 Kudos
squevill
Contributor
Contributor

The service is installed from the DVD and is running.  The Windows Firewall is disabled.

0 Kudos
mlydy12
Contributor
Contributor

Is there any answer to this problem?  I'm experiencing the exact same issues.  The only thing I can add to this is when I try to start the vSphere Web Client service I get Access Denied 5.  Otherwise all my symptoms are exactly the same.

0 Kudos
RickWilliams
Contributor
Contributor

Hello.

Probably my first post here.

I've had exactly the same issue.

Overview. Installed vSphere Client on Win 2008 R2 SP1. SQL Database on a remote server.

When I installed the Web Client, the service  vSphere Web Client did not start and also errored - as per this post (and afew others).

My solution after much reading around and a little reboot is this.

1) Uninstall the Web Client (Server)

2) Reboot

3) Go to your SQL server and make the account the Owner of the database (this is the account you also use in the ODBC connection).

-- I already hear the cries "VMware say you shouldn't do this" or "that's not how you should install it"; I followed the suggested route for my database prep and install of vCenter and it all worked until this point.

4) Install the Web Client (Server)

Magically it worked for me. Let me know if this solves your issue, as there are a couple of other posts about this on the forums.

0 Kudos
bluefluke
Contributor
Contributor

I just upgraded from vCener 4.1 to 5.0 Update 1 and ran into this issue.    I noticed the post install sent me to a local webpage but required flash (which we dont allow on servers) but it had a hint to run the admin-cmd.bat file to bypass the flash issue.    The admin-cmd.bat is more than that you have to enter arguments with the command.     Once I figured that out it worked fine.   You basically have to register webclient (Server side) to the vCenter.

You need to open a command prompt and browse to the install path (Default for me was C:\Program Files\VMware\Infrastructure\vSphereWebClient\scripts)  then run the following syntax

admin-cmd register https://hostname.domain.com:9443/vsphere-client hostname.domain.com <UID> <Password>

The reason you need to run it from the command prompt is because it will challenge you with a question about a certificate, choice your answer (a= accept, I=ignore, c=cancel) and press enter and your done.    I just copied the syntax for the remaining vCenters I had to upgrade, worked great.  I hope this helps.

0 Kudos
sakibpavel
Enthusiast
Enthusiast

Please make sure that apache is runing in your webserver. Also write the exact port that you have set in your httpd file like ...

https://localhost:[exact port]/admin-app/

Sakibpavel    
0 Kudos
mlydy12
Contributor
Contributor

RickWilliams procedure was the fix for me.  In my case it was the database permissions portion that needed to be set.

0 Kudos