Enthusiast
Enthusiast

Web Client connection problem

Hi,

I got problem that Web Client is not able to connect to vCenter. It is showing message:

HTTP Status 404 - /vsphere-client/

--------------------------------------------------------------------------------

type Status report

message /vsphere-client/

description The requested resource (/vsphere-client/) is not available.


--------------------------------------------------------------------------------

Apache Tomcat/7.0.26

I have tried to restart Web Clent Server but not helped.

Please help!

Tags (3)
19 Replies
Contributor
Contributor

I'm having the same http status 404 error. Have you allready find a solution?

0 Kudos
Expert
Expert

Do you get any error when you try restarting the web client via command line?

/etc/init.d/vsphere-client restart


Regards

Girish

To Virtualization and beyond! PS::If you felt the answer as helpful, please mark it as helpful/answered so that it helps other users as well! Blog:: www.virtualtipsntricks.com
0 Kudos
Contributor
Contributor

We don't use the appliance.

In our testlab we found a workaround. It looks like a config fault/bug in the java configuration. The space in the default installation path "c:\program files\vmware\infrastructure" is possibly causing this issue. I found the workaround after finding the following error in the vsphere_client_virgo.log.

Error processed default web.xml named conf/web.xml at C:\Program Files\VMware\Infrastructure\vSphereWebClient\server\conf\web.xml java.net.URISyntaxException: Illegal character in path at index 16:

After installing the Web Client in e.g. "c:\temp" and the Web client is working. The opposite of what is described in kb204495.

I'm still looking for a solution in stead of this workaround.

0 Kudos
Enthusiast
Enthusiast

Having the same issue with path containing spaces for 5.5, did you ever find a solution?

CHeers,

M

0 Kudos
Commander
Commander

Hi,

According to this KB : http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&docType=kc&externalId=2044953&sl...

There is no solution yet.

So the workaround is to :

  1. Uninstall the vSphere Web Client.
  2. Reinstall the vSphere Web Client.
  3. During the installation, accept the default installation directory on the C:\ drive when prompted by the installation wizard.

Regards,

Julien

Regards, J.Varela http://vthink.fr
0 Kudos
Hot Shot
Hot Shot

I am facing same issue ..getting error while contacting vshpere web client..

HTTP Status 404 - /vsphere-client

i have uninstall and install but still same error.

0 Kudos
Enthusiast
Enthusiast

King_Robert: Are you installing to a path with no spaces?

0 Kudos
Contributor
Contributor

Hi,

after long time searching i found a workaround working good, even with containing spaces in folders.

In my place we are install to drive d:\Program Files\VMware\Infrastructure\vSphereWebClient

What to do:

1. Make a symbolic link, here mklink /d D:\VWC "D:\Program Files\VMware\Infrastructur\vSphereWebClient"

2. Change "Value" under [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vspherewebclientsvc\ImagePath] to (in my place) "D:\VDC\server\bin\service\bin\wrapper.exe" -s "D:\VWC\server\bin\service\conf\wrapper.conf" "set.default.SERVER_HOME= D:\VWC\server" set.default.JMX_Port=9875

3. Restart Service and it works.

Hope it will help somebody.

Regrads

Andy

Contributor
Contributor

Try to refresh the page by pressing F5. Sometimes it only need reload to connect.

If refresh still didn't work, try to retype the url again. HTTP 404 usually occur when you type wrong url or you move url.

I hope those simple step will solve your problem.

0 Kudos
Contributor
Contributor

Worked indeed! Thank you.

Only some typo's in your post which needed to be corrected.

0 Kudos
Contributor
Contributor

Thank you!

Worked like charm!

Only some typo's in your post which needed to be corrected.

It's kind of redonkulas that vCenter 5.5 U2 still has this issue.

0 Kudos
Contributor
Contributor

I only came across this issue when installed vCenter 5.5U2 on Windows Server 2012 R2 Standard

I did not have this issue when installing vCenter 5.5 on Windows Server 2008 R2 Standard

We install our Apps to E: Apps the registry key mentioned on my 2008 server had

"E:\Program Files\VMware\Infrastructure\vSphereWebClient\server\bin\service\bin\wrapper.exe" -s "E:\Program Files\VMware\Infrastructure\vSphereWebClient\server\bin\service\conf\wrapper.conf" set.default.SERVER_HOME=E:\PROGRA~1\VMware\INFRAS~1\VSPHER~1\server set.default.JMX_PORT=9875

On the 2012 server it had

"E:\Program Files\VMware\Infrastructure\vSphereWebClient\server\bin\service\bin\wrapper.exe" -s "E:\Program Files\VMware\Infrastructure\vSphereWebClient\server\bin\service\conf\wrapper.conf" "set.default.SERVER_HOME=E:\Program Files\VMware\Infrastructure\vSphereWebClient\server" set.default.JMX_PORT=9875

This however does not solve the issue but may help shed some more light on it

0 Kudos
Contributor
Contributor

Further to this I did the following

I turned on 8 dot 3 on the E: APP Drive

fsutil 8dot3name set E: 0

Then after rebooting in Safe Mode with Command Prompt

fsutil file setshostname "E:\Program Files" PROGRA~1

Repeat this for all the sub directories

fsutil file sethostname "E:\Program Files\VMware" VMware

fsutil file sethostname "E:\Program Files\VMware\Infrastructure" INFRAS~1

fsutil file sethostname "E:\Program Files\VMware\Infrastructure\vSphereWebClient" VSPHER~1

Now reboot and Web Service works

0 Kudos
Contributor
Contributor

Hi vrm,

Have you resolved this issue.

I'm experiencing this exact same issue in our environment.

vSphere Web Client Running on Windows 2012 Server

After Uninstall and reinstalling on different directory seems to work but does not work in the default installation directory.

Strange thing it has been working for the past 4 months.

Just seem to stop working in my primary and secondary sites.

0 Kudos
Contributor
Contributor

Hello Velia,

I've seen this issue only with version 5.1. I've never changed it after I've installed it in a different folder without spaces because there was no need. In version 5.5 I use the default folder and it works.

What I can remember is that the issue had something to do with Java. Maybe you ran a Java update and that initiates the issue?

Cheers!

0 Kudos
Contributor
Contributor

We got the same problem after upgrading our vCenter Server to 5.5 U3 running on a physical standalone windows 2012 R2 machine,

turns out the problem was that the web client was installed on our D-drive - it worked on 5.5 original/5.5 U1/5.5 U2 on the D-drive without any problems funnily enough...

We just uninstalled the web client and did a reinstall on the default C-drive and path and everything works after that. Weird though...

0 Kudos
Enthusiast
Enthusiast

Hi,

  

It is often standard practice to install the server operating system on C: and then applications and data on additional drives such as E:, F: and so on.
However vSphere Web Client since its 5.0 release though 5.1 and including the latest version at time of writing 5.5 U2, if you install vSphere Web Client to any directory other than the default installation directory you will get the following error when browsing to the vSphere Web Client page.

"HTTP Status 404

The requested requested resource is not available"

I've seen this problem for a while now and just tried latest release 5.5 U2b hoping it had been resolved (I couldn't find a reference in the release notes).

Unfortunately it is still a problem and while the rest of the components such as Single Sign On, Inventory Services and vCenter Server can be installed to another drive letter or directory, the vSphere Web Client must still be installed to the default directory of C:\Program Files\VMware\Infrastucture

If you've installed vSphere Web Client to anything other than the default directory and getting the error above, the only way to resolve this is to uninstall and re-install to the default installation directory provided by the wizard.

Fingers crossed it gets fixed in vSphere 6.0!

0 Kudos
Enthusiast
Enthusiast

0 Kudos