savoy6
Contributor
Contributor

Vmotion Sanity check

Jump to solution

VMotion requires the setup of a private, Gigabit Ethernet migration network between all of the VMotion-enabled hosts. When VMotion is enabled on a host, configure a unique network identity object for the host and connect it to the private migration network.

ESX 3VI

Does this mean I need to get our network guys to setup a VLAN on the switch for all ports connecting to each ESX server? I have four ESX servers so I need to have four ports on the switch configured to a separate VLAN, such as 10.30.22.XX and a gateway of .1

I have read the documentation, but want to make sure

Thanks

Did you power down the VMs before the storage?
0 Kudos
1 Solution

Accepted Solutions
admin
Immortal
Immortal

That is correct, or you could use a small lower cost gigabit switch for VMotion only seeing as it needs no connectivity to the outside world.

View solution in original post

0 Kudos
3 Replies
admin
Immortal
Immortal

That is correct, or you could use a small lower cost gigabit switch for VMotion only seeing as it needs no connectivity to the outside world.

0 Kudos
esiebert7625
Immortal
Immortal

There are alot of unusual concepts in a VMware environment that many network guys are not used to. It's always a challenge trying to get them to change there ways. It helps to sit down with them and make them understand the unique networking features of Vmware (the concept of Vswitches, Vnics, Vmotion, Vlan tagging, Port groups, etc.). Once they understand more about it they tend to put up less resistance when you come to them with requests. Just tell them about all the network ports you'll be saving them when you have 50 virtual servers only using 10 or so network ports when they previously used 50 as physical servers....

These are good resources for ESX networking...

http://www.vmware.com/pdf/esx3_vlan_wp.pdf

http://download3.vmware.com/vmworld/2006/TAC9689-A.pdf

http://download3.vmware.com/vmworld/2006/tac9689-b.pdf

Rumple
Virtuoso
Virtuoso

One comment here is that I've set the gateway to be the same as the server. Since you need no routing outside of the vlan, you do not need a gateway.

Seems to have resolved issues for others. I've always done it this way so I'm not sure if setting the gateway to a true gateway works any differently.

0 Kudos