VMware Cloud Community
rf1908
Contributor
Contributor
Jump to solution

Virtual Center 2.5 Service will not start even after the SQL services are running

The server running VC and SQL was rebooted this morning and the VC service will not start. The SQL services are running and I receive the following message in the evernt viewer :

The description for Event ID ( 1000 ) in Source ( VMware VirtualCenter Server ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Failed to intialize VMware VirtualCenter. Shutting down....

I read in an earlier post that the SQL services needed to be running before VC could start. I have not seen anything on why VC will not start after SQL has.

Reply
0 Kudos
1 Solution

Accepted Solutions
mike_laspina
Champion
Champion
Jump to solution

Failed to create http proxy: Resource is already in use: Listen socket: :80

Is there a service using port 80.

Try stopping IIS and then start the VC service.

http://blog.laspina.ca/ vExpert 2009

View solution in original post

Reply
0 Kudos
7 Replies
arunprasad
Contributor
Contributor
Jump to solution

check the SQL instance is running on the server , and the server is listing on the SQL port like 1433 or your costum port no. then start the VC service .

and also check the dependencies.

Reply
0 Kudos
mike_laspina
Champion
Champion
Jump to solution

Hi,

Have a look at the log files in

C:\Documents and Settings\All Users\Application Data\VMware\VMware VirtualCenter\Logs

Open the one with the current date and time stamp.

You can attach it to a post if you like and we will have a look as well.

http://blog.laspina.ca/ vExpert 2009
Reply
0 Kudos
rf1908
Contributor
Contributor
Jump to solution

I am attaching the log from the last time I tried to start the service.

Reply
0 Kudos
mike_laspina
Champion
Champion
Jump to solution

Failed to create http proxy: Resource is already in use: Listen socket: :80

Is there a service using port 80.

Try stopping IIS and then start the VC service.

http://blog.laspina.ca/ vExpert 2009
Reply
0 Kudos
RParker
Immortal
Immortal
Jump to solution

VC service should still run, the WEB service may not. VC doesn't require HTTP ports. Maybe there is a bug with the web servcie if it tries to start, and it drops the VC service but VC doesn't need IIS or HTTP ports, so it should still start.. at least.

Something else may not be setup correctly.

Reply
0 Kudos
rf1908
Contributor
Contributor
Jump to solution

Turning off IIS worked. I had thought I turned that service to manual put it started. Thanks for your help.

Reply
0 Kudos
allisoncassatta
Contributor
Contributor
Jump to solution

Just FYI in case someone else runs into this problem. If you have the Windows Remote Management Service installed, using port 80 it causes the same problem (just found that out.) If you stop WINrm and start VCenter, then you can start WINrm back up.

Reply
0 Kudos