policeman510
Contributor
Contributor

Vcenter Server 6.5d Installation error 1603

Jump to solution

I'm doing a fresh install on a Windows 2019 server of Vcenter 6.5d.

The installation keeps failing at the VCSServiceManager with a 1603 error.

I've seen lots of posts on this before with upgrading Vcenter, but not on clean installations. 

The last steps I did was start from scratch with a new OS (with .net 3.5), new SQL build and a new Vcenter ISO download, but I'm still getting that 1603 error on VCSServiceManager.

I then installed VCSSServiceManager.msi first, then did the Vcenter installation and that completed "successfully" but not all services were installed and there was no Vcenter web client.

So now I'm back to square one.

I opened a support case and they mentioned it was because of a firewall rule.  I checked, I didn't install any of our antivirus software yet and the Domain/Public/Private Windows firewalls are on disabled.  I'm still working with support, but getting no where as far as a solution goes.

1 Solution

Accepted Solutions
daphnissov
Immortal
Immortal

Not sure the point you're making. I'm effectively saying:  If you use the appliance--which provides gains that would address your problem directly--you could side-step these installation issues altogether and be in a future-proof state. But if you absolutely insist on trying to install vCenter on Windows, vCenter 6.5 doesn't support Windows Server 2019. Not even 6.7 supports 2019 at this time. Source.

View solution in original post

0 Kudos
12 Replies
policeman510
Contributor
Contributor

I forgot to mention, I've been combing through the vminst.log file.  I see some errors, but nothing helping me fix the issue:

2019-03-06 13:05:05.444-06:00| vcsInstUtil-10964411| I: ParseStatusFile: curr error msg: "The installation of vCenter Server failed due to an internal error."

2019-03-06 13:05:05.444-06:00| vcsInstUtil-10964411| E: ParseStatusFile: Displaying error message for "VMware vCenter Server": "The installation of vCenter Server failed due to an internal error.

This is an unrecoverable error, please retry install. If you encounter this error again, please search for these symptoms in the VMware Knowledge Base for any known issues and possible resolutions. If none can be found, collect a support bundle and open a support request."

2019-03-06 13:18:27.437-06:00| vcsInstUtil-10964411| E: wWinMain: MSI result of install of "E:\vCenter-Server\Packages\vcsservicemanager.msi" may have failed: 1603 (0x00000643)

2019-03-06 13:18:27.437-06:00| vcsInstUtil-10964411| E: LaunchPkgMgr: Operation on vcsservicemanager.msi appears to have failed: 1603 (0x00000643)

2019-03-06 13:18:27.437-06:00| vcsInstUtil-10964411| I: PitCA_MessageBox: Displaying message: "Installation of component VCSServiceManager failed with error code '1603'. Check the logs for more details."

0 Kudos
daphnissov
Immortal
Immortal

In all honesty, please don't even bother with installing vCenter on Windows at this point, especially on v6.7 which is the last version that will ever be packaged for Windows. You really need to be using the appliance at this point, because as of next version your hand will be forced.

policeman510
Contributor
Contributor

I'm on board with that.  The problem is that we have HPE Simplivity which relies on VCenter heavily. 

And I've been in a situation where the host where Vcenter was running on crapped out and it was a fun 24 hour ordeal to get us to an up and running state.

0 Kudos
daphnissov
Immortal
Immortal

I don't see how you'd be helped by any of that going with Windows over the appliance. That effectively buys you nothing. But if you used the appliance and one host "crapped out" but didn't cause an HA failover, the appliance has native vCenter HA that would have kept you running. Windows has none of that.

0 Kudos
policeman510
Contributor
Contributor

Oh snap, you just burned me.

Do you feel better now?  Does it make you feel good?

I just wanted help with an install problem I'm having.  Never asked about VC appliances.

0 Kudos
daphnissov
Immortal
Immortal

Not sure the point you're making. I'm effectively saying:  If you use the appliance--which provides gains that would address your problem directly--you could side-step these installation issues altogether and be in a future-proof state. But if you absolutely insist on trying to install vCenter on Windows, vCenter 6.5 doesn't support Windows Server 2019. Not even 6.7 supports 2019 at this time. Source.

View solution in original post

0 Kudos
policeman510
Contributor
Contributor

Ahhh.  Thank you. 

You actually answered the question that I originally asked instead of giving me suggestions that I didn't ask for.  It only took you 3 tries.

Good job.

0 Kudos
daphnissov
Immortal
Immortal

Good luck on your journey back into time!

0 Kudos
policeman510
Contributor
Contributor

There's the humor.  And on a Thursday!

I like it.

0 Kudos
davidpfs
Contributor
Contributor

Hi policeman510, did you get this resolved? we are getting the same error.

Thanks,

0 Kudos
BFoss321
Contributor
Contributor

I have the same issue,  and for those that say use the appliance we do when we can.  Issue is we have over 100 clients that run 1 host with local disk and no san. You can run the appliance then and have it do updates to the host that your on.

Can VMware please help with this issue installing on windows, thank you.

Or if someone can suggest a way to manage a single host and get alerts.

0 Kudos
daphnissov
Immortal
Immortal

I don't see how anything you've said is a reason to use the Windows version over the appliance. Windows is dead. Use the appliance. End of story.

0 Kudos