calale
Contributor
Contributor

Vcenter 6.5 repair installation

Hello, i need to repair component of the Vcenter 6.5 on Windows Server 2012 R2.

Can i reinstall all the components with an existing installation ?

The DB is UP but some components are with problems ?

D:\Program Files\VMware\vCenter Server\bin>service-control --status

Running:

VMWareAfdService VMWareCAMService VMWareCertificateService VMWareDirectoryService VMwareDNSService VMwareIdentityMgmtService VMwareSTS content-library rhttpproxy vPostgres vmon vmonapi vmsyslogcolle

tor vmware-autodeploy-waiter vmware-cis-config vmware-psc-client

Stopped:

EsxAgentManager VMwareComponentManager VServiceManager mbcs vapiEndpoint vimPBSM vmware-imagebuilder vmware-license vmware-network-coredump vmware-perfcharts vmwareServiceControlAgent vpxd vpxd-svcs

vsan-health vsphere-ui vspherewebclientsvc

D:\Program Files\VMware\vCenter Server\bin>service-control --start vmware-license

Perform start operation. vmon_profile=None, svc_names=['vmware-license'], include_coreossvcs=False, include_leafossvcs=False

2020-07-17T09:36:47.850Z   Service cis-license state STOPPED

Error executing start on service cis-license. Details {

    "resolution": null,

    "detail": [

        {

            "args": [

                "cis-license"

            ],

            "id": "install.ciscommon.service.failstart",

            "localized": "An error occurred while starting service 'cis-license'",

            "translatable": "An error occurred while starting service '%(0)s'"

        }

    ],

    "componentKey": null,

    "problemId": null

}

Service-control failed. Error {

    "resolution": null,

    "detail": [

        {

            "args": [

                "cis-license"

            ],

            "id": "install.ciscommon.service.failstart",

            "localized": "An error occurred while starting service 'cis-license'",

            "translatable": "An error occurred while starting service '%(0)s'"

        }

    ],

    "componentKey": null,

    "problemId": null

}

Thank you.

Alessandro

0 Kudos
2 Replies

Hi there,

Did you reach to support to assist you with this? It may be best approach.

I did in the past (not 6.5) a fresh installation and then used an existing database and it works. You can try it if you want (take a backup of the database). I was trying to find a kb or blog with this process but is something lets say not standard and maybe without support. But again, strongly recommend you to reach support fix it and then you can plan a proper migration/upgrade.

Cheers

N

-------------------------------------------------------------------
Triple VCIX (CMA-NV-DCV) | vExpert | MCSE | CCNA
0 Kudos
RajeevVCP4
Expert
Expert

Did you already repaired or before repair getting license error

Rajeev Chauhan
VCIX-DCV6.5/VSAN/VXRAIL
Please mark help full or correct if my answer is use full for you
0 Kudos