jparnell
Hot Shot
Hot Shot

VMotion problem - 'device with remote backing'

When trying to VMotion from one ESX server to another, I receive this error:

Unable to migrate from ESX1 to ESX2: Virtual machine is configured to use a device that prevents migration: Device 'CD/DVD Drive 1' is a connected device with a remote backing.

If i view the virtual machine properties, the CD/DVD drive is showing as 'Connected - client unknown'. All of the CD/DVD properties are greyed out.

I can click the 'Disconnect D:' button on the toolbar with the VI client, but this doesnt have any effect.

Any ideas?!

P.S i even tried removing the CD/DVD device whilst the VM was powered off, powering up the VM, powering it down, and re adding the CD/DVD but this didnt have any effect.

Thanks

0 Kudos
28 Replies
davidiang
Contributor
Contributor

One more addition. The previously posted solutions did not work for me but i found that my guests CDROM was configured to "Emulate IDE" under the Mode section in properties of the CDROM. I set it back to Passthough IDE and vmotion worked with properly.

DG

0 Kudos
bolsen
Enthusiast
Enthusiast

Had this problem with one machine this morning.

To fix it, I had to remove the cdrom AND floppy disk -> bootup so windows removed them from dev mgr -> shutdown and re-add them. (For good measure, you may consider deleting the hidden devices.)

FWIW, the cd rom was originally set for "Emulate." Changing it to Passthrough did not[/i] work for me. I had to remove both devices.

0 Kudos
g_pich
Contributor
Contributor

I went into device manager and disabled the floppy drive and cd-rom. Once I did this I clicked edit settings and the cd-rom was no longer connected and I could migrate.

0 Kudos
axemaster9999
Contributor
Contributor

I simply reinstalled my VMWare Tools and it enabled me to VMotion correctly.

Thanks,

Josh

0 Kudos
virtualman25
Contributor
Contributor

I had this issue on all my VMs since I had installed VMtools. I did a service mgmt-vmware restart on each ESX host 1 min later connected to unknown with the check box was gone...works like a charm.

0 Kudos
wamatha
Contributor
Contributor

Thanks, this worked for me

0 Kudos
m0ps
Enthusiast
Enthusiast

I had this issue on all my VMs since I had installed VMtools. I did a service mgmt-vmware restart on each ESX host 1 min later connected to unknown with the check box was gone...works like a charm.

this is help's me on vmware esx4 host.

best regards, m0ps

best regards, m0ps
0 Kudos
borigor
Contributor
Contributor

Hi,

I found a simple solution: login into VM via console and umount cdrom and after that eject it.

0 Kudos
AndrewAbo
Contributor
Contributor

Same issue, same situation, slightly different fix.

Linux OS, same situation - CD/DCD set to client device with greyed out options, cannot vMotion.

The VMware Tools ISO was no longer mounted, but it was related to VMware Tools installation.  I had recently performed a successful tools install, which completed and dismounted the ISO.

However, it seems that the VM thought the ISO was still mounted.  In Linux, I tried to "umount" the cdrom, which did not help.

I then started a new VM tools install, which mounted the ISO, waited until the mount was completed, then ended VM tools installation.

This fixed the problem!

Thanks guys, for your posts.

0 Kudos