Monoman
Enthusiast
Enthusiast

VMWare tools - binding to wrong NIC

Jump to solution

Most of our VMs have to VNICs. One for production traffic and another for our backup software to use. I noticed on the summary tab for many of our VMs that the IP Address listed is for the backup VNIC.

I looked around and did not see a way to configure VMWare Tools to use the production VNIC. I was able to change the VNIC it was using by

1. Stop the VMWare Tools service

2. Disable the VNIC used for backups

3. Start the VMWare Tools service

4. Enable the VNIC used for backups

I suspect that after a reboot the VMWare tools will go back to the backups VNIC. Does anyone know how to configure VMWare Tools to use a specific VNIC?

Thanks.

0 Kudos
1 Solution

Accepted Solutions
esiebert7625
Immortal
Immortal

This is a quirk with the VI client, see this long post about it. The bottom line is VMware Tools does not use a particular NIC, VMware tools is a collection of drivers and tools and can see both NIC's just like the OS can.

VM Summary Page General showing other NIC ip address - http://www.vmware.com/community/thread.jspa?threadID=84784&messageID=649448#649448

Fyi…if you find this post helpful, please award points using the Helpful/Correct buttons.

-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=-=-

Thanks, Eric

Visit my website: http://vmware-land.com

-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=-=-

View solution in original post

0 Kudos
3 Replies
moo2102
Contributor
Contributor

that's an interesting question if someone has the answer it would help me too

0 Kudos
esiebert7625
Immortal
Immortal

This is a quirk with the VI client, see this long post about it. The bottom line is VMware Tools does not use a particular NIC, VMware tools is a collection of drivers and tools and can see both NIC's just like the OS can.

VM Summary Page General showing other NIC ip address - http://www.vmware.com/community/thread.jspa?threadID=84784&messageID=649448#649448

Fyi…if you find this post helpful, please award points using the Helpful/Correct buttons.

-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=-=-

Thanks, Eric

Visit my website: http://vmware-land.com

-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=-=-

0 Kudos
Monoman
Enthusiast
Enthusiast

Thanks for the pointer to the other thread. I don't know why I missed that in my searching.

It sounds like the VMWare client could use a bit of tuning. The client should have configuration options that let the user pick which adapter gets used.

0 Kudos