Razorhog
Contributor
Contributor

VM has incorrect date and time after a reboot

Jump to solution

vSphere Enterprise, ESXi 4

One of my VMs will get the wrong date and/or time after a reboot of the guest. It is a windows XP SP3 machine, running of all things, timeclock software. Any ideas?

0 Kudos
1 Solution

Accepted Solutions
MauroBonder
Leadership
Leadership

you have a ntp configured in HOST ESX (Configuration > Time Configuration) ?

check too a time of hadware (vmwHadwareTime)

check dialog box to configure time syncronization between host and guest.

**If you found this information useful, please consider awarding points for

"Correct" or "Helpful"**

*Please, don't forget the awarding points for "helpful" and/or "correct" answers. *Por favor, não esqueça de atribuir os pontos se a resposta foi útil ou resolveu o problema.* Thank you/Obrigado

View solution in original post

0 Kudos
5 Replies
MauroBonder
Leadership
Leadership

you have a ntp configured in HOST ESX (Configuration > Time Configuration) ?

check too a time of hadware (vmwHadwareTime)

check dialog box to configure time syncronization between host and guest.

**If you found this information useful, please consider awarding points for

"Correct" or "Helpful"**

*Please, don't forget the awarding points for "helpful" and/or "correct" answers. *Por favor, não esqueça de atribuir os pontos se a resposta foi útil ou resolveu o problema.* Thank you/Obrigado

View solution in original post

0 Kudos
admin
Immortal
Immortal

Check if the time sync is set in vmware tools properties window. If yes, make sure that the time is correct in the ESX host. If not, check the option. This should set the time to correct value.

-Sandeep

jbogardus
Hot Shot
Hot Shot

If it's part of a domain disable the Windows Time Service which will try to synch time with a Domain Controller when it is enabled. It can conflict with VMware Tools Time Synch setting and cause time to be incorrect. Make sure the ESX Hosts are set to correct UTC time (use NTP if possible to maintain correct time), make sure the Windows OS is set to the right time zone, and enable the VMware Tools Time Synch setting.

MauroBonder
Leadership
Leadership

is good you syncronize the clock on two things.

1- Software (ESX)

2- Hardware

you need set a clock at software and repass to hardware

*If you found this information useful, please consider awarding points for "Correct" or "Helpful"*

*Please, don't forget the awarding points for "helpful" and/or "correct" answers. *Por favor, não esqueça de atribuir os pontos se a resposta foi útil ou resolveu o problema.* Thank you/Obrigado
0 Kudos
Razorhog
Contributor
Contributor

Thanks for all of the great replies. I have set the NTP server and will set the vmware tools time sync asap.

0 Kudos