Contributor
Contributor

VCSA install - Unable to save IP settings

Jump to solution

Trying to install latest VCSA  7.0.1 trial in lab under VM Workstation but getting "Unable to save IP settings" during the set up phase no matter what I do.

VM is allocated 2 x Intel Core i7-10700, 11.7 GB memory. Its got a static IP and bridged to the local network which has a DNS server which I am confident is working because I can see the lookups and replies.

Wanting to get a lab running for NSX-T 3.0. Relatively new to this.

Thanks.

1 Solution

Accepted Solutions
Leadership
Leadership

It's likely a known bug which you are facing.

From VMware vCenter Server 7.0 Update 1 Release Notes

Deployment of a vCenter Server Appliance by using port 5480 at stage 2 fails with unable to save IP settings error

If you use https://appliance-IP-address-or-FQDN:5480 in a Web browser, go to the vCenter Server Appliance Management Interface for stage 2 of a newly deployed vCenter Server Appliance, and you configure a static IP or try to change the IP configuration, you see an error such as
Unable to save IP settings

Workaround: None.

André

View solution in original post

23 Replies
Leadership
Leadership

How exactly are you trying to deploy it?

0 Kudos
Contributor
Contributor

I appreciate the reply.

Using a procedure I've found in a few places. One example is : https://diyvirtualization.com/2020/05/28/how-to-install-vcsa-7-in-vmware-workstation-15-step-by-step...

Stuck at step 11 shown.

Thanks.

0 Kudos
Leadership
Leadership

It's likely a known bug which you are facing.

From VMware vCenter Server 7.0 Update 1 Release Notes

Deployment of a vCenter Server Appliance by using port 5480 at stage 2 fails with unable to save IP settings error

If you use https://appliance-IP-address-or-FQDN:5480 in a Web browser, go to the vCenter Server Appliance Management Interface for stage 2 of a newly deployed vCenter Server Appliance, and you configure a static IP or try to change the IP configuration, you see an error such as
Unable to save IP settings

Workaround: None.

André

View solution in original post

Contributor
Contributor

Thanks.

Workaround is to use another install method... I've made more progress using the installer to my ESXi host.

0 Kudos
Contributor
Contributor

What other option of installation is working?

0 Kudos
Contributor
Contributor

The error was occurring when I tried to install VCSA directly onto Workstation (Pro 16) on my lab network. I have now installed it under ESXi which is also running on Workstation, using the installer. I wanted to avoid the nesting, but its running fine like that.

0 Kudos
VMware Employee
VMware Employee

I have a workaround. Switch to dhcp from static.

1. Set up DHCP Reservation and DNS entry for the appliance. ( I used a domain controller)

2. Do not use the DCUI to switch the appliance to dhcp. This will fail.

3. Instead. alt-f1. log in as root, go to shell and run /opt/vmware/share/vami/vami_config_net

4. configure for dhcp from here.

5. Start a new VAMI connection to https://ip_address_or_fqdn:5480

You should now be able to proceed with configuration

0 Kudos
Contributor
Contributor

Fixed!
When I setup my lab, I was having the same issue when deploying VMware vCenter Server Appliance v7.0.1 ova to VMware Workstation Pro 16 when using static ipv4. I can't change the IP from static to DHCP in the Console, Web portal https://vca:5480 or /opt/vmware/share/vami/vami_config_net command via SSH.
Here is the fix. Note, changing DHCP=yes doesn't really use DHCP e.g. you don't need a DHCP server/service for it to work.
1) SSH to the vCenter IP, type shell, edit /etc/systemd/network/10-eth0.network file, change DHCP=no to DHCP=yes, save the file and done! No need to reboot
2) Head over to or refresh https://vca:5480 again to finish the configuration

Sample output below

 

Command> shell
Shell access is granted to root
root@vca [ ~ ]# cat /etc/systemd/network/10-eth0.network
[Match]
Name=eth0

[Network]
Gateway=192.168.199.2
Address=192.168.199.7/24
LinkLocalAddressing=no
DHCP=yes
Domains=lab.local

[DHCP]
UseDNS=false

[Route]
Gateway=192.168.199.2
Destination=0.0.0.0/0

 


Once I done that, No more IP information in Step 2 (see attached, No.1) while setting it up via https://vca:5480.

I can only upload 1 attachment, I combined 4 screen caps into 1 and attached to this reply

Tags (1)
Contributor
Contributor

You can export the VM from ESXi and run it in Workstation if you don't want to nest them?

0 Kudos
Contributor
Contributor

Thanks MarcusZheng

Sadly this did not work for me.  I couldn't get past stage 2, even with the server using DHCP, and it definately using DHCP.  All DNS records were working and correct for forward and reverse.  The only way I got it working was to deploy in ESXi, and the export the VM

0 Kudos
Contributor
Contributor

I had this issue while deploying vCenter ova to ESXi and VMware Workstation. Changing DHCP=no to DHCP=yes in /etc/systemd/network/10-eth0.network fixed both issues. The good thing is even you're setting DHCP=yes, but you don't need DHCP server/service for this to work. 

0 Kudos
Contributor
Contributor

Thank you Marcus. Yes the solution worked for me 🙂

0 Kudos
Enthusiast
Enthusiast

This worked for me also. TY!

Roger Lund Minnesota VMUG leader Blogger VMware and IT Evangelist My Blog: http://itblog.rogerlund.net & http://www.vbrainstorm.com
0 Kudos
Contributor
Contributor

Marcus' answer should be pinned as the solution. Worked for me and a few others.

0 Kudos
Contributor
Contributor

It worked like a charm! To be more clear to people who got no idea about SSH and LinuxBash; for SSH use PuTTy. 

After you connect to VSCA IP address with PUTTY, try the vi linux command to visually edit the file!

vi /etc/systemd/network/10-eth0.network

0 Kudos
Contributor
Contributor

This has been around for 2 months, I see this as a fail!! Another 2 hours wasted because of VMWare...

Enthusiast
Enthusiast

Thanks... That works for me... !

As the author said... I wanted a static IP vCenter as this is a test for me, I set to DHCP went back to the start of the Stage 2 settings and i picked on the screen like "use the IP settings arleady setup" and I got past that to the SSO setup page..

if you forgot how to use 'vi' to edit a text files on ESXi here is a cheat sheet.... (its been TOO long for me -- dont hate)

https://www.vi-tips.com/2012/06/basic-vi-text-editor-commands.html



VMware link saying NO WORKAROUND is pretty sad... 

 

 

VMware VCP 3.5 VMware VCP 4.0 VMware VCP 5.0
0 Kudos
Leadership
Leadership

Just a quick update.
The issue has finally been resolved, see the VMware vCenter Server 7.0 Update 1c Release Notes

André

0 Kudos
Contributor
Contributor

Great, this worked for me. 🙂  I'd setup a DNS server VM under Workstation Pro (using Unbound) to no avail.  That little change to the DHCP setting worked exactly as described.  Many thanks for the tip!

0 Kudos