kratochviljan
Contributor
Contributor

VCSA 7 backup failed, SMB, Credentials

I am trying to set up VCSA backup on a clean install (vCenter Server Management / Backup).
The backups should be located on a NAS accessible via SMB protocol.
I set everything up and everything behaves correctly, but the backup does not run at the selected time.

Backup job failed
Possible Causes:
Backup job failed Action: Check backup server connectivity and available space

If I run the backup manually [BACKUP NOW] and manually enter the login information for the NAS connection [Backup server credentials], everything will run fine.

But if I select "Use backup location and user name from backup schedule." the login credentials are transferred, but when I start the backup I get the error "Access to the backup server is denied. Check your credentials."

Here is the problem.

A careful check of the credentials transferred shows the password is one character shorter.
If I correct the password to the right one, the backup goes through.
(of course, only the black dots are visible, but their number doesn't match, my password has 12 characters, but there are only 11 black dots)

So, according to me, the whole problem is that the password that is stored at the backup is stored incorrectly and therefore the automatic backup does not work.

Does anyone have the same problem ?

 

Product:
VMware vCenter Server
Version:
7.0.3.00800
Build number:
20150588
Labels (4)
0 Kudos
2 Replies
BillionthOne
Contributor
Contributor

i had some failure issues using the vami backup process, turns out it was my proxy settings...
i had to modify my /etc/sysconfig/proxy file to change to an http in the https proxy

#
PROXY_ENABLED="yes"

# Example: HTTPS_PROXY="https://proxy.provider.de:3128/ "
HTTPS_PROXY="http://myproxyfqdn.com:9090/ "

and include the vcenter and sftp in the no_proxy section

# Example: NO_PROXY="www.me.de , do.main, localhost"
NO_PROXY="localhost, 127.0.0.1, myvcenter.fqdn.my.doamin.com, mybackupsftp.fqdn.server.com

of course restart services after modifying proxy

service-control --stop --all

service-control --start --all

0 Kudos
DhirajChopra
Enthusiast
Enthusiast

I believe it help you, for more information please find VMware KB : https://kb.vmware.com/s/article/70646

Cause
The issue occurs due to SMBv1 being disabled on SMB server.

Resolution
This is a known issue in VMware vCenter Appliance 6.7 U2 and above.
Currently, there is no resolution.

Workaround
To workaround this issue, enable the SMBv1 protocol on the SMB server.
For more information, see Microsoft Knowledge Base 2696547.

0 Kudos