bosco7777
Contributor
Contributor

VCSA 6.5 to 6.7 Upgrade pre-check warning

Jump to solution

I have two embedded VCSA appliances in embedded linked mode.  They are 6.5 U3a.  I'm trying to upgrade them to 6.7.  I'm using the 6.7 ISO 15132721 build.  On both of them I get

warning - Unable to retrieve replication status of the partners

resolution - Make sure vmdir service is reachable and started in partner nodes and this node before continuing

I've checked, and the vmdir service is running on both of them.  ./vdcrepadmin -f showpartnerstatus indicates Partner is 0 changes behind on both.  I've restarted both VCSAs.  I've not opened a support ticket on this yet

JB

1 Solution

Accepted Solutions
nirmalgnair
VMware Employee
VMware Employee

Hi @bosco7777,

Since you have already checked the replication I would suggest you to ignore as this is a warning message seen in 6.7u3b.

Just close the dialogue box and proceed with the upgrade. Please make sure that you have powered off snapshots of all  the nodes before upgrade.

Regards,

Nirmal Nair

View solution in original post

0 Kudos
4 Replies
nirmalgnair
VMware Employee
VMware Employee

Hi @bosco7777,

Since you have already checked the replication I would suggest you to ignore as this is a warning message seen in 6.7u3b.

Just close the dialogue box and proceed with the upgrade. Please make sure that you have powered off snapshots of all  the nodes before upgrade.

Regards,

Nirmal Nair

0 Kudos
bosco7777
Contributor
Contributor

Thanks Nirmal,  I probably will.  I found the logfile about the error in the bundle -

vmafdupgrade.replicationValidator Running: ['/usr/lib/vmware-vmdir/bin/vdcrepadmin', '-f', 'showservers', '-h', 'localhost', '-u',

and then after the -u, it just has jibberish.  I guess it's supposed to be an encrypted credential, but doesn't seem to appear formatted like an encrypted credential

ERROR vmafdupgrade.replicationValidator Unable to retrieve VMDir servers

ERROR vmafdupgrade.replicationValidator Stdout: Vdcrepadmin failed. Error [User invalid credential] [9234]

Stderr: password:

But as I mentioned, manually checking with vdcrepadmin with a known good password indicates all is well.

JB

nirmalgnair
VMware Employee
VMware Employee

You are correct. This happened because of the same where the script generates the errors and we are seeing this specially with 6.7u3b.

We even see this on embedded standalone VCSA as well.

Hope you were able to complete the upgrade.

Regards,

Nirmal Nair

0 Kudos
bosco7777
Contributor
Contributor

The upgrade went without issue.  thanks!

0 Kudos