Sebasian
Enthusiast
Enthusiast

VCSA 6.5 does not send alerts to e-mail

Hi,

I have the following problem. Currently, I installed a new Vcenter Server Appliance in version 6.5.0.14000. I can not cope with sending notifications via VCSA that does not work.

My external mail server for sending notifications works fine. Notifications from other devices affect my inbox.

I would also like to emphasize that our mail server (mail.companydomain.com) is open to the IP address and ports of the VCSA server.

Configuration in the VCSA GUI is in the instructions (Vcenter General-> Mail) in the fields are filled in as follows:

mail server - mail server address (mail.companydomain.com),

mail sender - (helpdesk@companydomain.com)

When using the VCSA console, the command:

echo "Subject: sendmail test" | sendmail -v my.email@companydomain.com

the mail is forwarded to my mailbox.

This is how my sendmail works in VCSA. Where to look for a problem?  It's need any additional settings?

best wishes,

14 Replies
a_p_
Leadership
Leadership

Please take a look at /var/log/vmware/vmware-vpx/vpxd.log to find out whether it contains entries regarding the SMTP issue.

André

0 Kudos
Sebasian
Enthusiast
Enthusiast

Hi

In the given path, this file is not present, it's in the location only: /storage/log/vmware/vpxd/vpxd.log

In it, I found only entries:

2018-03-01T12:37:11.028Z info vpxd[7FA22C47C700] [Originator@6876 sub=MoOptionMgr opID=VcActionCommand-apply-98030-ngc:70025064-a9] [OptionManagerMo] Invoking callbacks for key mail.smtp.username, pre commit

2018-03-01T12:37:11.030Z info vpxd[7FA22C47C700] [Originator@6876 sub=MoOptionMgr opID=VcActionCommand-apply-98030-ngc:70025064-a9] [OptionManagerMo] Invoking callbacks for key mail.smtp.username, post commit

2018-03-01T12:37:11.030Z info vpxd[7FA22C47C700] [Originator@6876 sub=MoOptionMgr opID=VcActionCommand-apply-98030-ngc:70025064-a9] Setting SMTP relay server to [mail.companydomain.com]:25

2018-03-01T12:37:11.030Z error vpxd[7FA22C47C700] [Originator@6876 sub=MoOptionMgr opID=VcActionCommand-apply-98030-ngc:70025064-a9] Cannot set SMTP relay server:FileIO error: Could not find file  : /etc/mail/auth/auth-info

2018-03-01T12:37:11.030Z info vpxd[7FA22C47C700] [Originator@6876 sub=MoOptionMgr opID=VcActionCommand-apply-98030-ngc:70025064-a9] [OptionManagerMo] Invoking callbacks for key mail.smtp.password, pre commit

2018-03-01T12:37:11.031Z info vpxd[7FA22C47C700] [Originator@6876 sub=MoOptionMgr opID=VcActionCommand-apply-98030-ngc:70025064-a9] [OptionManagerMo] Invoking callbacks for key mail.smtp.password, post commit

2018-03-01T12:37:11.031Z info vpxd[7FA22C47C700] [Originator@6876 sub=MoOptionMgr opID=VcActionCommand-apply-98030-ngc:70025064-a9] Setting SMTP relay server to [mail.companydomain.com]:25

Previously I tried to configure in VCSA Configure -> Adwanced Settings: mail.smtp.password and mail.smtp.username.

Currently as I am trying to generate an alarm - there is no information about SMTP in the vpxd.log file

0 Kudos
Finikiez
Champion
Champion

What's your VC build number?

Chek this KB and symptoms VMware Knowledge Base

0 Kudos
EstherP
Enthusiast
Enthusiast

Hello

I have the same problem but in my case, I solved doing a smal change. My VCSA sends mail via SMTP and for any reason, after migrating to VCSA 6.5 the mails stop sending.

I did a clean installation and the same problem.

If you are sending mail by SMTP, you can try the following.

Connect via SSH to the VCSA and go to the folder "mail"

>cd /etc/mail

You will see several files, you have to edit one called submit.cf (do a copy of the file, before modifying)

Look for this line "# "Smart" relay host (may be null)"

After the "DS", enter the FQDN of your SMTP server like this:
# "Smart" relay host (may be null)

DS smtp.pp.com (example)

Restart your vCenter, and you will see , how the mail are sent again. I hope this useful for you Smiley Happy

Regards

Cormite
Contributor
Contributor

Worked like a charm for me.

Thanks!

0 Kudos
Zarra
Contributor
Contributor

Many thanks, very useful.

Regards,

0 Kudos
BrianGem
Contributor
Contributor

I had the same exact issue after upgrading from Windows vCenter Server to the VCSA. I followed your directions except I used WinSCP and navigated right to the submit.cf file and modified it with my Exchange server's IP address. I saved the file and within minutes email alerts started sending again. I didn't even have to restart my vCenter services. Thanks for the quick fix!

Mahee_rr
Contributor
Contributor

Thank you so much Smiley Happy

0 Kudos
Mahee_rr
Contributor
Contributor

Thank you

0 Kudos
GregWooldridgeE
Contributor
Contributor

worked for me. Thanks!

0 Kudos
UpstairsDavid
Contributor
Contributor

One can also use the command "service sendmail restart"  as alternative to rebooting vCenter.

0 Kudos
jplopper
Contributor
Contributor

I was seeing this in VCSA 6.7 and might apply in 6.5.  I found that all I had to do was to remove the smtp server from the mail server settings, save it, and then re-add the smtp server and save it again.  No service restarts or server restart required.  Seemed to stop working after an upgrade of the VCSA.  This tipped me off: https://www.ictstuff.info/vsphere-6-7-no-e-mail-notifications-from-vcenter/ .

HunvHunvHunv
Contributor
Contributor

This is the answer for me!

It was already not working in vCenter Appliance 6.5. We upgraded to 6.7 and it was still not working. After removing Servername and sender address, save the empty settings, and add them again everything is fine.

Better than editing the submit.cf where no one knows anything about in a year.

0 Kudos
awingren
Contributor
Contributor

Thank you for suggesting WinSCP.  This along with the instructions from Piki I got my alerts working too!

Cheers!

-Alicia

0 Kudos