AntonVZhbankov
Immortal
Immortal

VC4: Overview performance could not be loaded

Installed VC4 on clean Oracle DB, and can't now get overview performance, advanced works fine

"Perf Charts service experienced and internal error.

Message: Report application initialization is not completed successfully. Retry in 60 seconds. "


---

VMware vExpert '2009

http://blog.vadmin.ru

EMCCAe, MCITP: SA+VA, VCP 3/4/5, VMware vExpert http://blog.vadmin.ru
Tags (2)
31 Replies
AntonVZhbankov
Immortal
Immortal

Nope.

We scheduled upgrade to Oracle 11.


---

MCSA, MCTS, VCP, VMware vExpert '2009

http://blog.vadmin.ru

EMCCAe, MCITP: SA+VA, VCP 3/4/5, VMware vExpert http://blog.vadmin.ru
0 Kudos
artist-06
Contributor
Contributor

Anton,

Can you explain your setup a bit more?

Is your Oracle server remote? Which version?

What is your VC OS? Is your VC in a domain with DNS working?

I found the clue to my solution in stats log file in Tomcat\logs folder. I suggest you attach that file.

Did you copy ojdbc5.jar and ojdbc14.jar files to 3 locations as I stated in my post above?

My performance charts are working now! after editing a registry key with fully qualified database name.

Burak

0 Kudos
AntonVZhbankov
Immortal
Immortal

Win 2003 R2 Ent, Oracle 10.2.0.4 local. vCenter in domain, secondary DNS is installed on vCenter.

I'll take a look at your solution tomorrow, it's already 12 AM here. Thank you.


---

MCSA, MCTS, VCP, VMware vExpert '2009

http://blog.vadmin.ru

EMCCAe, MCITP: SA+VA, VCP 3/4/5, VMware vExpert http://blog.vadmin.ru
0 Kudos
Corpus
Contributor
Contributor

I'm also experiencing this same issue, and as mentioned in a

different thread (http://communities.vmware.com/message/1408331) we also have this error messages on the Service Status and Hardware Status, in the plug-in manager:

-


vCenter Service Status

VMware, Inc.

4.0

Disabled

Displays the health status of

vCenter services

The following error

occured while

downloading the script

plugin from

https://->Server-FQDN<-:8443/h-

ealth-ui/scriptConfig-

.xml:

The remote server

returned an error:

(400) Bad Request.

-


It seams to be related to the error in performance overview saying:

"This error (HTTP 400 Bad Request) means that this program

was able to connect to the web server, but the webpage could not be found

because of a problem with the address."

The problem is the same on the vcenter server and on a workstation running the vSphere client.

BTW: The BAD REQUEST error is also displayed if I try to access the page directly from IE

I've tried redusing the memory for the tomcat/java.

I've restarted both HTTP-SSL and the VMware VirtualCenter Management Webservices

Trying to Enable the plug-ins in the plug-in manager does nothing. They stays disabled.

And a few other things, but still nothing.

Øystein S.

0 Kudos
HughBorg707
Hot Shot
Hot Shot

Hi guys,

Same problem minus the Oracle.

This link worked for me:

Summary:

1 . Close all sessions of vSphere Client.

2. Go Start > Administrative Tools > Services

3. Find VMware VirtualCenter Management Webservices

a. Right Click Stop (Don’t do a restart, wait for the service to stop)

b. Right Click Start (This will stop and start the Tomcat Server)

4. Don’t close Services.mmc but find a service SQL Server Browser

a. Right Click > Properties

b. Change Startup Type: Automatic

c. OK

d. Right Click and Start the Service

5. Login into vCenter and Look at Performance > Overview you should

see Nice Graphs of CPU, Memory, Disk. You have options to pick between

History Graphs and Real-time Graphs.

Also I noticed that my local XP PC that I was using to log into my vCenter server was not using the correct gateway for the test network. As a result when I checked my vCenter plugins, the vCenter Status and vCenter Hardware Status plugins were red X deactivated and would not enable. (said it could not resolve the name of my vcenter server >> vcenter.domain.net:8xxx)

As soon as I changed my local PC to the correct default gateway they enabled fine, but I was still not able to enable the charts until I followed the above items.

I have run into the issue a few times on different systems but this is the only thing that has worked for me directly.

Regards

Mike

0 Kudos
AntonVZhbankov
Immortal
Immortal

Thank you very much, but there is no SQL Server Browser for Oracle.


---

MCSA, MCTS, VCP, VMware vExpert '2009

http://blog.vadmin.ru

EMCCAe, MCITP: SA+VA, VCP 3/4/5, VMware vExpert http://blog.vadmin.ru
0 Kudos
HughBorg707
Hot Shot
Hot Shot

Ahh, I was hoping that would work for you.

I've run into the problem here and there so I wasn't sure if it was a gateway, dns, or SQL issue... or just a random mix of all of them.

Regards

0 Kudos
AntonVZhbankov
Immortal
Immortal

And finally answer is found!!!

Here is example of tnsnames.ora

>vcenterdb.world =

(DESCRIPTION =

(ADDRESS_LIST =

(ADDRESS = (PROTOCOL = TCP)(HOST = x.x.x.x)(PORT = 1521))

)

(CONNECT_DATA =

(SID = vcenterdb)

(SERVER = DEDICATED)

)

)

When you configure ODBC System DSN you can set "TNS Service Name" as "vcenterdb" and vCenter will work fine. But Overview plugin requires full name, so you have to set it to "vcenterdb.world"

Works in 10.2 and 11.1


---

MCSA, MCTS, VCP, VMware vExpert '2009

http://blog.vadmin.ru

EMCCAe, MCITP: SA+VA, VCP 3/4/5, VMware vExpert http://blog.vadmin.ru
0 Kudos
jmotes
Contributor
Contributor

to solve the problem the OP is having if you are on microsoft sql server:

open regedit

navigate to HKLM\Software\ODBC\ODBC.INI\

find the key that corresponds to your ODBC you configured for vcenter and expand it.

you should see the following values:

(default) REG_SZ

you will notice that the Server value is missing. please create a new string value and set the value to the IP address or host name of your SQL server.

restart the VMware VirtualCenter Management Webservices service.

Close and re-connect the VI client.

0 Kudos
meistermn
Expert
Expert

How to change the ms sql port from 1433 to 12333 ?

0 Kudos
toob
Contributor
Contributor

I had this problem with one of our production vCenter (4.1) boxes that uses a remote SQL DB in a different domain.

To set up the vCenter connection I used cliconfig to create an alias for the fqdn and port. However to make the java work I needed to edit

HKLM\Software\ODBC\ODBC.INI\DB_Name\Server

and replace the simple name with FQDN,port (note comma, not colon or full stop)

EG:

Name             Type                           Data

Server            REG_SZ                      bob.test.local,1865

hth

0 Kudos
robincm
Contributor
Contributor

In my case this was fixed by changing the account used by the vctomcat service (aka VMware VirtualCenter Management Webservices) from LocalSystem to an Active Directory account - I used the same one that was running the vpxd service (VMware VirtualCenter Server).

Stopped and re-started the vctomcat service and performance overview is now working.

Had related SQL login failed messages on the SQL server, which have gone away now, see http://rcmtech.wordpress.com/2012/08/06/vsphere-client-performance-overview-not-working/ for details.