jslarouche
Enthusiast
Enthusiast

VC 2.5 Update 4 - sysprep 2008 issue

Jump to solution

Hello all,

We've upgraded to Update 4 over the weekend and while trying to sysprep a windows 2008 machine all goes well till when it's completely finished. We tried to login and it wont allow us to login with the local admin account. I've set the customization admin password in VC to match what is inside the Virtual Machine and it's not allowing us to login.. What gives? Something we are missing?

0 Kudos
1 Solution

Accepted Solutions
kjb007
Immortal
Immortal

Sounds correct, if you are using those characters. Wasn't an issue previously. Another backup I use is to have a 2nd local admin account that is not Administrator. The @ should work as well as the !

-KjB

VMware vExpert

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB

View solution in original post

0 Kudos
12 Replies
kjb007
Immortal
Immortal

Have you tried to reboot the machine again, just to make sure?

-KjB

VMware vExpert

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
Troy_Clavell
Immortal
Immortal

....also, we have our password already set in the "gold image" and therefore left the customization specs password as blank, maybe that would be something to try as well.

kjb007
Immortal
Immortal

We set our password in the image itself as well.

-KjB

VMware vExpert

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
0 Kudos
jslarouche
Enthusiast
Enthusiast

Let me give that a try.. See if that does the trick..

0 Kudos
jslarouche
Enthusiast
Enthusiast

I've tried both of your suggestiong and still no go.. I've even converted the Template back to a VM to validate the password and it worked.. Any other suggestions?

0 Kudos
Troy_Clavell
Immortal
Immortal

so, when creating this "gold image", you are just shutting down the VM when complete and converting it to a template, correct? No other steps are involved. Then when you deploy off template, you are using the customization process in vCenter, correct? Maybe you can try to walk through a new customization process to see if that helps. Once complete save it.

0 Kudos
kjb007
Immortal
Immortal

When you are using the customization spec, are you clicking the checkbox for the admin account to log in automatically? At least for one time? Then, check your password?

-KjB

VMware vExpert

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
0 Kudos
jslarouche
Enthusiast
Enthusiast

I called VMware and this is what they told me.. I am trying to validate workaround

Cannot log into a Windows 2008 virtual machine deployed and customized from template on VirtualCenter 2.5 Update 4

When deploying a Windows 2008 virtual machine from template and customizing, the task is successful, however you are unable to log into the deployed virtual machine with the customized password.

Resolution

The following workaround applies:

Do not use special characters in the password used for customization. Characters such as &,%,$, etc. are not passed correctly to sysprep which then creates a password that is unknown.

VMware is aware of the issue and is working on a fix in the next update.

0 Kudos
kjb007
Immortal
Immortal

Sounds correct, if you are using those characters. Wasn't an issue previously. Another backup I use is to have a 2nd local admin account that is not Administrator. The @ should work as well as the !

-KjB

VMware vExpert

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB

View solution in original post

0 Kudos
Troy_Clavell
Immortal
Immortal

I understand why VMware is saying, but if you don't create a password, meaning leave it blank in the customization specs, why would this matter? We have spaces in our local admin passwords along with special characters and haven't seen this problem. Maybe i'm just lucky Smiley Happy

Nonetheless, glad to see you are working or have worked to resolution.

don't forget to award points by marking answers as "correct" or "helpful"

0 Kudos
jslarouche
Enthusiast
Enthusiast

Well i've tried everything today and basically wasted my whole day on this stupid bug.. I think i'll take your advice and setup a second local admin account, testing that right now.. Thanks for all your help on this issue.

0 Kudos
admin
Immortal
Immortal
0 Kudos