briandunk
Contributor
Contributor

Upgrading vCenter Server Appliance 5.0.x

I've been having some problems with my vCenter Server Appliance 5.0.0.3324 Build 472350 lately. Here is my list of problems:

  • Cannot access vCenter through the vSphere client yet I can access the Web App and everything seems to be fine
    • A reboot fixes this problem
  • vCenter freezes where I need to force the VM to shut down
  • SMTP doesn't work at all
  • I have a Health Status monitoring on Alert for the past 2 weeks. The triggers are:
    • New state = Red
    • New State = not available

I couldn't seem to find the problem on my own, after talking to VMware support they suggested I create a new vCenter VA and upgrade from one server to the other.

Greate idea but I have now run into a new problem on this. When I go to the upgrade page from my Web app I am supposed to select "destination" as my appliance role for my new server. The only role I get is "Source" which is supposed to be the pre existing vCenter.

Does anyone have any ideas that can help? I can get more information if needed. The main thing I was trying to solve initially before I started running into these problems is getting the SMTP emailed alerts working.

Thanks Everyone,

Brian

0 Kudos
2 Replies
BL460c
Contributor
Contributor

I think the "destination" option is only available for major updates.

Which one would have thought a complete Database change is, but apparently its not.

worst thing is, what you are trying (as was I) is the documented way to do the upgrade according to vmware pub document.

http://pubs.vmware.com/vsphere-50/index.jsp?topic=%2Fcom.vmware.vsphere.upgrade.doc_50%2FGUID-6A5C59...

I just did the upgrade using the "update" tab (as opposed to the upgrade) within the vcenter web interface and it worked fine.

briandunk
Contributor
Contributor

Thank you for your suggestion and help. I gave it a try and it worked perfectly. It took a little while making me think I broke something but after leaving it for the night it was done by morning and I have had no problems since.

0 Kudos