manleyjw
Contributor
Contributor

Upgrading from vCenter 6.5 to 6.7 Phase 1 failure with general system error, vix code = (1, 0)

I am attempting to upgrade a vCenter 6.5 appliance running on Photon OS 1.0 to vCenter 6.7.  When I run the installer, it fails with the error "A problem occurred while getting data from the source vCenter Server."  The installation log shows that the installer was able to log into both the vCenter admin account and the ESX server root account. Then the log shows a series of "general system errors":

2020-12-18T19:04:57.032Z - debug: initiateFileTransferFromGuest error: ServerFaultCode: A general system error occurred: vix error codes = (1, 0).

2020-12-18T19:04:57.032Z - debug: Failed to get fileTransferInfo:ServerFaultCode: A general system error occurred: vix error codes = (1, 0).

2020-12-18T19:04:57.032Z - debug: Failed to get url of file in guest vm:ServerFaultCode: A general system error occurred: vix error codes = (1, 0).

2020-12-18T19:04:57.032Z - error: Error in getting fileData for nodeType. Error: ServerFaultCode: A general system error occurred: vix error codes = (1, 0).

2020-12-18T19:04:57.032Z - error: Failed to read the nodetype, Error: A general system error occurred: vix error codes = (1, 0).

Then installer looks like it tries to login to the Photon OS cli:

2020-12-18T19:04:57.032Z - info: Checking if password expired
2020-12-18T19:05:02.044Z - info: Banner from server,
VMware vCenter Server Appliance 6.5.0.5200

Type: vCenter Server with an embedded Platform Services Controller


2020-12-18T19:05:02.045Z - info: Connection ready
2020-12-18T19:05:02.100Z - info: STDOUT: Last login: Fri Dec 18 18:11:46 2020 from 172.20.10.200


2020-12-18T19:05:02.101Z - info: STDOUT: date
exit

2020-12-18T19:05:02.280Z - info: STDOUT: Connected to service

2020-12-18T19:05:02.289Z - info: STDOUT:
* List APIs: "help api list"
* List Plugins: "help pi list"
* Launch BASH: "shell"


2020-12-18T19:05:02.291Z - info: STDOUT: Command> date

2020-12-18T19:05:02.300Z - info: STDOUT: Unknown command: `date'

2020-12-18T19:05:02.302Z - info: STDOUT: Command>
2020-12-18T19:05:02.303Z - info: STDOUT: e
2020-12-18T19:05:02.304Z - info: STDOUT: x
2020-12-18T19:05:02.304Z - info: STDOUT: i
2020-12-18T19:05:02.305Z - info: STDOUT: t
2020-12-18T19:05:02.306Z - info: STDOUT:

2020-12-18T19:05:02.335Z - info: Stream :: close
2020-12-18T19:05:02.335Z - info: Password not expired
2020-12-18T19:05:02.336Z - error: sourcePrecheck: error in getting source Info: ServerFaultCode: A general system error occurred: vix error codes = (1, 0).

The installer never issues the "shell" command to the CLI so it doesn't know how to parse the "date" or "exit" commands.

I haven't been able to find anything in the KB or on the interwebs that gives me a clue as to how to fix this.

 

0 Kudos
2 Replies
manleyjw
Contributor
Contributor

It lies!  The installer says the password is good but it's not.

I found this article: https://www.vmwareblog.org/upgrading-vcsa-6-5-6-7u2/

Which explains what happened and how to fix the problem.

0 Kudos
adityasen
VMware Employee
VMware Employee

0 Kudos