rmackenziesah
Contributor
Contributor

Upgrade vCenter 5U1 to 5.1 fails

Hi,

trying to upgrade my vcenter server to 5.1 but getting the below message

error 29114 cannot connect to db

I have tried this with a local express DB and a full 2008 R2 DB server and get same results. After trying that ive tried building a new vCenter and i still seem to get the same error. Can anybody point me in the right direction to fix this?

Thanks

0 Kudos
20 Replies
rmackenziesah
Contributor
Contributor

should have mentioned this is on the SSO part of the install

0 Kudos
spravtek
Expert
Expert

This excerpt is from the 5.1 release notes:

Installation fails when you attempt to install vCenter Single Sign On in an IPv6 environment
When you use the command netsh interface ipv4 uninstall with reboot in a purely IPv6 environment on Windows 2003, 2008, or 2008 R2, vCenter Single Sign On installation fails. The following error occurs: Error 29114. Cannot connect to database. In addition, this error might appear in the install.log file: Error: Failed to access configuration database: Network error IOException: Address family not supported by protocol family: create.


It's about the same error ... Though I don't know you have an IPv6 environment ... But maybe it will point you in the correct direction.

In the release notes there are more tips: http://www.vmware.com/support/vsphere5/doc/vsphere-esx-vcenter-server-51-release-notes.html

0 Kudos
rmackenziesah
Contributor
Contributor

Hi,

Our enviroment is ipv4 only. I have tried uninstalling ipv6 also to see if that made any difference.

thanks

0 Kudos
javier_dp
Contributor
Contributor

Just my 2 cents. Even if ipv6 was disabled in the tcpip properties, if i opened a cmd and did a ping to the fqdn of the server, an ipv6 address was resolved. Editing the hosts file brought back ipv4 to self-pinging the vcenter server.

0 Kudos
rmackenziesah
Contributor
Contributor

Hi,

Have tried changing the host file and the ping replys with an ip address.

I am at a loss as to why this is happening even if its on a new server straight from win2008r2 DVD and just added to the domain (no policies applied).

0 Kudos
cougar694u
Enthusiast
Enthusiast

What database are you using?  Did you use the option to install local SQLExpress?  Did you use the sql scripts included?

I'm asking because I have similar problems.  I'm using SQLExpress, but on another machine.  I used the scripts to create the database, users, and schema, and I get an error stating the user does not have sufficient privileges.  If I use 'sa' user, it passes that step, but later fails with the same error you get.

~Luke http://thephuck.com
0 Kudos
jvuletic
Contributor
Contributor

Same thing happened to me, and then I found this:

CannotGetJdbcConnectionException: Could not get JDBC Connection; nested exception is java.sql.SQLException: Charset 0x1A04D00000/Cp1250  is not supported by the JVM.

Change your db collation Smiley Wink

0 Kudos
cougar694u
Enthusiast
Enthusiast

The DB I manually created used collation SQL_Latin1_General_CP1_CI_AS, the one automatically created by the installer was also SQL_Latin1_General_CP1_CI_AS.

I was able to get the auto-installed SQL Express DB working.  I unchecked the IPv6 option for the NIC, disabled the firewall, and also changed the protocol settings in SQL Server Config Mgr.  Launch, SQL Server Config Mgr, expand SQL Server Network Configuration, click on Protocols for VIM_SQLEXP (that's the default instance name).  In the right pane, right-click TCP/IP, select properties, then go to the IP Addresses tab.

Here are the settings I changed (ignored all the others):

IP1 (I had an IPv6 address)

     Active: change to 'No'

     Enabled: already 'No'

IP2 (had my IPv4 address)

     Active: already 'Yes'

     Enabled: changed to 'Yes'

     TCP Port: changed to '1433'

IPAll

     TCP Dynamic Ports: deleted everything (had '0')

     TCP Port: changed to '1433'

After that, I had to use SQL Management Studio to change the sa password and run through the installer again, and it work.  I'm not sure exactly what 'fixed' the problem, but installation completed successfully and services are running.

~Luke http://thephuck.com
0 Kudos
ben-groundspeak
Contributor
Contributor

On the screen where you're entering the database connection information, select the checkbox "Use manually created DB users".  Then enter additional credentials for SQL Server login that has sysadmin rights on the SQL Server.  That fixed it for me.

My specific problem had these entries in the main install log:

RunSSOCommand:: error code returned is 14 while launching C:\Program Files\VMware\Infrastructure\SSOServer\utils\rsautil.cmd
Posting error message 29114

Which lead me to examine "C:\Program Files\VMware\Infrastructure\SSOServer\utils\logs\install.log" where I saw:

SQL [ CREATE LOGIN RSA_DBA WITH PASSWORD = '********', DEFAULT_DATABASE = vCenter_RSA ];

Password validation failed. The password does not meet Windows policy requirements because it is too short.

So apparently the auto-generated password the script used to create the RSA_DBA user didn't meet the password complexity requirements for my environment.  I assume this may be the case for others as well.

0 Kudos
DSeaman
Enthusiast
Enthusiast

I ran into several SSO installation gotchas, but worked up a basic installation guide that worked for me:

http://derek858.blogspot.com/2012/09/vmware-vcenter-51-installation-part-1.html

My source of the 29114 failure was forcing encryption on the SQL server, which worked great with all vSphere 4.x and 5.0 products.

Derek Seaman
0 Kudos
cougar694u
Enthusiast
Enthusiast

Funny, I started writing a blog post about this yesterday and polished it up a few minutes go: http://bit.ly/U9GLOL

~Luke http://thephuck.com
0 Kudos
Amandrek
Contributor
Contributor

Cougar694u's blog post is accurate.  Too bad he didn't finish the blog post a day earlier and saved me several hours.

I finally figured out the same issues with the database connectivity for SSO.  I ended up having to leave dynamic ports and use only port 1433 for my database connection because the SQL server wasn't listening on port 1433 at all using dynamic ports.

I will add that I also used the two user accounts created by the SQL scripts on the install media: RSA_DBA and RSA_USER by checking the box that indicates you will use manually created db user accounts.

Also, even though I had a named instance, the installer eventually went through with just the server name and database name without the instance specified after the hostname.

0 Kudos
cougar694u
Enthusiast
Enthusiast

True, I didn't add an insance either, just the servername.  I don't think JDBC really cares.

PS, I'm linking to Derek's blog regarding error 20020.

~Luke http://thephuck.com
0 Kudos
AWo
Immortal
Immortal

Even if you disable IPv6 at the interface level, it still is actve and registers itsel in DNS, for example. I found a failes DNS reverse lookup in the log file and that was due to the fact that there was an IPv6 address registered in DNS. The setup makes a reverse lookup at least for that IPv6 address which, of course, failed.

You need to create a 23 Bit DWOR value under "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters" called "DisabledComponents".


Depending on the value of that key, you can achieve the following:

0  to enable all IPv6 components

  • 0xffffffff  to  disable all IPv6 components except the IPv6 loopback interface. This  value also configures Windows to prefer using IPv4 over IPv6.
  • 0x20  to prefer IPv4 over IPv6 by changing entries in the prefix policy table.
  • 0x10  to disable IPv6 on all nontunnel interfaces (both LAN and Point-to-Point Protocol [PPP] interfaces).
  • 0x01   to disable IPv6 on all tunnel interfaces.
  • 0x11  to disable all IPv6 interfaces except for the IPv6 loopback interface.

I used 0 to disable it completely and the installation worked.

AWo

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
0 Kudos
Pvajdic
Enthusiast
Enthusiast

Hi,

We tried to upgrade our vCenter server 5.0 to 5.1 and also had issues with SSO installation. What ever we did "by-the-book" and KBs same error occurred 29114. Cannot connect to DB. After hours of investigating we finally found out by checking install.log that JVM does not support CP1250 code page!!

ERROR: Failed to access configuration database: Charset 0x1A04D00000/Cp1250  is not supported by the JVM.
com.rsa.tools.common.action.exception.ExitException: Failed to access configuration database: Charset 0x1A04D00000/Cp1250  is not supported by the JVM.

It would be nice to give more meaningful error description during installation instead of browsing thru tons of log files and records. Not to mention that if last log is located in SSO folder which is rolled back if you click ok (logs are still there but anyway).

Regards.

0 Kudos
gmihalinec
Contributor
Contributor

Hey!

How did you solve JVM and 1250 codepage problem?

I have the same issue... 😞

0 Kudos
Pvajdic
Enthusiast
Enthusiast

Hi,

Our database admin created new DB on existing vCenter server DB instance. During creation he set the following value on that new DB:

database collation - SQL_Latin1_General_CP1_CI_AS

Our server collation is Croatian_CI_AS and this is why we needed to change it for SSO DB.

After that everything went ok. Hope this helps you.

Regards,

Petar.

0 Kudos
rmackenziesah
Contributor
Contributor

Hi,

I think i ended up having 2 issues with the install and not sure what fixes what.

1) The collition was wrong on the DB like above poser

2) our domain forces passwords like that to be 15+ charactors and whatever was in the install/upgrade script had 4-5. I had to remove the machine from the domain to get the software upgraded.. i also suppose that just moving it in AD would work but was getting quite anoyed at that point! Smiley Happy

0 Kudos
emh
Contributor
Contributor

I have the same problem.

Upgrade from 5.0,clean install 5.1,bundled sql,remote sql,with domain,without...always the same error.

MSI (s) (64:40) [10:42:19:144]: Invoking remote custom action. DLL: C:\Windows\Installer\MSIA24A.tmp, Entrypoint: VMExecuteSSOCommand
Error 29114.Cannot connect to DB.
MSI (s) (64!A4) [10:42:28:535]: Product: vCenter Single Sign On -- Error 29114.Cannot connect to DB.
CustomAction VM_InstallCastle returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 10:42:28: InstallFinalize. Return value 3.
0 Kudos