markok
Contributor
Contributor

Upgrade path failure from vCenter v5.0 U2 to v5.1

Hi,

I noticed that VMware has released a new version on December for vCenter v5.0. This new Update 2 includes possibility to run vCenter Server on Windows Server 2012. Please see detailed information from the release notes: https://www.vmware.com/support/vsphere5/doc/vsp_vc50_u2_rel_notes.html

But I think this now enables a situation that you install vCenter Server 5.0 U2 on Windows Server 2012 and later you might want to upgrade to version 5.1. According to the readme pdf document of vCenter Server 5.1.0b says that it should be possible:

Upgrade Paths

vCenter Server 5.1.0b is not a patch release. You can upgrade to this version of vCenter Server from the following previous versions:

  • vCenter Server 4.1, 4.1 Ux
  • vCenter Server 5.0, 5.0 Ux
  • vCenter Server 5.1 GA, 5.1.0a

vCenter Server 5.1.0b supports the same database and OS configurations as the original release of vCenter Server 5.1. Note that if you have already installed or upgraded to the 5.1 GA version, you can only use the custom installation option to move to 5.1.0b. In this scenario you would first upgrade vCenter Single Sign On, followed by vCenter Inventory Service and then vCenter Server.

Notice the part of text which indicates that only OS configurations of original release is supported. So you cannot upgrade from v5.0 U2 -> v5.1.0b when running on Windows Server 2012. And yes, the application binaries might work correctly but it is not officially supported by VMware.

Maybe we need to wait vCenter Server v5.2 to have also support for Windows Server 2012. And only after that the upgrade path works correctly.

Br,

Marko

Tags (3)
0 Kudos
3 Replies
criver
Enthusiast
Enthusiast

Hi,

According to the following VMware Compatibility Guide, at this time vCenter Server is not supported for installing Windows Server 2012.

There's no telling when it will be supported.


http://www.vmware.com/resources/compatibility/search.php?deviceCategory=software&testConfig=17&produ...

0 Kudos
markok
Contributor
Contributor

Hi,

Please look at the release notes for v5.0 Update 2 (link above). It says that it is now supported:

What's New

This release of VMware vCenter Server 5.0 Update 2 offers the following improvements:

  • vCenter Server is now supported on Windows Server 2012

The problem now comes when trying to upgrade from v5.0 U2 to v5.1 where Windows Server 2012 is not supported. VMware documentation says that v5.0 Ux (meaning also this latest Update 2) can be upgraded to v5.1, but I guess they have now missed this Windows OS version part completely.

Br,

Marko

0 Kudos
criver
Enthusiast
Enthusiast

Hi,

Thank you for your feedback.

Obviously, VMware vCenter Server 5.0 Update 2 Release Notes are written as follows !!

https://www.vmware.com/support/vsphere5/doc/vsp_vc50_u2_rel_notes.html

Sorry, I didn't know that..

0 Kudos