swissmiss
Contributor
Contributor

Update from VCenter 6.7 to 7.0.3 Fail

Hello iwant update my vcenter from 6.7 to 7.0.3 and always stops in step 2 mirate from the old vcenter . i try 2 times always the same.

 

on the pre check i see this warnings i think maybe a problems the others warnings are ok.

  • Certificate specified for SSL Trust has expired
  • SSL Trust certificate does not match the current MACHINE_SSL_CERT for one of the service registration


its maybe a problem with the certificates? but in vcenter i see all certificates are green.

 

 

Error

Encountered an internal error. Traceback (most recent call last): File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 1448, in main vmidentityFB.boot() File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 340, in boot self.configureSTS(self.__stsRetryCount, self.__stsRetryInterval) File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 925, in configureSTS self.startSTSService() File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 845, in startSTSService returnCode = self.startService(self.__sts_service_name) File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 102, in startService update_services_runstate("start", None, False, False, svc_names=[svc_name]) File "/usr/lib/vmware/site-packages/cis/svcsController.py", line 834, in update_services_runstate ignore_err=ignore_err) File "/usr/lib/vmware/site-packages/cis/svcsController.py", line 696, in _update_services_runstate_svclist controller.start_svc(svc_id, explicit_op=explicit_op) File "/usr/lib/vmware/site-packages/cis/svcsController.py", line 444, in start_svc manual_start=True, check_state=True) File "/usr/lib/vmware/site-packages/cis/utils.py", line 1087, in service_start raise ServiceStartException(svc_name) cis.exceptions.ServiceStartException: { "detail": [ { "id": "install.ciscommon.service.failstart", "translatable": "An error occurred while starting service 'Traceback (most recent call last): File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 1448, in main vmidentityFB.boot() File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 340, in boot self.configureSTS(self.__stsRetryCount, self.__stsRetryInterval) File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 925, in configureSTS self.startSTSService() File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 845, in startSTSService returnCode = self.startService(self.__sts_service_name) File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 102, in startService update_services_runstate("start", None, False, False, svc_names=[svc_name]) File "/usr/lib/vmware/site-packages/cis/svcsController.py", line 834, in update_services_runstate ignore_err=ignore_err) File "/usr/lib/vmware/site-packages/cis/svcsController.py", line 696, in _update_services_runstate_svclist controller.start_svc(svc_id, explicit_op=explicit_op) File "/usr/lib/vmware/site-packages/cis/svcsController.py", line 444, in start_svc manual_start=True, check_state=True) File "/usr/lib/vmware/site-packages/cis/utils.py", line 1087, in service_start raise ServiceStartException(svc_name) cis.exceptions.ServiceStartException: { "detail": [ { "id": "install.ciscommon.service.failstart", "translatable": "An error occurred while starting service '%(0)s'", "args": [ "sts" ], "localized": "An error occurred while starting service 'sts'" } ], "componentKey": null, "problemId": null, "resolution": null } '", "args": [ "sts" ], "localized": "An error occurred while starting service 'sts'" } ], "componentKey": null, "problemId": null, "resolution": null }

Resolution

This is an unrecoverable error, please retry install. If you encounter this error again, please search for these symptoms in the VMware Knowledge Base for any known issues and possible resolutions. If none can be found, collect a support bundle and open a support request.

0 Kudos
4 Replies
a_p_
Leadership
Leadership

Please see whether https://kb.vmware.com/s/article/79741 helps.

Ensure that you backup the old vCenter (or at least create a snapshot) prior to apply the fix.

André

0 Kudos
Ajay1988
VMware Employee
VMware Employee

Run lsdoctor trust fix from https://kb.vmware.com/s/article/80469

If you think your queries have been answered
Mark this response as "Correct" or "Helpful".

Regards,
AJ
0 Kudos
maxr91
Contributor
Contributor

You didn't mention which vCenter 6.7 build version you have and which build of 7.0.3 you to install? 

I am not sure that problem really in Build Versions - but who knows, I recommend to check it

Try to patch vCenter 6.7 to latest version and after that to perform upgrade to vCenter 7.0.3

 

Check once again your settings that you are providing already during pre installation of vCenter 7.0.3

 

 

 

0 Kudos
berndweyand
Expert
Expert

patching will not solve the problem

also the templates in lsdoctor are not up to date - so you have to generate a template from a healthy vcsa. not everyone has access to multiple vcenter

0 Kudos