emaracan
Contributor
Contributor

Unable to login to vCenter 6.7

I am unable to log into vSphere or the VMSA interface. Both interfaces give me a "Unable to login" error.

Already checked:
- I am able to login to it via SSH as root.
- Already tried changing the root password, without any result. 
- applemgmt service is up and running.

Below the error I am getting from: cat /var/log/vmware/applmgmt/vami.log

2022-01-27T07:50:40.209 [11785]INFO:cgiutil:id=getStatus, action=query

2022-01-27T07:50:40.509 [11785]DEBUG:detwist:method = com.vmware.appliance.recovery.restore.job.get, args = ()

2022-01-27T07:50:40.509 [11785]DEBUG:detwist:Before PintProcessWrapper call

2022-01-27T07:50:40.509 [11785]DEBUG:detwist:After PintProcessWrapper call

2022-01-27T07:50:40.514 [11785]DEBUG:detwist:After execute call

2022-01-27T07:50:40.515 [11785]DEBUG:detwist:Before getResult Method

2022-01-27T07:50:40.515 [11797]DEBUG:detwist:At pintFunction before importing  Method = 'get', args = ()

2022-01-27T07:50:40.604 [11797]DEBUG:detwist:At pintFunction after importing  Method = 'get', args = ()

2022-01-27T07:50:40.605 [11797]DEBUG:detwist:Before exec invoke_method Method = 'get', args = ()

2022-01-27T07:50:41.12 [11797]DEBUG:detwist:Method = 'get', args = [<vmware.appliance.backup_restore.impl.RestoreJob object at 0x7fe6b9e5bcf8>]

2022-01-27T07:50:41.12 [11797]ERROR:detwist:Method failure = <twisted.python.failure.Failure vmware.vherd.base.pint.Error: pint.Error('com.vmware.applmgmt.err_status_does_not_exist', "Status for '%(0)s' does not exist.", **{'args': 'RESTORE'})>

2022-01-27T07:50:41.14 [11797]ERROR:detwist:Traceback (most recent call last):

  File "/usr/lib/python3.5/site-packages/twisted/internet/defer.py", line 653, in _runCallbacks

    current.result = callback(current.result, *args, **kw)

  File "/usr/lib/python3.5/site-packages/twisted/internet/base.py", line 441, in _continueFiring

    callable(*args, **kwargs)

  File "/usr/lib/applmgmt/base/py/vmware/vherd/base/detwist.py", line 151, in invoke_method

    dObj = _method(*realargs)

  File "/usr/lib/applmgmt/base/py/vmware/vherd/base/pint.py", line 979, in run

    ret = defer.maybeDeferred(method, self, *realArgs)

--- <exception caught here> ---

  File "/usr/lib/python3.5/site-packages/twisted/internet/defer.py", line 150, in maybeDeferred

    result = f(*args, **kw)

  File "/usr/lib/applmgmt/backup_restore/py/vmware/appliance/backup_restore/impl.py", line 135, in wrapper

    return func(*args, **kwargs)

  File "/usr/lib/applmgmt/backup_restore/py/vmware/appliance/backup_restore/impl.py", line 1187, in get

    args=op)

vmware.vherd.base.pint.Error: pint.Error('com.vmware.applmgmt.err_status_does_not_exist', "Status for '%(0)s' does not exist.", **{'args': 'RESTORE'})

2022-01-27T07:50:41.14 [11797]DEBUG:detwist:Method result = {'message': "Status for '%(0)s' does not exist.", 'attributes': {'args': 'RESTORE'}, '__error__': True, 'code': 'com.vmware.applmgmt.err_status_does_not_exist'}

2022-01-27T07:50:41.14 [11785]DEBUG:detwist:At getResult after pipe recv

2022-01-27T07:50:41.14 [11785]DEBUG:detwist:After getResult call

2022-01-27T07:50:41.14 [11785]DEBUG:detwist:Child process still alive, terminating it

2022-01-27T07:50:41.16 [11785]DEBUG:detwist:Process pid=11797, exitcode=0

2022-01-27T07:50:41.16 [11785]DEBUG:detwist:Before pPipe close

2022-01-27T07:50:41.16 [11785]DEBUG:detwist:After pPipe close

2022-01-27T07:50:41.17 [11785]DEBUG:detwist:Before cPipe close

2022-01-27T07:50:41.17 [11785]DEBUG:detwist:After cPipe close

2022-01-27T07:50:41.17 [11785]INFO:cgiutil:flow is: ['firstboot']

2022-01-27T07:50:41.17 [11785]INFO:cgiutil:firstboot: succeeded, 100, Starting VMware Performance Charts...

2022-01-27T07:50:41.17 [11785]INFO:cgiutil:Response : 

 <response><locale>en-US</locale><requestid>getStatus</requestid><value actions="enabled" id="status">succeeded</value><value actions="enabled" id="progress">100</value><value actions="enabled" id="details" /></response>

Additional logs can be found below:

root@photon-machine [ ~ ]# tail -f /opt/vmware/var/log/lighttpd/error.log

2021-12-17 10:54:44: (/build/mts/release/bora-13654878/studio/src/vami/apps/lighttpd/1.4.45/src/connections-glue.c.200) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request 

2021-12-17 10:54:45: (/build/mts/release/bora-13654878/studio/src/vami/apps/lighttpd/1.4.45/src/connections-glue.c.200) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request 

2021-12-17 10:54:45: (/build/mts/release/bora-13654878/studio/src/vami/apps/lighttpd/1.4.45/src/connections-glue.c.200) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request 

2021-12-17 10:54:45: (/build/mts/release/bora-13654878/studio/src/vami/apps/lighttpd/1.4.45/src/connections-glue.c.200) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request 

2021-12-17 10:54:51: (/build/mts/release/bora-13654878/studio/src/vami/apps/lighttpd/1.4.45/src/connections-glue.c.200) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request 

2021-12-22 12:24:47: (/build/mts/release/bora-13654878/studio/src/vami/apps/lighttpd/1.4.45/src/mod_proxy.c.1041) establishing connection failed: Connection refused 

2021-12-22 12:24:47: (/build/mts/release/bora-13654878/studio/src/vami/apps/lighttpd/1.4.45/src/mod_proxy.c.1153) proxy-server disabled: 127.0.0.1 8201 8 

2021-12-22 12:24:47: (/build/mts/release/bora-13654878/studio/src/vami/apps/lighttpd/1.4.45/src/mod_proxy.c.523) no proxy-handler found for: /api 

2021-12-22 12:24:52: (/build/mts/release/bora-13654878/studio/src/vami/apps/lighttpd/1.4.45/src/mod_proxy.c.1417) proxy - re-enabled: 127.0.0.1 8201 

2022-01-27 08:03:02: (/build/mts/release/bora-13654878/studio/src/vami/apps/lighttpd/1.4.45/src/connections-glue.c.166) SSL: -1 5 104 Connection reset by peer

 

0 Kudos
0 Replies