luizhbedin
Enthusiast
Enthusiast

URGENT - Task remain "in progress" ....

Hi all,

I need an urgent help on this, It's the second time that it happens to me and I don't know how to do to prevent this.

I have an environment, with 14 hosts with DRS and HA enabled. We had an network outage in 3 servers, and one of our hosts didn't switched the virtual machines to other server in cluster.

When this physical host came back online, I tryied to start the VMs and all tasks remained like "in progress". I waited for 25 minutes, I tryied to kill the process (but I could not Identify it correctly), restarted de the physical host.The host came online again, and the tasks remained "in progress". I restarted the VirtualCenter Server service on windows, and after 5 minutes the tasks failed.

I tryied to look on vmware logs, but no information about the host failure was found...

It is not the first time that I get a task that hangs. Does someone know why is this caused and how to solve it?

Thanks All..

0 Kudos
8 Replies
depping
Leadership
Leadership

I've seen this several times and the only way i've been able to fix this is by restarting the virtualcenter service.

Duncan

My virtualisation blog:

luizhbedin
Enthusiast
Enthusiast

Do you have any idea how to find the root cause of this? Is this a know issue?

Tks.

0 Kudos
admin
Immortal
Immortal

Is difficult to find the root cause but most of the time is cause by a ESX when the service console don't have enough memory available. This append when you have software running in the service console (the service console need is 272mb for itself), if you have other software running there you have to add memory. I did that to one of my customer and this solve is problem. Once again, you have to check log to find the root cause but by experience is what I see most of the time.

And depping is true, the best way to solve the problem is by restarting the service

0 Kudos
luizhbedin
Enthusiast
Enthusiast

Well, I don't believe that my server is running out of memory since the VC server has 4 GB RAM....

What log files do I need to look at? I already looked into log files inside ...windows\temp ...., /var/messages , virtual center

Does someone think that one of the possible causes is that I'm using SQL MSDE, intead full SQL server database?

Thanks..

0 Kudos
admin
Immortal
Immortal

First, I don't talk about the RAM of your VC but for each ESX host.

For MSDE, this DB version is not supported by VMware for production environment.

Have a look on the ESX log files /var/log...

0 Kudos
MikeTedescucci
Enthusiast
Enthusiast

I have seen this happen when the service console network port is shared with any other processes (virtual machine network, vmotion, etc) Not that I would ever do that in a production environment Smiley Wink

;-/

0 Kudos
luizhbedin
Enthusiast
Enthusiast

Thanks all for the replies,

The problem was solved (I know that I'm late to close this question.. but I'm just closing some opened questions...)

Acttualy, there was some troubles in this test environment the we created here... after review best practises,apply lastest hotfixes we fixed all these issues. by the way SQL wasn't developer version...

Thanks all.

0 Kudos
luizhbedin
Enthusiast
Enthusiast

Fixed the problem.

0 Kudos