FArmantrout
Contributor
Contributor

Tying two sites with PSC's but they are not replicating.

Greetings

My First post / need for assistance via the Tech network

I have two sites.  In my case two new VBlock's with VCenter and ESXi at 6.0 update 1.  The VCenter's are windows based.

Each site was built separately and consist of two external PSC's in a replicated primary / secondary setup and one VCenter.  Individually each VCenter sees the PSC pair it is associated with when built up.

Both sites were built using the same SSO domain of vcenter.local but the second site I am trying to tie in was not created from the first site, it was build on its own.

The PSC's and both VCenters are on the same IP Subnet but that net is joined with a Cisco OTV Router so they MAY see some of the same traffic

I am trying to tie both pairs of PSC to each other to form a long distance replication / Enhanced Linked Mode, in my case across town and not across the pond, so we can VMotion between one VCenter's

Using the command line on each of the PSC I tried to add replication between all four PSC's using the following:

/usr/lib/vmware-vmdir/bin/vdcrepadmin -f createagreement -2 -h psc_fqdn_or_static_ip -H partner_psc_fqdn_or_static_ip -u administrator

I have run the create on all four PSC's to link them to the other PSC's so they all cross connect to each other in a full mesh tie together.

When I run ./vdcrepadmin -f showservers -h localhost -u administrator it only shows the original pair of PSC's that are in the same data center.

If I show the partners with ./vdcrepadmin -f showpartners -h localhost -u administrator

It lists all three of the other hosts I partnered them with

In the ./vdcrepadmin -f showpartnerstatus -h localhost -u administrator

The original partner the local PSC was linked to shows replication is working and normal but the two I joined the PSC to from the other site are both showing available but the replication count is not incrementing and is stuck at 0

Did I miss a step or is there a way to get them to start replicating or do I have to go back and build from scratch the second site which has a Few VM's in place.

Any guidance would be appreciated.

Fred

0 Kudos
0 Replies