zemotard
Hot Shot
Hot Shot

Transaction log full what can I do ?

Jump to solution

Hi, i have change from mdse to sql express 2005.

The I installed VC 2.5

But Now, after 3 running days, I have this message, and my VC can't start.

The transaction log for database 'VCDB' is full. To find out why space in the log cannot be reused, see the log_reuse_wait_desc column in sys.databases

What can I do, because I'm not a DBA.

Regards

Best Regards If this information is useful for you, please consider awarding points for "Correct" or "Helpful".
0 Kudos
1 Solution

Accepted Solutions
Dave_Mishchenko
Immortal
Immortal

You'll want to download and install SQL Express Management Studio - . Once you have it installed, start the Management Studio, connect to your SQL install and right click on the database. Then set the recovery model to simple - see the options tab (see attached image).

View solution in original post

0 Kudos
9 Replies
RussH
Enthusiast
Enthusiast

Using SQL Management Studio, select the 'VCDB' database right click and there should be an option to Backup, backup the transaction log to a file. Although this wont physically shrink ths size of the active log file (you could use dbcc shrinkfile to do this), it will create space internally within the file.

I personally set my VC database to 'Simple' recovery mode, but beware this in essence is circular logging and you will lose all data (e.g. performance metrics and any recent VC config) prior to your previous full backup if you end up losing the DB for any reason.

RParker
Immortal
Immortal

Go to the control panel. Click on ODBC. Click on SystemDSN tab. Then find the VM Management (I think that's what its called) and click setup. Don't change any settings, just click next, by the third screen, there is a place with a check box by it that shows where the logs are stored. Look carefully, there is a transaction log and a ODBC message log. Next to the Transaction log copy paste the path, and put it the run command window. Click CANCEL on the ODBC, and close the control panel.

Then click ok, use notepad to open the file. Scroll to the end, see why it's logging so many messages. Do a save as, and save the log in another location.

Then somewhere in the start menu there is a SQL Sevice manager, open it. Stop the SQL Express. Delete the log from the same path it was (just delete the entire file). Then start the SQL Express service again, and the VSS service. Everything should be good now.

0 Kudos
zemotard
Hot Shot
Hot Shot

Thanks, how do you change the DB mode to 'Simple' recovery mode ?

Best Regards If this information is useful for you, please consider awarding points for "Correct" or "Helpful".
0 Kudos
zemotard
Hot Shot
Hot Shot

I haven't any path checked ....

Best Regards If this information is useful for you, please consider awarding points for "Correct" or "Helpful".
0 Kudos
RussH
Enthusiast
Enthusiast

In SQL Managment Studio - right click the 'VCDB' database, and select properties.

One of the options should be "Recorvery Model" change this from Full to Simple. (bear in mind the trade offs i mentioned previously from having database in simple recovery mode)

zemotard
Hot Shot
Hot Shot

This option is no available in sql 2005 express ...

Best Regards If this information is useful for you, please consider awarding points for "Correct" or "Helpful".
0 Kudos
zemotard
Hot Shot
Hot Shot

This message appears

How can I find this comlunm ?

Regards

Best Regards If this information is useful for you, please consider awarding points for "Correct" or "Helpful".
0 Kudos
Dave_Mishchenko
Immortal
Immortal

You'll want to download and install SQL Express Management Studio - . Once you have it installed, start the Management Studio, connect to your SQL install and right click on the database. Then set the recovery model to simple - see the options tab (see attached image).

View solution in original post

0 Kudos
zemotard
Hot Shot
Hot Shot

Perfect guy, thanks for all.

Regards

Best Regards If this information is useful for you, please consider awarding points for "Correct" or "Helpful".
0 Kudos