sonyvadakelvmwa
Contributor
Contributor

Srvc_StartService::vctomcat service NOT STARTED Error: 1068. VCENTER 5

getting following error when installing vcenter 5 .

< VMware VirtualCenter-build-455964: 09/15/11 15:34:47 Srvc_IsServiceStatus::serviceStatus: 4 VMware VirtualCenter-build-455964: 09/15/11 15:34:47 Srvc_IsService VMware VirtualCenter-build-455964: 09/15/11 15:34:47 OpenSrvcManager VMware VirtualCenter-build-455964: 09/15/11 15:34:47 OpenSrvc VMware VirtualCenter-build-455964: 09/15/11 15:34:47 Srvc_IsService::done Service EXISTS VMware VirtualCenter-build-455964: 09/15/11 15:34:47 OpenSrvcManager VMware VirtualCenter-build-455964: 09/15/11 15:34:47 OpenSrvc VMware VirtualCenter-build-455964: 09/15/11 15:34:47 Srvc_IsServiceRunning::done Service is NOT RUNNING VMware VirtualCenter-build-455964: 09/15/11 15:34:47 OpenSrvcManagers VMware VirtualCenter-build-455964: 09/15/11 15:34:47 OpenSrvcManager VMware VirtualCenter-build-455964: 09/15/11 15:34:47 OpenSrvcs VMware VirtualCenter-build-455964: 09/15/11 15:34:47 OpenSrvc VMware VirtualCenter-build-455964: 09/15/11 15:34:47 StartSrvc::NumArgs: 0 VMware VirtualCenter-build-455964: 09/15/11 15:35:49 StartSrvc::ERROR_SERVICE_DEPENDENCY_FAIL The service depends on another service that has failed to start Error: 1068 VMware VirtualCenter-build-455964: 09/15/11 15:35:49 Service could not be started. VMware VirtualCenter-build-455964: 09/15/11 15:35:49 Srvc_StartService::vctomcat service NOT STARTED Error: 1068 VMware VirtualCenter-build-455964: 09/15/11 15:35:49 End Logging VMware VirtualCenter-build-455964: 09/15/11 15:35:52 Begin Logging VMware VirtualCenter-build-455964: 09/15/11 15:35:52 --- CA exec: VMCleanupRegistry VMware VirtualCenter-build-455964: 09/15/11 15:35:52 Getting Property TEMPLATE = x64 VMware VirtualCenter-build-455964: 09/15/11 15:35:52 Warning: Deleting a key that isn't empty: "HKEY_CURRENT_USER\VMW" VMware VirtualCenter-build-455964: 09/15/11 15:35:52 Warning: Deleting a key that isn't empty: "\InstRTPaths" VMware VirtualCenter-build-455964: 09/15/11 15:35:52 End Logging>

0 Kudos
13 Replies
sclausson
Contributor
Contributor

i'm having the same error related to the tomcat service failing.  Were you able to find a fix?  thanks!

0 Kudos
DavidPatrick
Enthusiast
Enthusiast

Me too, I 'm having the same issues. Any ideas?

Cheers

0 Kudos
cfox1
Contributor
Contributor

Same issue here - anyone?

0 Kudos
DenisDyomin
Contributor
Contributor

I have the same issue.

Does anyone resolved this problem?

0 Kudos
sclausson
Contributor
Contributor

I was able to resolve this by going into windows services  console and looking at the accounts that the VMware services were running under.  When I performed the upgrade it used the local account that I was logged in with, and the services then fauiled to start.  In my case, I changed these to run as Local System, and then everything started up ok (including the VMware Web Service / Tomcat).  Hope this works for you as well.

0 Kudos
DenisDyomin
Contributor
Contributor

Thanks a lot.

0 Kudos
vmjellz
Contributor
Contributor

So during installation there are no services using your local account (because it isn't installed yet). Once the installer fails, changing the service log on accounts still does not allow them to start correctly. Can you please elaborate on the procedure? Does anyone know of a VMware KB to support this glitch? I have not been able to find any. Thank you!

0 Kudos
arrietty
Enthusiast
Enthusiast

I too am getting this error in my log.  The upgrade fails with 'exeption thrown while executing SQL script'.  In the logs I have the above vctomcat as above errors but all my VM services are using local system account including the VMware VirtualCenter Management Webservices which is the tomcat6.exe.  Has anyone got any thought?

0 Kudos
cfox1
Contributor
Contributor

Thank you for your message. I will be out of the office from Thursday, February 9, 2012 through Thursday, February 16, 2012.

If you need assistance with a technical issue, please contact Ideal Service Desk at 412-349-6678.

For non-technical matters, please contact Al Stasko at astasko@idealintegrations.net or 412-349-6680.

Thank you,

0 Kudos
jhwlw
Contributor
Contributor

Same issue here. I even had my vCenter 4 completely rebuilt and the database restored. Same problem again, upgrading to vCenter 5. That's ridiculous!

0 Kudos
johnnymcconny
Contributor
Contributor

I'm having this same issue. I'm on the phone with VMware support right now trying to fix it. So I figured I would try looking up fixes but I found this one with no fix.

0 Kudos
arrietty
Enthusiast
Enthusiast

Well good luck.  I never got a fix for it- however it might have just been an error relating to another issue.  My SQL express database was too full of rubbish and logs to install vsphere 5 so VMware support helped me to clean it up.  I then had to start all over again with the install, and I did not get the above error message again.

0 Kudos
johnnymcconny
Contributor
Contributor

0 Kudos