jayschupp
Contributor
Contributor

Resource module 'alarm' not found

Hoping someone here has seen this...

My vSphere log is full of these messages.

Resource module 'alarm' not found. Using from default locale...

'alarm' cycles through 'perf', 'enum' and 'vm'

I'm not sure what the default locale would be. I did stop the vCenter server services as I thought maybe something else was using the Tomcat port 8080 but that wasn't the problem.

Thanks in advance.

...Jay

0 Kudos
15 Replies
RodgerOrr
Contributor
Contributor

Our vSphere 4 system log is also full of these messages. We generate over 2048 in 1/2 a day. Anyone have the answer?

Resource module 'vm' not found. Using from default locale...

Rodger

0 Kudos
egodette
Contributor
Contributor

Anyone find an answer to this issue?

0 Kudos
HannaL
Enthusiast
Enthusiast

Do you have any 3rd party plugin's? ie anything in vCenter that didn't ship with vCenter?

Thanks

Hope that helps, Hanna --- BSCS, VCP2, VCP VI3, VCP vSphere, VCP 5 https://www.ibm.com/developerworks/mydeveloperworks/blogs/vmware-support-ibm
0 Kudos
onefstprld
Contributor
Contributor

seeing the same thing here - by any chance are you guys running SRM 4 too?

0 Kudos
mowgus
Enthusiast
Enthusiast

Experiencing the same issues as well...logs are full of these messages. Did anyone come up with any sort of solution?

Thanks

0 Kudos
HannaL
Enthusiast
Enthusiast

Yes here is the answer.

<!-- /Main Body Table -->

The vCenter Server vpxd log reports this message: Resource module 'xxxx' not found. Using from default locale

http://kb.vmware.com/kb/1022708

Hope that helps,

Hanna

---

BSCS, VCP2, VCP VI3, VCP vSphere

Hope that helps, Hanna --- BSCS, VCP2, VCP VI3, VCP vSphere, VCP 5 https://www.ibm.com/developerworks/mydeveloperworks/blogs/vmware-support-ibm
0 Kudos
onefstprld
Contributor
Contributor

I tried this work around last week when it was released but it didn't work. I know that it is related to applications using the vSphere API but it will be hard to track down.

Although I believe the workaround works for some but not all.

0 Kudos
mowgus
Enthusiast
Enthusiast

The fix described in the article worked for me. I created a new 'en_US' folder, copied the contents of the 'en' folder to it and restarted the VC services. Annoying 'locale' log entries have stopped.

0 Kudos
rott
Enthusiast
Enthusiast

Hi,

today I experienced the same behavior on a vCenter server. The KB1022708 didn't help me. So I started procmon and traced the start of the vCenter server service. After app. 3-5 seconds the vpxd log showed the first "Resource module ... not found. Using from default locale" messages. A few milliseconds earlier the procmon trace showed that vpxd.exe started looking in the registry under

HKU\\ControlPanel\International\Locale

We had an english system (Windows 2003) but the service account user comes from a german domain and so the value was 00000407 (german language). Parallel to this the vpx-log showed something like "setting default language to 'de' ".

I just changed that value to 00000409 (US) and restarted vCenter. All the Ressource entries were gone and procmon showed that it went on reading the next regional settings like time format (it didn't before)! But I think it will be better to update all the regional settings to english for that user - I'll do tomorrow...

Maybe it'll just occur because of the service account that vCenter service is started with because I have several pure german systems that don't have the problem - but they've been started with the system account. Also it could be just the combination: english system with a service account user with a different language.

Please post to this message, if you resolved your problem with that solution and tell me the language of the OS and User (if any).

Thanks!

Michael

0 Kudos
onefstprld
Contributor
Contributor

I am eager to try this fix - but if the vCenter service starts with Local System, which registry would that fall under HKEY_USERS?

0 Kudos
rott
Enthusiast
Enthusiast

Hi,

I'm not sure - I would first try to set the "Regional and Language Options" in control panel all to English US - under advanced make sure to check the box to apply these settings to the default user! VMware loves the default user Smiley Wink

These settings require a reboot!

If that doesn't help, you can start the procmon from sysinternals, and filter for "Process Name=vpxd.exe" and record the vCenter start. Then match the time with the time when the log begins to complain about the locale. There you can find the registry access for the locale... If you don't feel comfortable with that, you can also send me the procmon log (save as .csv).

What language is your OS?

Michael

0 Kudos
RLI27
Contributor
Contributor

@onefstprld: LocalSystem uses usualy the HKU\.DEFAULT settings.

But thanks for the information rott! Under http://HKEY_USERS\.DEFAULT\Control Panel\International I changed the locale=00000807 (Swiss German) to locale=00000407 (US) and for now (after restarting the vCenter Service) the annoying entries are gone! Cool!

Cheers

0 Kudos
Hooooooi
Contributor
Contributor

Hi, I got stuck trying to modify the locale settings. I got round the issue by adding an extra locale folder:"C:\Program Files\VMware\Infrastructure\VirtualCenter Server\locale\nl_NL", and copying the files from the "en" folder. Only needed to restart the service...

0 Kudos
Hooooooi
Contributor
Contributor

Hi, I got stuck trying to modify the locale settings. I got round the issue by adding an extra locale folder:"C:\Program Files\VMware\Infrastructure\VirtualCenter Server\locale\nl_NL", and copying the files from the "en" folder. Only needed to restart the service...

0 Kudos
rott
Enthusiast
Enthusiast

Addition to my answer above:

Hi!

Just had the same behavior with a different cause today - but with vCenter 4.1 and German Client Language at the vSphere Client PC!

Here it just helped to call ALL off the vSphere Clients with the option "-- locale en_US" - and all the messages were gone - we tested it also forth and back and messages appeared and were gone depending on the locale.

Hope that helps someone!

Michael

0 Kudos