sreboulet
Contributor
Contributor

Question regarding seeing files (such as VMDK)

I hope this isn't some newbie question, but I'll ask it anyway.

We've recently deployed VMware ESX, converted a number of servers over to VMware as well as deployed new ones. We had an instance where a VMserver would no longer would start (kept saying missing files). Based on reading similar case, I removed it from inventory, created a new VM and for the hard drive went to 'attach to an existing drive". When I browsed to the directory, I found it empty. I then noticed all the directories were empty.

Going into Inventory, I opened up the VMFS stores, and while I could see directories, I couldn't see any files. This held true for my login as well as the Administrator.

Now I know these files are there as the VM's work, and I can see the available space go down when I add additional VM's, but why can I not see them?

I'm still searching this list to see if anyone has already asked this, but I would appreciate it if anyone had any suggestions. Also, my account is setup as Administrator, so I would imaging that I have the rights to see these files.

Thank you.

0 Kudos
3 Replies
cemetric
Enthusiast
Enthusiast

Whatabout if you login into the COS and browse the volumes/folders there, or use a tool like WinSCP or Veeam SCP, can you see the files then ?

Are the files hidden, maybe the admin account you're using doesn't have the necessary rights to see the files ?

Never ran into this problem, interesting Smiley Happy

C.

0 Kudos
esiebert7625
Immortal
Immortal

I've seen cases where VC acts flaky when trying to use it's built-in file manager to browse the datastore, it usually ends up being a permissions issue. Try using the command line or WinSCP as suggested to browse the server. WinSCP has a Windows Explorer like interface and is alot better then the built-in file manager.

WinScp (file transfer) - http://winscp.net/eng/index.php

Also see this post...

http://www.vmware.com/community/thread.jspa?messageID=600512

Message was edited by:

esiebert7625

0 Kudos
sreboulet
Contributor
Contributor

I completely spaced on replying to this thread. I am up and running say that rights appear to have been the issues. once I connected directly to the blades rather than to the ESX server, I could once again see the files and relinked the VM server.

0 Kudos