mbalser
Contributor
Contributor

Permission to use "Send Ctrl-Alt-del" in console is missing after upgrade to vSphere4 from VC2.5

Hello,

since we've upgraded to vSphere4 the "Send Ctrl-Alt-del" command in console session is grayed out for users, not for admins. The permission "Virtual Machine > Interaction > Console Interaction" is set in the role definition. We didn't change anything in the role definitions after upgrading.

Which permission did I have to set to allow the "Send Ctrl-Alt-del" command?

Best regards

Matthias

0 Kudos
21 Replies
admin
Immortal
Immortal

Is ur VM running? You just need to have "Virtual Machines--> Interaction --> Console Interaction" privilege for doing this operation.

-Sandeep

0 Kudos
jessek
Contributor
Contributor

We're having the exact same problem, as one of my co-workers pointed out to me today. I'm admin, she is not. The VMs are all powered on. If I right click on a VM the option to CAD is grayed out. If I open the console and use the VM menu, the option is available to me there. For her it was grayed out in both spots and I had to do it for her. She was a Virtual Machine User, and even though all of the permissions for that role looked just fine I upped her to a Virtual Machine Power User. It was still grayed out for her.

Jesse Kozikowski Aspirus, Inc
0 Kudos
admin
Immortal
Immortal

The option will be enabled only when you have the console of the VM opened. So you open the console and then check the option by right clicking on the VM.

Please check for the virtual machine user you have the privilege "Virtual Machines--> Interaction --> Console Interaction" assigned (You can verify this from the Roles tab). If not, assign this manually and your issue should be resolved.

-Sandeep

0 Kudos
jessek
Contributor
Contributor

I had the "Virtual Machine User" role set for this user, and that role does have "Console Interaction" checked. I had her open the console, use the VM menu in the console's menu bar, and CtrlAltDel was grayed out.

I just tested this with another standard user account. Added permission for this specific VM, searched for and selected the new user account, and applied the Virtual Machine User role. I logged into the vSphere Client and see this one VM listed, as I should, opened the console, and CtrlAltDel is still grayed out.

Jesse Kozikowski

Aspirus, Inc

Jesse Kozikowski Aspirus, Inc
0 Kudos
dpablo
Contributor
Contributor

i have the same problema, any person have a solution?

0 Kudos
dhenson7578
Contributor
Contributor

Same problem here too, one of our users brought it to my attention.

I found that if I give the same user "VM user" rights at the root and enable propagation, the CtrlAltdel functionality returns. Unfortunately, I don't want to give every user access to every VM in our environment. So it has nothing to do with the "VM user" role template itself, but where it's applied to.

BTW - I also tried to apply the role at the root without propogation, but that did not work.

Message was edited by: dhenson7578

0 Kudos
dpablo
Contributor
Contributor

Well this is firts step to found a key to resolve the problem but make permision from root tree its very security problem for a lot of companies

0 Kudos
watermannj
Contributor
Contributor

Add us to the list. Very frustrating when you've got many folders of VMs and the people assigned can't log in. We're going to allow RDP for those people configured via a GPO since they're Windows servers.

0 Kudos
zik
Enthusiast
Enthusiast

We found that users can still use "Ctrl-Alt-Ins", even when the "Send Ctrl-Alt-Del" option is greyed out.

0 Kudos
dpablo
Contributor
Contributor

Estare ausente hasta el 1 de Septiembre / I'll be out of office until 1 of September

En estos momentos estoy fuera de la oficina, si tiene una urgencia puede llamar al : 902056355 o +34 911201995

Recuerde adjuntar su nombre, empresa y motivo en el mensaje y le llamarenos en no más de 24 horas.

También puede mandar un email a emergencias@csr-online.net y se pondrán en contacto con Ud.

At this momment i am out of office, if you have an emergency please call to +34 911201995 ext.101 and leave a message call you in less than 24 hours.

You can send an email to emergencias@csr-online.net too and we contact you!

David Pablo

Grupo CSR online

Telf Nacional. 902056355 Ext.101

Telf Internacional. +34.911201995 Ext.101

Fax: +34.935874122

0 Kudos
Jan_MS
Contributor
Contributor

We have the same problem. Did someone open a support call for this case?

0 Kudos
mbalser
Contributor
Contributor

Ich bin am Donnerstag, 13.08.2009 wieder im Büro und kann bis dahin E-Mails nicht oder nur sporadisch lesen. Rufen Sie bitte in dringenden Fällen unser Teamtelefon an (09131/920-4141).

Ihre E-Mail wird nicht weitergeleitet.

Grüße Matthias Balser

0 Kudos
dpablo
Contributor
Contributor

Estare ausente hasta el 1 de Septiembre / I'll be out of office until 1 of September

En estos momentos estoy fuera de la oficina, si tiene una urgencia puede llamar al : 902056355 o +34 911201995

Recuerde adjuntar su nombre, empresa y motivo en el mensaje y le llamarenos en no más de 24 horas.

También puede mandar un email a emergencias@csr-online.net y se pondrán en contacto con Ud.

At this momment i am out of office, if you have an emergency please call to +34 911201995 ext.101 and leave a message call you in less than 24 hours.

You can send an email to emergencias@csr-online.net too and we contact you!

David Pablo

Grupo CSR online

Telf Nacional. 902056355 Ext.101

Telf Internacional. +34.911201995 Ext.101

Fax: +34.935874122

0 Kudos
aveenema
Contributor
Contributor

Well,.... i'm still in the office working with this frustrating bug... anyone had a workaround jet?

I can confirm that CTRL-ALT-INS still works. Also upgraded to vSphere, and not changed the VM User role.

- Arnold -

0 Kudos
altmeyer
Contributor
Contributor

Hello aveenema,

I openend a Support Request just 5 minutes ago. I keep you updated.

Greetings from Freiburg,

Micha

0 Kudos
aveenema
Contributor
Contributor

just noticed your update... I did as well filed a case at VMware... let's see.

The first thing the asked me to do was a uninstall/install of VMware Tools in the guest. But that didn't work.

Kind regards,

Arnold Veenema

0 Kudos
altmeyer
Contributor
Contributor

I got the following answer from the support:

"This fix has now already been approved for

VC4.0 update 1 and is currently scheduled for release in late Q3 2009.

At this juncture, there is very little more

I can do to help and therefore will move to close this SR.

Should you require any further assistance

in the future, don't hesitate to open a new SR."

Well, we have to wait...

0 Kudos
matkay521225
Contributor
Contributor

We're having the exact same problem. I've tried all the fixes in this thread as well. No luck. Guess we will just have to wait.........

FYI, our environment was wiped clean. Clean installed of ESX, vCenter, and the vCenter DB. Everything was brand new.

0 Kudos
simtr
Contributor
Contributor

Same issue here...

I've also found what I think is a related permission issue with console access, via the Web interface.

With default Virtual Machine User or Virtual Machine Power User, if you log on using the Web UI, you cant seem to open the console. I justget a time out issue in multiple browers.

Spent a fair bit of time trying to get to the bottom of both these issues, annoying!

Anyone know if there is an official fix yet? or are we waiting for update 1?

0 Kudos