hardke01
Contributor
Contributor

PRTG and vCenter

I am having issues getting the PRTG to monitor vCenter servers. I have setup the PRTG system with the correct credentials to login to the vCenter system however when i go to add a new VMware sensor to the VC device i get the following message.

Sorry, the scan for available monitoring items has failed!

Error Message:"HTTP/1.1 500 Internal Server Error"

According to the minimal amount of prtg documentation available the setup of the sensors should be as easy as adding the sensor and saving. However it seems to not be the case. I have also tried the authentication to via https using a trusted certificate and still no luck.

Does anyone have any experience or pointers to getting the vc and all its managed servers into the prtg monitoring system?

Monitoring the ESX host directly works fine. The the virtual server option thats supposed to work with the VC does not, and as we utilise vmotion would be better for our environment.

0 Kudos
1 Reply
dennisowens41
Contributor
Contributor

@hardke01, I realize this is an older post, but I wanted to reply so that anyone out there with the same issue might find the answer faster.  Like Im sure you did, I eventually found this to be a problem with the local firewall wall on the machine I had PRTG installed on.  By opening the local firewall up I was instantly able to connect to my vVcenter and see all of my individual VMs.

I havent identified exactly which port needs to be cleared yet, but I believe it to be 23560.

Hope this helps save someone some time.

0 Kudos