VMware Cloud Community

Orphaned VM with shared disk not deleting

After following instructions found on the internet to delete an orphaned VM, I am not having much success in getting the VM removed from Vcenter.


Running Vsphere 6.5 on Purestorage array presented datastores, esxhosts are running on UCS enclosure blades UCSB-B200-M4

VMs are windows 2012 R-2

Shared storage was presented to Primary and additional disk was added to the Secondary

I have 2 VMs clustered using MS clustering but sharing a disk on the Datastore. I had to delete the VMs;

the secondary VM deleted from Vcenter without issue after shut-down,The Primary VM in the cluster would not delete.

The Primary VM in the cluster is displaying in Vcenter as (orphaned)

Orphaned VM has no Actions to be performed as all options are greyed out within Vcenter with the exception of orchestrator tasks and Tagging

Vcenter displays location on host, nothing on the ESX host after console & SSH'ing into blade

Vcenter displays location on Datastore, nothing in datastore pertaining to this VM

Not a single VMDK in site for this orphaned VM

I tried logging directly onto the host using SSH and followed the instructions on removal from here : Removing Inaccessible VMs from vCenter | Virtualization for Service Providers

I rebooted the hosts after restarting the VPXA and HOSTD svc restarts; VM still displays within Vcenter as orphaned after logging out/logging back in

At my wits end as this VM is nowhere except within Vcenter.

I have tried the following instructions to remove this Orphaned VM with no success, Anyone experience this or have another solution :

How to deal with orphaned virtual machines

How to deal with orphaned virtual machines

[SOLVED] an orphaned VM in vCenter - Spiceworks

0 Kudos
1 Reply
Hot Shot
Hot Shot

Here's a workaround I found some time ago by accident:

1. Open vCenter and navigate to VMs and Templates view

2. Create new folder such as "Delete" and move the orphaned VM into it

3. Right click on "Delete" folder and remove it.

This should remove both the temporary folder and the VM inside it. I used this method multiple times on many failed VMs and it worked each time. Give it a try!

Cheers, Paul Wilk
0 Kudos