wkwicker
Enthusiast
Enthusiast

Operation Timed Out When migrating VM across SLOW WAN

Hello,

I have one datacenter that is connected by a fractional T1 link so the throughput is probably less than 100KB/sec. I have created a virtual machine at the main site and am trying to migrate it with it off to the remote site. I fully expect it to take a few days to get there but I get an Operation Timed Out after about 20 minutes. The status is "In Progress" with no percent yet displayed. The only thing I see from the log is "Unexpected exception (vim.fault.Timedout) while relocating VM. Aborting." It does create the files on the VMFS at the remote site and then deletes them since the task failed.

Just to test, I migrated a small VM, thin provisioned with only about 1MB provisioned and it worked just fine.

Has anyone done this before or is this link just too slow to migrate a normal size VM with vCenter Server?

I am using ESX 4.1 and vCenter Server 4.1.

Tags (3)
0 Kudos
4 Replies
vmroyale
Immortal
Immortal

Hello.

Are you trying to cold migrate or vMotion? How big is this VM? I have cold migrated fairly large VMs over a slow WAN link with no issue.

Good Luck!

Brian Atkinson | vExpert | VMTN Moderator | Author of "VCP5-DCV VMware Certified Professional-Data Center Virtualization on vSphere 5.5 Study Guide: VCP-550" | @vmroyale | http://vmroyale.com
0 Kudos
wkwicker
Enthusiast
Enthusiast

This is a cold migrate. I do a right click, migrate, change datastore and host. This VM is 45GB. What size VM's did you migrate and over what type link?

Perhaps I posted this too soon. The first few I did timed out at exactly 20 minutes. This one has been going on for 4 hours. It still shows "In Progress" with no % shown but is actually updating the .vmdk on the destination so this one might work.

0 Kudos
vmroyale
Immortal
Immortal

I've moved VMs well over 100 GB, using the same connection you have. I typically start them at the close of business and let them go overnight. They always finish, but it is never fast!

Brian Atkinson | vExpert | VMTN Moderator | Author of "VCP5-DCV VMware Certified Professional-Data Center Virtualization on vSphere 5.5 Study Guide: VCP-550" | @vmroyale | http://vmroyale.com
0 Kudos
wkwicker
Enthusiast
Enthusiast

This morning, after 22 hours, if failed with the message Cound not complete network copy for the file myvm/myvm.vmdk.

The logs say the following which doesn't really give a reason for the failure.

NfcNetTcpWrite: bWritten: -1

NfcNet_Send: requested 272, sent only -1 bytes

NfcFile_SendMessage: hdr send failed:

NfcBuf_Send: failed to send next file portion

Nfc_PutFile: failed to send the buffer

File transfer failed: Network error -- NfcBuf_Send: failed to send next file portion

Closing NFC connection to server

This WAN link may be slow but it is a solid one. Nothing else has drop problems so I wouldn't think it would be related to my WAN link.

I probably won't do this often so I'm just creating a split tarball and will sftp it to the destination, extract, and import. It would be nice if there is anything I can change to get this working in my environement if anyone has any ideas of if you can point me to a different log to look at.

0 Kudos