VMware Cloud Community
mlarrivee80
Contributor
Contributor

Migration-Assitant error during prechecks from Windows 5.5 to VCSA 6.5

This is the error I get while running the migration assistant on my Windows 5.5 vCenter server.  VMware update manager is working correctly so my guess is that the database is available and working.

Error messages: Error: Unable to connect to VMware Update Manager Database, Cannot proceed with migration

Resolution: Please check that VMware Update Manager Database is reachable before migration and Please make sure Migration Assistant is launched under service account for VMware Update Manager

My guess is that my current account does not have enough permissions to access the database.  I'm currently running the migration assistant with my admin account which is a domain admin account with administrator rights locally on the machine.

4 Replies
RickVerstegen
Expert
Expert

Hi mlarrivee80 ,

Are you running Update Manager on a different machine then vCenter?

Rick

Was I helpful? Give a kudo for appreciation!
Blog: https://rickverstegen84.wordpress.com/
Twitter: https://twitter.com/verstegenrick
Reply
0 Kudos
REC007
VMware Employee
VMware Employee

I have also faced the same issue when I was performing the migration from vCenter 5.5 to VCSA 6.5.

Since in VCSA 6.5, Update manager is bundled with vCenter, You can can disable Update Manager from MOB page & proceed for migration.

You can follow below troubleshooting steps.

1) Take a snapshot of Vcenter machine

2) Stop Update manager service & disable the UM plugin

3) Remove the UM extension from vCenter MOB page by following below VMware KB article

VMware Knowledge Base

4) Extension for UM : com.vmware.vcIntegrity

Hope this helps!!

Thanks!

mlarrivee80
Contributor
Contributor

I found the problem.  It was indeed a permission issue.  I had to run the migration assistant on the Winows vCenter server with another domain account.  From there I was able to access the VUm database.

So basically, make sure that your account has enough permissions to access the database.

Reply
0 Kudos
justyjusty123
Contributor
Contributor

If you cannot access the DB, make sure that the user has SA permissions and that Replace process level permission is set as following:

gpedit.msc - Computer Configuration - Security Settings - Local Policy - User Rights assignment

Click on "Replace a process level token" and assign it to the user running the Migration assistant and/or the service user which you are using for vCenter DB.

Also, I had an error about something with Update Manager. Closed the Migration Assistant, opened it again and WORKED. (w/o changes, w/o reboot, w/o logging off and on).

Reply
0 Kudos