VMware Cloud Community
awinkel
Contributor
Contributor

Maintenance mode: vm doesn't migrate

When I enter an ESX server in maintenance mode I have the problem that not all of the VM's are migrating to an another host.

There are two vm's which doesn't migrated and even appear below in the windows between all other hosts which are migrating.

I restarted both the ESX server and VM's but nothing helps.

When I try the same at an another ESX server the same VM's doesn't migrate.

What could be wrong?

Reply
0 Kudos
7 Replies
Rubeck
Virtuoso
Virtuoso

VMs that wont migrate, do they have CDrom and/or Floppy connected? Or are they connected to an vSwitch with no pNICs? Are they running MSCS?

With any of the above VMotion wont work..

What version of ESX and VC are you running?

/Rubeck

Reply
0 Kudos
awinkel
Contributor
Contributor

One of the VMs is running and the other is powered off. Both aren't connected to a floppy of cdrom. They are connected well to the vswitch and the vscwitch is well connected to pNICS. They aren't running MSCS.

I'm running ESX 3.5 U2 and VC 2.5.0 build 104215.

Reply
0 Kudos
fejf
Expert
Expert

Have you tried to vmotion (migrate) the problematic VMs by hand? If there's a problem with the VMs you'll get a error message when you try the manual vmotion.

--

There are 10 types of people. Those who understand binary and the rest. And those who understand gray-code.

-- There are 10 types of people. Those who understand binary and the rest. And those who understand gray-code.
Reply
0 Kudos
awinkel
Contributor
Contributor

Yes, I've tried that and then the migration succeed.

Then I put the vms back on the first ESX server and enter the ESX host in maintenance mode but the migration still fails and there is no error message at all.

I'm totally confused...

Reply
0 Kudos
awinkel
Contributor
Contributor

Hmm...I'm just a little bit less confused then I thought. Smiley Happy

The problem is just solved!

1) Select the VM and choose "Remove from inventory"

2) Browse the datastore and select the VM and choose "Add to inventory"

3) Now anything just works fine

I think that the registration was lost and with a new import the registration is made again.

Reply
0 Kudos
weinstein5
Immortal
Immortal

auto migrating when placing a host inot maintenance mode will only occur when the host is part of a DRS cluster in full automatic mode -

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful
Reply
0 Kudos
awinkel
Contributor
Contributor

Yes I know. Smiley Happy And that's exactly how I configured it. Smiley Happy

Reply
0 Kudos