Highlighted
Enthusiast
Enthusiast

Ignore "SSH enabled" / Remote Tech Support warning in vCenter for ESXi

I would like to leave SSH (Remote Tech Support Mode) enabled on all of my ESXi hosts, but don't want to see that "warning" flag.

When did SSH of all things become a security concern?  Of all the protocols utilized by VMWare, SSH is one of the more secure, yet it props up a warning flag when you enable it in ESXi.

Host access is necessary whenever there is some type of issue between vCenter and vSphere, or if there is an issue with the host itself.

Console sucks:  There are many mechanisms for attaching to console and they all suck.  legacy KVM, KVM over IP, ILO, attaching directly.  All tend to be inefficient in some manner.

The SSH interface is faster, more secure, and more efficient than gaining console access.

If I have to restart the VMWare Management service (hostd), it is far quicker for me to do this via SSH than any other means.

Anyone else agree?  Is there a way to make this warning message disappear from "vCenter"?

0 Kudos
3 Replies
Highlighted
Immortal
Immortal

restarting the management agents (through SSH #services.sh restart) will make these warnings go away

See also

http://www.vcritical.com/2011/02/get-rid-of-those-esxi-tech-support-mode-warnings/

Highlighted
Enthusiast
Enthusiast

I appreciate the response.

That method seems to work on vCenter 4.x, but not on vCenter 5.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Found a permanent answer that works only for vCenter 5 / ESXi 5:

http://kb.vmware.com/kb/2003637

To disable these warnings:
  1. Select the ESXi host from the Inventory.
  2. Select Advanced Settings from the Software menu.
  3. Navigate to UserVars > UserVars.SupressShellWarning.
  4. Set the value from 0 to 1.
  5. Click OK.

This setting can also be applied via host profile.

Thanks to this page:

http://www.boche.net/blog/index.php/2011/09/02/tech-support-mode-warnings-revisited-in-vsphere-5/

0 Kudos