jeffreywmcclain
Enthusiast
Enthusiast

How to change System Domain back to "vsphere.local"?

I initially set the vCenter System Domain in the format "lab.company.com".

However, now I want to join the vCenter to an Active Directory domain (also in the format "lab.company.com").

The initial domain join worked successfully, however when I try to add the domain as an identity source using the source type "Active Directory (Windows Integrated Authentication)" I receive an error stating "Check the network settings and make sure you have network access to the identity source". Considering the initial domain join was successful and I can see the vCenter machine in the "Computers" OU, I suspect the issue is likely caused by the system domain being identical to the Active Directory domain.

I tried following this walkthrough and running the command "cmsso-util domain-repoint -m execute --src-emb-admin Administrator --dest-domain-name vsphere.local", but it failed at the very end. I created a backup first which I have since restored (and anyways this is a lab environment), but does anyone know if I need to run a different command or satisfy any prerequisites for the repoint to complete successfully?

For reference, I am running the latest stable version of vSphere 6.7 U3.

Tags (1)
0 Kudos
5 Replies
IRIX201110141
Champion
Champion

I think thats not possible/supportet.  You have to reinstall your vCenter.

Regards,

Joerg

0 Kudos
jeffreywmcclain
Enthusiast
Enthusiast

I somewhat suspected as much, in that case I'll just redeploy the vCenter then.

Thanks!

0 Kudos
NathanosBlightc
Commander
Commander

You cannot change it to a default name or something else like that, however as you know it's possible to repoint it (after release of vSphere 6.7) to another new deployed SSO domain with the default name (vsphere.local) via the cmsso-util domain-repoint.

Please check this link too.

Please mark my comment as the Correct Answer if this solution resolved your problem
0 Kudos
Vijay2027
Expert
Expert

You should be able to change domain name using the mentioned in your description. Do you have logs from the time of failure?

"cmsso-util domain-repoint -m execute --src-emb-admin Administrator --dest-domain-name vsphere.local"

0 Kudos
aabuhamad
Contributor
Contributor

After run this command nothing is working service state error and cannot repoint again with failed error message and need to restore  from backup , please help

0 Kudos