C2NSIAdmin
Contributor
Contributor

Hardware Status: Message - Do not have permission for this command

Hello all,

When using vSphere Client and clicking the Hardware Status tab, I receive the following error:

Message

Do not have permission for this command.

I have already reviewed the following link: http://communities.vmware.com/message/1360601#1360601 to no avail.

I don't understand why all of a sudden I'm receiving this error since all was working well since I installed vCenter Server a couple of months ago. vCenter Server is installed on a Dell PE2900 with Windows Server 2008 R2 Standard. The Dell server is used for nothing else but vCenter Server. I have attached a print screen of my vSphere Client were I receive the error.

Has anyone else stumbled across this problem and found a valid fix?

Thank you in advance.

0 Kudos
4 Replies
krowczynski
Virtuoso
Virtuoso

0 Kudos
C2NSIAdmin
Contributor
Contributor

Krowczynski,

Thank you for the link. However, I have already tried that as well.

0 Kudos
ccostan
Contributor
Contributor

You may want to try this link :

http://www.vmwareinfo.com/2009/12/vcenter-hardware-status-error-you-do.html

Worked for me.

Carlo.

Carlo Costanzo | http://www.VMwareInfo.com | @ccostan
0 Kudos
benny_hauk
Enthusiast
Enthusiast

I found that Java memory settings fixed this for me.  Here's the KB: http://kb.vmware.com/kb/1039180

The only thing I'll add to the KB is that with Windows 2k8 (with UAC enabled) you have to right-click on "Configure Tomcat" and "Run as Administrator" instead of just running it.

I added 50% to the "Maximum memory pool" and issue was fixed right up.

Benny Hauk Systems Admin, VCP3/VCP4 LifeWay Chrstian Resources
0 Kudos