koit
Contributor
Contributor

General system error when relocate VM files

Jump to solution

I'm trying to move a VM from one SAN LUN to another with the Relocate VM files option while doing a migration.

It reaches 100% but ends with a General system error.

Does anyone know the cause og this problem?

Is the only way to move VM files to copy them manually, remove them from inventory and then add them back?

0 Kudos
1 Solution

Accepted Solutions
masaki
Virtuoso
Virtuoso

vmkfstools -L release or -L lunreset /vmfs/devices/disks/vmhbaA:T:L:P

to free the LUN from a lock but this will affect the entire LUN.

View solution in original post

0 Kudos
6 Replies
masaki
Virtuoso
Virtuoso

Usually is because there is some kind of lock on the files.

Do you have any console opened?

Can you post the error logs about this issue?

0 Kudos
koit
Contributor
Contributor

How can I check which file is locked and which process is locking it?

I tried to locate the log containing the relocate event, but I can't find anything. Do you know which log it is?

0 Kudos
masaki
Virtuoso
Virtuoso

vmkfstools -L release or -L lunreset /vmfs/devices/disks/vmhbaA:T:L:P

to free the LUN from a lock but this will affect the entire LUN.

0 Kudos
masaki
Virtuoso
Virtuoso

To search in the log open VI client and go to Admin -> logs then enter keyword to search (something like "relocate" or "move")

0 Kudos
koit
Contributor
Contributor

I'm not that used to VI so I have a little trouble with locating the Admin mode/function.

Which log file contains the relocate files operation.

I can then use a "less "NameOfLog" |grep relocate" command.

0 Kudos
masaki
Virtuoso
Virtuoso

Unfortunately I don't have a console available right now but I think you must search under /var/log/vmware

so less *.log |grep relocate

0 Kudos