Jock8186
Enthusiast
Enthusiast

Extremely slow thick client performance, although web client is ok??

I am running a vSphere 5.5 environment. vCenter Server (VM) is standard with SQL 2012 backend. My vCenter Database is 10GB in size. Transaction logs have ample space allocation and are set to backup and truncate every 4hrs. All default SQL vSphere jobs are running fine. Both vCenter Server and SQL database sit on same subnet and are located on same ESXi host (DRS affinity rule in place).

The problem I am facing is the performance of the Thick client. More often than not (especially when navigating around VM&Templates) the performance is so bad it becomes unusable. When click on a folder or attempting to populate vms, it hangs for 5-10mins. This same issue is not seen in the web client.

Strangely enough, every now and again the thick clients does respond in a more satisfactory manner. I have reset the vCenter Inventory Service database to no avail. VMware support isn't offering much in the way of help or idea. My 10Gb network is still in its infancy of use and the underlying netapp storage is barely 40% utilised and no latency is being observed.

Has any else experienced this issue with the thick client??

0 Kudos
8 Replies
unsichtbare
Expert
Expert

Is the SQL Agent started?

+The Invisible Admin+ If you find me useful, follow my blog: http://johnborhek.com/
0 Kudos
Jock8186
Enthusiast
Enthusiast

Many thanks for the reply.....

yes, SQL Agent is running

0 Kudos

is the client version matching the server version? if not, i would update the client by opening the browser and enter the vcenter hostname.

there you can download the newest viclient for your vcenter.

what is saing the vcenter service status? is there someting red?

------------------------------------------------------------------------------- If you found this or any other answer helpful, please consider to award points. (use Correct or Helpful buttons) Regards from Switzerland, B. Fernandez http://vpxa.info/
0 Kudos
Jock8186
Enthusiast
Enthusiast

yes, client is 5.5 along side the vCenter Server version.......and yeh, al vCenter Service status's are up and showing nice and green.

0 Kudos
odohertyd
Contributor
Contributor

Are your vcentre server and SQL server provisioned correctly? How much RAM is assigned? How many CPU's? What is your % ready time like on the sql box when you use the thick client? Is there CPU over provisioning on that box? Are your disks thick or thin on the sql box?

0 Kudos
Jock8186
Enthusiast
Enthusiast

Thanks for reply,

Specs as follows:

vCenter Server:

RAM: 10GB - Active pages rarely hits 6GB, averages around 4/5GB usage.

CPU: 4 x vCPU - Usage is fractionally used. CPU ready time is around 0.5%. Never gets close to the 5% "rule of thumb" limit

SQL Server

RAM: 8GB - Active pages rarely hits 3GB, averages around 20% usage

CPU: 2 x vCPU - Average usage sits steady around 10-20% - CPU Ready averages around 1% with a peak (in the last 7 days) of 1.66%. Not enough i wouldn't imagine to impact performance

0 Kudos
odohertyd
Contributor
Contributor

Sounds ok. We had a problem with poor SQL performance before and it was due to thin provisioning as well as high ready time. Are your disks thick or thin? Also what type of storage do the VMs sit on? How is the performance for the disk and datastore in the performance graphs? Any high read/write times?

0 Kudos
odohertyd
Contributor
Contributor

Also forgot to say are you running the thick client on your laptop/dektop or the vcentre server directly?

0 Kudos