joboo12
Enthusiast
Enthusiast

Event ID 7024 - The VMware VirtualCenter Server service terminated with service-specific error 2 (0x2) upon starting up VC Server

Jump to solution

I am currently running VC 2.5 virtualized. WIndows 2003 SP2 with SQL Express 2005. Everytime I reboot the server I received Event ID 7024 - The VMware VirtualCenter Server service terminated with service-specific error 2 (0x2). Eventually I am able to manually start the service and everything is fine. Has anyone else experienced this issue?

Thanks

0 Kudos
1 Solution

Accepted Solutions
jhanekom
Virtuoso
Virtuoso

It's probably a case of the VC service starting before SQL starts. If you leave it alone, the VC service should automatically try to restart after 5 minutes.

If you want to avoid the problem altogether, you'll need to do the following:

- Obtain the service name for your SQL Service - in Registry Editor, browse to HKLM\System\CurrentControlSet\Services and look for entries starting with MSSQL. In all likelyhood, yours will be called either MSSQL or MSSQL$SQLEXPRESS (ignore MSSQLServerADHelper)

- Now browse to HKLM\System\CurrentControlSet\Services\vpxd

- Open the REG_MULTI_SZ value called DependOnService

- Add a line called "MSSQL$SQLEXPRESS" (or whatever value you determined above)

- Ensure that the last line in the value is blank

In future, whenever SQL is stopped, VC will now be stopped as well. Whenever VC is started, SQL will also be started. You should also be able to view the dependency by opening the service's properties in the Services control panel applet and going to the Dependencies tab.

View solution in original post

0 Kudos
53 Replies
jhanekom
Virtuoso
Virtuoso

It's probably a case of the VC service starting before SQL starts. If you leave it alone, the VC service should automatically try to restart after 5 minutes.

If you want to avoid the problem altogether, you'll need to do the following:

- Obtain the service name for your SQL Service - in Registry Editor, browse to HKLM\System\CurrentControlSet\Services and look for entries starting with MSSQL. In all likelyhood, yours will be called either MSSQL or MSSQL$SQLEXPRESS (ignore MSSQLServerADHelper)

- Now browse to HKLM\System\CurrentControlSet\Services\vpxd

- Open the REG_MULTI_SZ value called DependOnService

- Add a line called "MSSQL$SQLEXPRESS" (or whatever value you determined above)

- Ensure that the last line in the value is blank

In future, whenever SQL is stopped, VC will now be stopped as well. Whenever VC is started, SQL will also be started. You should also be able to view the dependency by opening the service's properties in the Services control panel applet and going to the Dependencies tab.

View solution in original post

0 Kudos
joboo12
Enthusiast
Enthusiast

Thanks. For some reason, even though the service is set to restart on failure after 5 mins.. then again after another it does not seem to start unless I manually start it. Anyway.. Dependcy setup worked perfectly! Thanks!

0 Kudos
AMF78
Contributor
Contributor

I have the same issue, only I can't manually restart the service. The VC database is installed on SQL 2K5.

I haven't logged into VirtualCenter in a few weeks as the project had been put on hold. Backup exec 11d has been installed on the server as well since last successful login. I know there is a dependency on both products for the Workstaion process.

Any suggestions?

0 Kudos
Jasemccarty
Immortal
Immortal

On my test system, this happens every time I reboot.

I have figured out, that if I stop the VMware Converter Service, and then start the VirtualCenter Service, it works every time.

I then restart the VMware Converter Service.

Jase McCarty

http://www.jasemccarty.com

Jase McCarty - Field SA @PureStorage - @jasemccarty
0 Kudos
rwoolley
Contributor
Contributor

I know this question shows answered, but I'd like to add that I just had this same issue doing a test upgrade and my resolve was not anything listed here. We run the VCServer service as a specific user and not the LocalSystem account. Once the upgrade was completed the service "LogOn" settings were set back to default and the service would not start. It was giving the exact same error listed in the subject. Once I changed the LogOn properties back to the service account we use, it started right up.

We use SQL2K on a remote server to house the VC dB, so LocalSystem doesn't grant access to it. Our dBs also lock down the SQL servers fairly tight, so if you're not using the right service account, you can't see anything.

Just wanted to add this in here, in case someone else comes across this issue. I didn't take too long to notice and I'm glad it was solved easily.

0 Kudos
Jabberwocq
Contributor
Contributor

Good call rwoolley. Dbase for VirtualCenter Server on remote SQL box here as well. The service was set to use LocalSystem therefor, the service can't access the database. Change service credentials to an account that had access to the remote SQL box and database and all works as expected.

0 Kudos
GIlouMDL
Contributor
Contributor

Hi,

I've got exactly this problem.

But your solutions don't work for me, the VC service can't be run automatically or manually.

It happened after a reboot with the last version upgraded.

Any clue ?

Thx

0 Kudos
jhanekom
Virtuoso
Virtuoso

You may have the same symptoms, but quite probably not the same problem Smiley Happy those error messages are about as generic as they get.

To get at the root of the problem, view the VirtualCenter log files in C:\Windows\Temp\vpxa (for VC 2.0.x) or C:\Documents and Settings\All Users\Application Data\VMware\VMware VirtualCenter\Logs (for VC 2.5.x).

Look for the file with the most recent file stamp. The last few lines in the log file should give you more details as to what is going wrong in your case.

0 Kudos
GIlouMDL
Contributor
Contributor

Here are the last logs :

Log for VMware VirtualCenter, pid=5932, version=2.5.0, build=build-64192, option=Release, section=2

Current working directory: C:\WINDOWS\system32

HOSTINFO: Seeing Intel CPU, numCoresPerCPU 2 numThreadsPerCore 1.

HOSTINFO: This machine has 1 physical CPUS, 2 total cores, and 2 logical CPUs.

Log path: C:\Documents and Settings\All Users\Application Data\VMware\VMware VirtualCenter\Logs

Initializing SSL

Using system libcrypto, version 90709F

Vmacore::InitSSL: doVersionCheck = true, handshakeTimeoutUs = 120000000

Starting VMware VirtualCenter 2.5.0 build-64192

Account name: SYSTEM

Enabled low-frag process heap.

Enabled low-frag crt heap.

34 max LROs

6 reserved internal LROs

6 reserved blocker LROs

6 reserved short LROs

4 reserved long LROs

600-second task lifetime

Couldn't read registry entry vmdbPort

Couldn't read registry entry managedIP

Ignoring unknown entry from DB: AgentUpgrade.maxConcurrentUpgrades

Ignoring unknown entry from DB: Perf.Stats.FilterLevel

Invoking callbacks for key vpxd.npivWwnGeneration.singleNodeWwn

Invoking callbacks for key vpxd.npivWwnGeneration.portWwnNumber

Failed to initialize: not well-formed (invalid token)

Failed to intialize VMware VirtualCenter. Shutting down...

Forcing shutdown of VMware VirtualCenter now

I think we will reinstall everything clean but if there is any solution before i take it ^^

I use esx 3.5 and VC 2.5

Thx

0 Kudos
jhanekom
Virtuoso
Virtuoso

It does appear as if something went wrong with the database upgrade:

2008-02-14 11:57:04.734 'App' 364 error OptionMgr Ignoring unknown entry from DB: AgentUpgrade.maxConcurrentUpgrades

2008-02-14 11:57:04.734 'App' 364 error OptionMgr Ignoring unknown entry from DB: Perf.Stats.FilterLevel

I've not seen those particular lines before, but it would be consistent with a partially successful (or partially failed, depending on whether you see your disks as half full or half empty) database upgrade.

If you'd like to retain the historical performance data, cluster setups, alarms, permissions, customisation specifications etc. you've set up in VirtualCenter, you will need to remove the new version of VirtualCenter, re-install the previous version and recover the database from a backup (which you hopefully took before upgrading Smiley Happy)

0 Kudos
GIlouMDL
Contributor
Contributor

Hi ^^

I repaired my VC install and now are the logs :

Log for VMware VirtualCenter, pid=5380, version=2.5.0, build=build-64192, option=Release, section=2

Current working directory: C:\WINDOWS\system32

HOSTINFO: Seeing Intel CPU, numCoresPerCPU 2 numThreadsPerCore 1.

HOSTINFO: This machine has 1 physical CPUS, 2 total cores, and 2 logical CPUs.

Log path: C:\Documents and Settings\All Users\Application Data\VMware\VMware VirtualCenter\Logs

Initializing SSL

Using system libcrypto, version 90709F

Vmacore::InitSSL: doVersionCheck = true, handshakeTimeoutUs = 120000000

Starting VMware VirtualCenter 2.5.0 build-64192

Account name: administrateur

Enabled low-frag process heap.

Enabled low-frag crt heap.

34 max LROs

6 reserved internal LROs

6 reserved blocker LROs

6 reserved short LROs

4 reserved long LROs

600-second task lifetime

Couldn't read registry entry vmdbPort

Couldn't read registry entry managedIP

Invoking callbacks for key vpxd.npivWwnGeneration.singleNodeWwn

Invoking callbacks for key vpxd.npivWwnGeneration.portWwnNumber

Locale subsystem initialized from C:\Program Files\VMware\Infrastructure\VirtualCenter Server\locale/ with default locale en.

Initializing SSL Contexts

Setting VerifySSLCertificates to FALSE

Running on PDC

Local Domain : DOMAINE

IsWorkgroup: No

Local Machine:

Default resource used for 'LicenseRestrictedEvent.category' expected in module 'event'.

Default resource used for 'LicenseRestrictedEvent.fullFormat' expected in module 'event'.

Default resource used for 'LicenseRestrictedEvent.formatOnDatacenter' expected in module 'event'.

Default resource used for 'LicenseRestrictedEvent.formatOnComputeResource' expected in module 'event'.

Default resource used for 'LicenseRestrictedEvent.formatOnHost' expected in module 'event'.

Default resource used for 'LicenseRestrictedEvent.formatOnVm' expected in module 'event'.

-- BEGIN task-internal-1 -- -- VpxdDrmMainLoop

Entered value for key vcp2v.osToken.nt is NT

Entered value for key vcp2v.osToken.windows is WINDOWS

Entered value for key vcp2v.osToken.xp is XP

Entered value for key vcp2v.osToken.business is BUSINESS

Entered value for key vcp2v.osToken.server is SERVER

Entered value for key vcp2v.osToken.w2000 is 2000

Entered value for key vcp2v.osToken.w2003 is 2003

Entered value for key vcp2v.osToken.enterprise is ENTERPRISE

Entered value for key vcp2v.osToken.vista is VISTA

Entered value for key vcp2v.osToken.pro is PRO

Entered value for key vcp2v.osToken.advanced is ADVANCED

Entered value for key vcp2v.osToken.standard is STANDARD

Entered value for key vcp2v.osToken.web is WEB

Entered value for key vcp2v.osToken.datacenter is DATACENTER

Entered value for key vcp2v.osToken.v3dot1 is 3.1

Entered value for key vcp2v.osToken.w95 is 95

Entered value for key vcp2v.osToken.w98 is 98

Entered value for key vcp2v.osToken.me is ME

Entered value for key vcp2v.osToken.w64bit is X64

Entered value for key vcp2v.osToken.w64bit is 64-BIT

Entered value for key vcp2v.osToken.w64bit is 64

Entered value for key vcp2v.osToken.w64bit is ITANIUM

Entered value for key vcp2v.osToken.longhorn is LONGHORN

Entered value for key vcp2v.osToken.longhorn is 2008

: starting guided consolidation

Running on PDC

Local Domain : DOMAINE

IsWorkgroup: No

Local Machine:

P2V logger created

SSL context created

AppInit completed

Invoking callbacks for key VirtualCenter.MaxDBConnection

primary handler started

VMLicense_GetInfo: feature not found: 'VC_DRS_POWER' v2005.05

VMLicense_GetInfo: feature not found: 'VC_SERVERHOST' v2005.05

VMLicense_GetInfo: feature not found: 'VC_SVMOTION' v2005.05

VMLicense_GetInfo: feature not found: 'PROD_VC_EXPRESS' v2005.05

Http Service started:

Web server bound to pipe:
.\pipe\vmware-vpxd-webserver-pipe

-- BEGIN task-internal-2 -- -- ScheduledTaskManager

Failed to lookup account DOMAINE\Domain Admins (err: 1332, )

Failed to add default permission: user DOMAINE\Domain Admins found

Cannot start authorize - system has no access rules

Failed to initialize:

Failed to initialize security

Shutting down VMware VirtualCenter...

Exit done.

We repaired our License Server too but we don't know how to repair this :'(

Thx for the help

0 Kudos
jhanekom
Virtuoso
Virtuoso

Hmm. This appears to be due to a bug in VirtualCenter that causes it to not play well with non-English versions of Windows. It seems to explicitly look for the group "Domain Admins" on your machine, since the machine is a Domain Controller. The correct way for VirtualCenter to have dealt with this would have been to use the SID for the Domain Admins group, not the name.

Before we start logging support calls, may I suggest that you try the following workaround: Create a group in your domain called "Domain Admins" and make the "Admins du domaine" a part of that group (assuming you're using a French version of Windows.) You could also just add the users you want to give access to VirtualCenter to this group.

If that works, I'd suggest you log a support call with VMware and report the bug - it will help fix the problem in the long term.

0 Kudos
batfink
Contributor
Contributor

This also happened to me, although as posted previously by someone else, that's a fairly generic error, so you need to check the logs. Mine was because I have IIS running, and another service was connecting and using port 80. I changed the port for the IIS site, changed that the client was trying to connect to, and everything is now happy.

0 Kudos
VMmepls
Contributor
Contributor

I had this same issue come up on our VC 2.5 server. It connects to an Oracle DB. After some investigation I got our DBA to have a look at the DB and he found numerous processes and threads that were locking it up. All of them were from the "Update Manager". So I stopped all of the VMware services on the VC, then he killed all of the threads and processes. I then proceeded to restart the services one by one starting with Virtual Center and ending with Update Manager. This seems to have resolved it for now.

0 Kudos
squirrelking
Enthusiast
Enthusiast

That was my issue as well as batfink described it.. stopping IIS and then starting the VC services worked for me..

---- VCP3 VCP4 VTSP VSP VMware Solution Provider Premier Partner VMware Authorized Consultant [http://blog.lewan.com]
0 Kudos
scerazy
Enthusiast
Enthusiast

Same here (and I do NOT use IIS on this server), VC server running in VM, SQL Express on same machine, licensing working, added DependOnService entries

On every VC VM start I get same error (log below)

Without ANY change to anything I CAN start the service by hand with NO problems (so the log error about "Login failed for user ...." is a total b*****t IMHO)

If the user was wrong then I would never be able to start the service!

Of course checked & re-checked ODBC etc (no problems)

Log for VMware VirtualCenter, pid=1448, version=2.5.0, build=build-64192, option=Release, section=2

2008-03-29 12:02:40.765 'App' 1424 info Current working directory: C:\WINDOWS\system32

2008-03-29 12:02:40.765 'BaseLibs' 1424 info HOSTINFO: Seeing Intel CPU, numCoresPerCPU 2 numThreadsPerCore 1.

2008-03-29 12:02:40.765 'BaseLibs' 1424 info HOSTINFO: numPhysCPUs is 0, bumping to 1.

2008-03-29 12:02:40.765 'BaseLibs' 1424 info HOSTINFO: This machine has 1 physical CPUS, 1 total cores, and 1 logical CPUs.

2008-03-29 12:02:40.765 'App' 1424 info Log path: C:\Documents and Settings\All Users\Application Data\VMware\VMware VirtualCenter\Logs

2008-03-29 12:02:40.765 'App' 1424 info Initializing SSL

2008-03-29 12:02:40.765 'BaseLibs' 1424 info Using system libcrypto, version 90709F

2008-03-29 12:02:41.984 'App' 1424 info Vmacore::InitSSL: doVersionCheck = true, handshakeTimeoutUs = 120000000

2008-03-29 12:02:41.984 'App' 1424 info Starting VMware VirtualCenter 2.5.0 build-64192

2008-03-29 12:02:41.984 'App' 1424 info Account name: Administrator

2008-03-29 12:02:41.984 'App' 1424 info Enabled low-frag process heap.

2008-03-29 12:02:41.984 'App' 1424 info Enabled low-frag crt heap.

2008-03-29 12:02:41.984 'App' 1424 info 34 max LROs

2008-03-29 12:02:41.984 'App' 1424 info 6 reserved internal LROs

2008-03-29 12:02:41.984 'App' 1424 info 6 reserved blocker LROs

2008-03-29 12:02:41.984 'App' 1424 info 6 reserved short LROs

2008-03-29 12:02:41.984 'App' 1424 info 4 reserved long LROs

2008-03-29 12:02:41.984 'App' 1424 info 600-second task lifetime

2008-03-29 12:02:42.171 'App' 1424 error ODBC error: (28000) - [SQL Native Client][SQL Server]Login failed for user 'VCENTER\Administrator'.

2008-03-29 12:02:42.171 'App' 1424 error Failed to intialize VMware VirtualCenter. Shutting down...

2008-03-29 12:02:42.171 'App' 1424 info Forcing shutdown of VMware VirtualCenter now

That is the log when VC service is started by hand instantly after VC server reboot (and VC service fails as above)* *

Log for VMware VirtualCenter, pid=3416, version=2.5.0, build=build-64192, option=Release, section=2

2008-03-29 12:04:45.968 'App' 3428 info Current working directory: C:\WINDOWS\system32

2008-03-29 12:04:45.968 'BaseLibs' 3428 info HOSTINFO: Seeing Intel CPU, numCoresPerCPU 2 numThreadsPerCore 1.

2008-03-29 12:04:45.968 'BaseLibs' 3428 info HOSTINFO: numPhysCPUs is 0, bumping to 1.

2008-03-29 12:04:45.968 'BaseLibs' 3428 info HOSTINFO: This machine has 1 physical CPUS, 1 total cores, and 1 logical CPUs.

2008-03-29 12:04:45.968 'App' 3428 info Log path: C:\Documents and Settings\All Users\Application Data\VMware\VMware VirtualCenter\Logs

2008-03-29 12:04:45.968 'App' 3428 info Initializing SSL

2008-03-29 12:04:45.968 'BaseLibs' 3428 info Using system libcrypto, version 90709F

2008-03-29 12:04:47.156 'App' 3428 info Vmacore::InitSSL: doVersionCheck = true, handshakeTimeoutUs = 120000000

2008-03-29 12:04:47.156 'App' 3428 info Starting VMware VirtualCenter 2.5.0 build-64192

2008-03-29 12:04:47.156 'App' 3428 info Account name: Administrator

2008-03-29 12:04:47.156 'App' 3428 info Enabled low-frag process heap.

2008-03-29 12:04:47.156 'App' 3428 info Enabled low-frag crt heap.

2008-03-29 12:04:47.156 'App' 3428 info 34 max LROs

2008-03-29 12:04:47.156 'App' 3428 info 6 reserved internal LROs

2008-03-29 12:04:47.156 'App' 3428 info 6 reserved blocker LROs

2008-03-29 12:04:47.156 'App' 3428 info 6 reserved short LROs

2008-03-29 12:04:47.156 'App' 3428 info 4 reserved long LROs

2008-03-29 12:04:47.156 'App' 3428 info 600-second task lifetime

2008-03-29 12:04:52.625 'BaseLibs' 3428 warning Couldn't read registry entry vmdbPort

2008-03-29 12:04:52.625 'BaseLibs' 3428 warning Couldn't read registry entry managedIP

2008-03-29 12:04:52.656 'App' 3428 error Ignoring unknown entry from DB: AgentUpgrade.maxConcurrentUpgrades

2008-03-29 12:04:52.656 'App' 3428 error Ignoring unknown entry from DB: Perf.Stats.FilterLevel

2008-03-29 12:04:52.703 'App' 3428 info Invoking callbacks for key vpxd.npivWwnGeneration.singleNodeWwn

2008-03-29 12:04:52.703 'App' 3428 info Invoking callbacks for key vpxd.npivWwnGeneration.portWwnNumber

2008-03-29 12:04:54.718 'Locale' 3428 info Locale subsystem initialized from C:\Program Files\VMware\Infrastructure\VirtualCenter Server\locale/ with default locale en.

2008-03-29 12:04:54.718 'App' 3428 info Initializing SSL Contexts

2008-03-29 12:04:54.718 'App' 3428 info Setting VerifySSLCertificates to FALSE

2008-03-29 12:04:55.656 'BaseLibs' 3428 info Local Domain : SPGSGROUP

2008-03-29 12:04:55.656 'BaseLibs' 3428 info IsWorkgroup: Yes

2008-03-29 12:04:55.656 'BaseLibs' 3428 info Local Machine: VCENTER

2008-03-29 12:04:56.015 'Locale' 3428 warning Default resource used for 'LicenseRestrictedEvent.category' expected in module 'event'.

2008-03-29 12:04:56.015 'Locale' 3428 warning Default resource used for 'LicenseRestrictedEvent.fullFormat' expected in module 'event'.

2008-03-29 12:04:56.015 'Locale' 3428 warning Default resource used for 'LicenseRestrictedEvent.formatOnDatacenter' expected in module 'event'.

2008-03-29 12:04:56.015 'Locale' 3428 warning Default resource used for 'LicenseRestrictedEvent.formatOnComputeResource' expected in module 'event'.

2008-03-29 12:04:56.015 'Locale' 3428 warning Default resource used for 'LicenseRestrictedEvent.formatOnHost' expected in module 'event'.

2008-03-29 12:04:56.015 'Locale' 3428 warning Default resource used for 'LicenseRestrictedEvent.formatOnVm' expected in module 'event'.

2008-03-29 12:04:56.093 'App' 3544 info -- BEGIN task-internal-1 -- -- VpxdDrmMainLoop

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.nt is NT

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.windows is WINDOWS

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.xp is XP

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.business is BUSINESS

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.server is SERVER

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.w2000 is 2000

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.w2003 is 2003

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.enterprise is ENTERPRISE

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.vista is VISTA

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.pro is PRO

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.advanced is ADVANCED

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.standard is STANDARD

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.web is WEB

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.datacenter is DATACENTER

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.v3dot1 is 3.1

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.w95 is 95

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.w98 is 98

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.me is ME

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.w64bit is X64

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.w64bit is 64-BIT

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.w64bit is 64

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.w64bit is ITANIUM

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.longhorn is LONGHORN

2008-03-29 12:04:56.281 'App' 3428 info Entered value for key vcp2v.osToken.longhorn is 2008

2008-03-29 12:04:56.281 'App' 3428 error : starting guided consolidation

2008-03-29 12:04:56.421 'BaseLibs' 3428 info Local Domain : SPGSGROUP

2008-03-29 12:04:56.421 'BaseLibs' 3428 info IsWorkgroup: Yes

2008-03-29 12:04:56.421 'BaseLibs' 3428 info Local Machine: vcenter

2008-03-29 12:04:56.750 'P2V' 3428 info P2V logger created

2008-03-29 12:04:56.750 'P2V' 3428 info SSL context created

2008-03-29 12:04:56.765 'P2V' 3428 info AppInit completed

2008-03-29 12:04:56.796 'App' 3428 info Invoking callbacks for key VirtualCenter.MaxDBConnection

2008-03-29 12:04:57.015 'App' 3552 info primary handler started

2008-03-29 12:04:57.796 'BaseLibs' 3428 info VMLicense_GetInfo: feature not found: 'VC_DRS_POWER' v2005.05

2008-03-29 12:04:57.796 'BaseLibs' 3428 info VMLicense_GetInfo: feature not found: 'VC_SERVERHOST' v2005.05

2008-03-29 12:04:57.796 'BaseLibs' 3428 info VMLicense_GetInfo: feature not found: 'VC_SVMOTION' v2005.05

2008-03-29 12:04:57.796 'BaseLibs' 3428 info VMLicense_GetInfo: feature not found: 'PROD_VC_EXPRESS' v2005.05

2008-03-29 12:04:58.015 'HttpSvc' 3428 info Http Service started:

2008-03-29 12:04:58.015 'App' 3428 info Web server bound to pipe:
.\pipe\vmware-vpxd-webserver-pipe

2008-03-29 12:04:59.484 'App' 3556 info -- BEGIN task-internal-2 -- -- ScheduledTaskManager

2008-03-29 12:04:59.843 'ProxySvc' 3428 info Proxy: Starting new Proxy service

2008-03-29 12:04:59.843 'ProxySvc' 3428 info Proxy: Starting new Proxy service

2008-03-29 12:04:59.859 'VmdbAdapter' 3428 info Using new VMDB VMOMI serialization format

2008-03-29 12:04:59.859 'SoapAdapter' 3428 info Http Service started: TCPServerSocket(listen=127.0.0.1:8085)

2008-03-29 12:04:59.859 'App' 3428 info SOAP adapter started on port 8085

2008-03-29 12:04:59.859 'SSL SoapAdapter' 3428 info Http Service started:

2008-03-29 12:04:59.859 'App' 3428 info Secure SOAP adapter started on port 8089

2008-03-29 12:04:59.859 'DebugBrowser' 3428 info Http Service started:

2008-03-29 12:04:59.859 'App' 3428 info MOB started on pipe
.\pipe\vmware-vpxd-mob-pipe

2008-03-29 12:05:00.000 'BaseLibs' 3428 info VMLicense_GetInfo: feature not found: 'ESX_VDI_VM' v2005.05

2008-03-29 12:05:00.000 'App' 3428 error No such feature exists.

Feature: VC_VMOTION

License path: 27000@vcenter

FLEXnet Licensing error:-5,412

For further information, refer to the FLEXnet Licensing End User Guide,

available at "[www.macrovision.com|http://www.macrovision.com|Linkification: http://www.macrovision.com]".

2008-03-29 12:05:01.515 'App' 3560 info -- BEGIN task-internal-3 -- host-8 -- VpxdInvtHostSyncHostLRO.Synchronize

2008-03-29 12:05:01.515 'App' 3560 info Synchronizing host: esx1.spgs.org (10.0.0.49)

2008-03-29 12:05:21.718 'BaseLibs' 3560 warning SSLVerifyCertAgainstSystemStore: The remote host certificate has these problems:

  • A certificate in the host's chain is based on an untrusted root.

2008-03-29 12:05:21.718 'BaseLibs' 3560 warning SSLVerifyCertAgainstSystemStore: Certificate verification is disabled, so connection will proceed despite the error

2008-03-29 12:05:22.250 'VpxProfiler' 3560 warning GetChanges host:esx1.spgs.org (10.0.0.49) took 20687 ms

2008-03-29 12:05:22.250 'App' 3560 info Retrieved host update to 524

2008-03-29 12:05:22.437 'App' 3560 info VM vim.VirtualMachine:vm-22: config changed, invalidating cache...

2008-03-29 12:05:22.578 'App' 3560 info Completed host synchronization

2008-03-29 12:05:22.578 'VpxProfiler' 3560 warning InvtHostSyncLRO::StartWork took 21062 ms

2008-03-29 12:05:22.578 'App' 3560 info -- FINISH task-internal-3 -- host-8 -- VpxdInvtHostSyncHostLRO.Synchronize

0 Kudos
possamai
Contributor
Contributor

I found out something else that generates this error..

A computername can only be 15 characters long.

You can make in longer in windows and you'll get a notice and it'll just be the long name you chose,

but Virtual Center goes berserk on this. Check it out, maybe that's what's causing the problem.

0 Kudos
scerazy
Enthusiast
Enthusiast

vcenter (looks short to me...)

Seb

0 Kudos
Rik_Pasman
Contributor
Contributor

Hello, i've got the same problem with the same error:

The VMware VirtualCenter Server service terminated with service-specific error 2 (0x2).

My log file looks like this:

Log for VMware VirtualCenter, pid=3116, version=2.5.0, build=build-64192, option=Release, section=2

Current working directory: C:\WINDOWS\system32

HOSTINFO: Seeing Intel CPU, numCoresPerCPU 1 numThreadsPerCore 2.

HOSTINFO: numPhysCPUs is 0, bumping to 1.

HOSTINFO: numCores is 0, bumping to 1.

HOSTINFO: This machine has 1 physical CPUS, 1 total cores, and 1 logical CPUs.

Log path: C:\Documents and Settings\All Users\Application Data\VMware\VMware VirtualCenter\Logs

Initializing SSL

Using system libcrypto, version 90709F

Vmacore::InitSSL: doVersionCheck = true, handshakeTimeoutUs = 120000000

Starting VMware VirtualCenter 2.5.0 build-64192

Account name: SYSTEM

Enabled low-frag process heap.

Enabled low-frag crt heap.

34 max LROs

6 reserved internal LROs

6 reserved blocker LROs

6 reserved short LROs

4 reserved long LROs

600-second task lifetime

ODBC error: (08001) - [SQL Native Client]SQL Network Interfaces: Error Locating Server/Instance Specified .

Failed to intialize VMware VirtualCenter. Shutting down...

Forcing shutdown of VMware VirtualCenter now

So it seems it has got something to do with the SQL database. but i tried all the solutions in this topic and the service still wont start.

Anyone got an idea for this problem?

0 Kudos