edevlin
Contributor
Contributor

Error when enabling HA

Hi,

I get an error when enabling HA on my vCenter 4.1 cluster

A general system error
occurred: Failed to
increase memory
reservation and limit
for host/vim/vmvisor
from -1 to 148. HA
may not configure on
the host.

I have 2 x ESXi 4.1 host's and 15 VM's running inside my cluster. I have ran through the KB posted here.....http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=102603...

however I still get this error every time I try to enable HA?

Thanks

0 Kudos
11 Replies
admin
Immortal
Immortal

This is a known bug. As a workaround do the following:

For each host, go to the "Configuration" tab

In the "Software" section, click on the "System Resource Allocation" link.

Click on the "Advanced" link on the top right.

Navigate to the host/vim/vmvisor resource pool

Click "Edit settings..."

In the "Memory Resources" section, set the limit to the same as the reservation.

Elisha

0 Kudos
edevlin
Contributor
Contributor

Hi Elisha,

Set the 2 ESXi host's the way you described and I get a similar error.....

Configuring HA
192.168.1.223
A general
system error
occurred: Failed to increase memory reservation and limit for host/vim/v-mvisor from 1232 to 1381.

Thanks

0 Kudos
admin
Immortal
Immortal

Ok, can you manually increase the memory of the host/vim/vmvisor/aam resource pool to 100. for each host.

0 Kudos
admin
Immortal
Immortal

Just to clarify - increase the memory _limit_ of the host/vim/vmvisor/aam resource pool to 100. for each host.

Elisha

0 Kudos
edevlin
Contributor
Contributor

Hi,

The limit was set at 363MB, I have set it to 100MB and I still get an error enabling HA....I also increased the limit from it's original 363 to 463 however fault persists.

A general system error occurred: Failed to increase memory reservation and limit for host/vim/v-mvisor from 1381 to 1793

Thanks

0 Kudos
admin
Immortal
Immortal

The default memory limit for the aam resource pool should be 30MB, not 363MB. Can you upload a screenshot of the settings of the system resource pool you're trying to change so I can make sure we're talking about the same thing.

Elisha

0 Kudos
edevlin
Contributor
Contributor

I have set the limit to 30 now however still get the same error - attached is the screen shot you're looking for

0 Kudos
edevlin
Contributor
Contributor

Hi,

Thanks for your assistance on this! Attached is the log file you requested.

Thanks

0 Kudos
admin
Immortal
Immortal

vpxd is trying to increase the aam memory limit to 512 which is too much:


[2011-10-05 15:24:16.576 02016 info 'App' opID=0FB79C16-00000250-ba] [VpxdDasConfig] Need to increase memory limit for host/vim/vmvisor/aam from 30 to 512

Can you check the vpxd.cfg file to see if it has a setting for vpxd.das.aamMemoryLimit? If it does, remove it and restart the vpxd service.

Elisha

0 Kudos
edevlin
Contributor
Contributor

Hi,

Just checked the vpxd.cfg file and I don't have any aamMemoryLimit in there?

Thanks

0 Kudos
admin
Immortal
Immortal

Sorry, I got confused. Since you're using vCenter 4.1, vpxd does try to bump up the limit to 512MB which is the default. In vCenter 5.0, we're rearchitected the HA agents so they need much less memory and the limit only needs to be 100MB. If you're sticking with 4.1, we'd probably recommend you get hosts with more memory. You could try setting vpxd.das.aamMemoryLimit to some lower value (eg. 363MB which it was originally) in the vpxd.cfg file and restart the vpxd service so this will take effect. This will be an unsupported setting though - it might not be enough for the HA agents to run especially if you have a large cluster with many hosts/vms in which case HA will not work correctly.

Elisha

0 Kudos