VMware Cloud Community

EnvironmentBrowser.QueryConfigTarget error when trying to edit vm settings

I started the upgrade of my VMware  environment to vsphere5 a couple of days ago. First thing was the  upgrade of my vcenter server. Upgrade went relatively smooth, except  that the upgrade procedure complaint about on NFS Datastore which uses  different specification for the host. Since that datastore was only for  temporarly ISO-Images, I deleted that datastore from all ESXi hosts and  the rest of the upgrade was done without any further problems.

Next step was the installation of the vsphere5 client, also not problems there.

First checks of the new upgraded vcenter 5 showed no problems.

Last  night my Windows 2008 R2 NFS server for the ISO images and backup  rebooted due to windows security patch installation. Unfortunately the  NFS service didn't come up, which i didn't detect right away.

Today  I tried to modify the settings of one  VM and I got the error message  "EnvironmentBrowser.QueryConfigTarget" and didn't get the edit vm  settings windows. After that I tried to edit the settings of other VMs  and I always got this error message.

Some googling gave me the following KB article: 2006615

In  this article an inactive NFS datastore is the reason for raising the  error message. They actually recommend to unmount this stale NFS  datastore.

I simply started the NFS service on my server and after that I was able to edit the settings of my VMs.

In  my opinion this behaviour is very unpleasant. In my case I only lost an  uncritical datastore (only 2 VMs used that for their CDROM ISO images)  but now I am not able to edit the settings of ALL of my VMs.



Tags (2)
0 Kudos
0 Replies